Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


fants

30 posts

Geek


#92928 9-Nov-2011 09:35
Send private message

Hi all
I'm using iOS 5 on my 3GS and I've noticed when SMSing my friend who is on iOS 5 on a 4, that some times when he messages me I receive the message in my email??!!

Why does this occur and how can I stop it.

Thanks.

Create new topic
clicknz
426 posts

Ultimate Geek

Trusted

  #542982 9-Nov-2011 09:42
Send private message

Hi - not sure if it's the reason, but on your phone in settings > messages there is a 'receive at' option. Make sure your phone number is in there. It could be that when your friend starts the message and the options pop up for your name maybe they are tapping on your email address (if it's in their contacts)....




Cheers,
Mike

Photographer/Videographer clickmedia.nz


Batman
Mad Scientist
23051 posts

Uber Geek

Trusted
Lifetime subscriber

  #542985 9-Nov-2011 09:52
Send private message

i don't use it but look here: this will (should) solve your mystery

http://senseiphone.com/howto-activate-configure-imessage-ios-5-0921731/




Involuntary autocorrect in operation on mobile device. Apologies in advance.


 
 
 
 


Teeps
501 posts

Ultimate Geek


  #543004 9-Nov-2011 10:28
Send private message

fants: Hi all

I'm using iOS 5 on my 3GS and I've noticed when SMSing my friend who is on iOS 5 on a 4, that some times when he messages me I receive the message in my email??!!



Why does this occur and how can I stop it.



Thanks.


It is most likely to do with the CallerID setting. It's not documented well by Apple but I had problems getting my iMessages in sync between my iPhone and iPad but after changing the CallerID to the same email address on both it worked. If you just have an iPhone though you should be OK to keep it on your phone number, but if your friend sends to your email you'll still get the message anyway. There seems to be some inconsistencies after that as to whether it uses the email or phone number to send, I'm guessing it depends on if you're replying to a message or not. Think there a bit of room for improving how it handles this and hopefully Apple will update it in the future.

fants

30 posts

Geek


  #543033 9-Nov-2011 11:27
Send private message

ClickNZ - Hi - not sure if it's the reason, but on your phone in settings > messages there is a 'receive at' option. Make sure your phone number is in there. It could be that when your friend starts the message and the options pop up for your name maybe they are tapping on your email address (if it's in their contacts)....


Tried this but it doesn't let me delete or switch off the email address that is selected (i think that it uses your email address from your itunes)

joker97 - i don't use it but look here: this will (should) solve your mystery 

http://senseiphone.com/howto-activate-configure-imessage-ios-5-0921731/ 


Thanks for the link... all it did was freeze my macbook :(


Teeps - It is most likely to do with the CallerID setting. It's not documented well by Apple but I had problems getting my iMessages in sync between my iPhone and iPad but after changing the CallerID to the same email address on both it worked. If you just have an iPhone though you should be OK to keep it on your phone number, but if your friend sends to your email you'll still get the message anyway. There seems to be some inconsistencies after that as to whether it uses the email or phone number to send, I'm guessing it depends on if you're replying to a message or not. Think there a bit of room for improving how it handles this and hopefully Apple will update it in the future.


The only problem with this is that i don't check my emails every couple of minutes to check for new messages.


Thanks for all the replies.... anymore suggestions?



clicknz
426 posts

Ultimate Geek

Trusted

  #543040 9-Nov-2011 11:38
Send private message

Hi - odd that you don't seem to be able to add your phone number in the Messages settings. Perhaps you could ensure that your phone number is set as 'My Number' in the 'Phone' settings... and maybe check under the 'Mail, Contacts, calendar' setting to ensure that you've got your own contacts set up under the 'My Info' tab.
I'm not sure whether these will help, but worth a go...




Cheers,
Mike

Photographer/Videographer clickmedia.nz


Teeps
501 posts

Ultimate Geek


  #543042 9-Nov-2011 11:39
Send private message

fants: The only problem with this is that i don't check my emails every couple of minutes to check for new messages.


Sorry, I misunderstood you. You actually mean you get them as emails? Not an iMessage assigned to an email address?

If so, are you sure you're using iMessages and not SMS? are the messages you get from your friend that go to email ones with media attached (pictures etc)? If so sounds like he's sending them as MMS messages and you don't have MMS setup on your iPhone.

fants

30 posts

Geek


  #543532 10-Nov-2011 10:22
Send private message

Hi teeps

I have my phone number setup as I do mms and also under messaging i have "when I message is unavailable send as SMS" selected. I think what maybe happening is when it can't be sent as a iMessage it's sending it to my email instead. Why? I don't know.

 
 
 
 


quebec
658 posts

Ultimate Geek


  #545132 14-Nov-2011 13:04
Send private message

It has something to do with your phone number entered in the iPhone. Go to Settings-Phone and on top, do you see your phone number in My Number?

fants

30 posts

Geek


  #545406 14-Nov-2011 23:02
Send private message

Yes it's there.

Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS1621+ 
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.