Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


11 posts

Geek


Topic # 224227 8-Nov-2017 18:15
Send private message

Hey there :)  First time poster - please bare with me.

 

I've just received a new modem which came with Merlin firmware pre-installed (https://asuswrt.lostrealm.ca/). Slingshot is our internet provider, on Fibre 100/20.

 

Here's the issue: I just can't get the modem to connect to the internet. On the phone with Slingshot they said that they can't see any connection requests coming through, so my settings are definitely wrong somewhere. I have confirm that my PPP user and pass are correct (they work on the Netcom router supplied by Slingshot).

 

If you have Merlin firmware and connect with Slingshot, would you be willing to share your settings with me? 

 

I'd be super grateful for that, or any general help!

 

Thanks heaps for your time.

 

 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
4848 posts

Uber Geek
+1 received by user: 1507


  Reply # 1897712 8-Nov-2017 18:19
One person supports this post
Send private message

What settings have you used so far? Perhaps a screenshot of the settings page would be useful.


'That VDSL Cat'
7944 posts

Uber Geek
+1 received by user: 1628

Trusted
Spark
Subscriber

  Reply # 1897724 8-Nov-2017 18:42
Send private message

Post your settings.

 

 

 

i'd expect the issue is one of the following.

 

     

  1. Vlan tag not applied
  2. incorrect PPPoE Encapsulation
  3. Service name in PPPoE connection.

 

 

 

 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




11 posts

Geek


  Reply # 1897730 8-Nov-2017 19:09
Send private message

Hey! Thanks for the quick replies :) Here's a screenshot of the WAN settings: 

 

 

 

 

 


'That VDSL Cat'
7944 posts

Uber Geek
+1 received by user: 1628

Trusted
Spark
Subscriber

  Reply # 1897751 8-Nov-2017 19:43
Send private message

lan -> IPTV.

 

 

 

set the Internet VLAN to 10.

 

set the interface in dualwan to the VLAN'd interface.

 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




11 posts

Geek


  Reply # 1897868 8-Nov-2017 21:43
Send private message

I don't quite follow this. Are you saying to set the settings as in the screenshots?

 

 

 

 

 

hio77:

 

lan -> IPTV.

 

 

 

set the Internet VLAN to 10.

 

set the interface in dualwan to the VLAN'd interface.

 

 


'That VDSL Cat'
7944 posts

Uber Geek
+1 received by user: 1628

Trusted
Spark
Subscriber

  Reply # 1897893 8-Nov-2017 22:28
Send private message

Pretty sure the Primary WAN dropdown needs to be changed to the vlan10 interface.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




11 posts

Geek


  Reply # 1897912 8-Nov-2017 23:08
Send private message

hio77:

 

Pretty sure the Primary WAN dropdown needs to be changed to the vlan10 interface.

 

 

 

 

I don't seem to have that option :(...

 


26486 posts

Uber Geek
+1 received by user: 6036

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1897934 9-Nov-2017 07:14
One person supports this post
Send private message

Wht model router is it? It's always possible it's a model that doesn't support VLAN tagging in which case you'll need to buy something more suitable.

 

 




11 posts

Geek


  Reply # 1898023 9-Nov-2017 08:41
Send private message

Ahh bugger. 

 

Tenda AC18 is what I got: http://www.tendacn.com/en/product/AC18.html

 

It does mention VLAN for IPTV services in the user manual..

 

 

 

 


2077 posts

Uber Geek
+1 received by user: 215

Trusted
Subscriber

  Reply # 1898064 9-Nov-2017 09:00
Send private message

That first screenshot you posted above (the one after hio77’s reply), that’s what your settings need to be. Next to Internet you want VID 10 and PRIO 0 after you’ve chosen the manual setting. If your modem doesn’t have this option then it doesn’t do VLAN tagging and you won’t be able to connect.

You don’t need to have Dual WAN turned on, that’s just if Slingshot falls over and you have a backup connection, like a USB dongle for connecting to a mobile network.




MacBook Pro 13" w/ Touch Bar (Early 2017) | iPad Pro 10.5 Wi-Fi 128GB (Space Grey) | iPhone 8 Plus 64GB (Product RED) | HomePod (Space Grey) | Apple TV 4K | Apple TV (4th Generation) | Apple Watch Series 3 42mm (Space Grey)



11 posts

Geek


Reply # 1898231 9-Nov-2017 12:22
Send private message

Thanks. That's good to know :)

 

All those options are available to me (LAN -> IPTV -> Manual -> VID = 10), but it doesn't produce connection.

 

I did notice that under Tools, where it lists the Ethernet Ports it showed that WAN was set to VLAN 2 (even though I'd changed the IPTV settings). I did some searching and found a way to make the WAN port assigned to VLAN 10. I followed this here: https://www.snbforums.com/threads/vlans-on-merlin-mini-howto.20529/#post-205548

 

Which means the WAN port is now definitely set to VLAN 10:

 

 

 

 

 

 

But alas, still no connection.

 

I even tried manually adding Slingshot's WAN DNS settings (WAN -> WAN DNS Setting -> Connect to server automatically -> "NO"). No connection that way either.

 

 

 

So sad :(




11 posts

Geek


Reply # 1899365 11-Nov-2017 20:11
Send private message

Just cracked it today :) 

 

This article was super handy: https://www.dd-wrt.com/wiki/index.php/Switched_Ports

 

I had to SSH in and do this:

 

 

nvram set vlan10ports="0t 5u"

 

nvram set port5vlans="10"

 

nvram set vlan10hwname="et0"

 

nvram commit

 

reboot

 

 

 

 

And we're winning. Thanks for the help everyone!


'That VDSL Cat'
7944 posts

Uber Geek
+1 received by user: 1628

Trusted
Spark
Subscriber