Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


jjero

45 posts

Geek


#35692 14-Jun-2009 21:10
Send private message

First up I am using a Nova T 500, and I have installed the latest wintv 7 cd 1.1d from the hauppauge website. My system OS is windows 7 RC (7100)

When using Wintv 7, the picture shows on every channel but there is no audio on any of them.  I am using cyberlink h264 video codec and have tried various audio codecs to no avail.

When using windows media center the picture and audio work for the HD channels 1, 2 and 3. But for the rest of the channels the picture is black or green and pixelated - but audio comes through fine. I don't know how to check what video codec windows media center is using.

Does anyone know a solution to this problem?

EDIT: OK after restarting, wintv 7 won't even buffer any channel but windows media center is still as before.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3
Affiliate link
 
 
 

Affiliate link: Find your next Lenovo laptop, desktop, workstation or tablet now.
jjero

45 posts

Geek


  #225308 15-Jun-2009 17:56
Send private message

Bump. Can anyone help me troubleshoot this? I really don't know where to go from here. I'm OK with wintv 7 not working, and would like to just get the video working on wmc.

techo
46 posts

Geek


  #225327 15-Jun-2009 18:47
Send private message

jjero: First up I am using a Nova T 500, and I have installed the latest wintv 7 cd 1.1d from the hauppauge website. My system OS is windows 7 RC (7100)

When using Wintv 7, the picture shows on every channel but there is no audio on any of them.  I am using cyberlink h264 video codec and have tried various audio codecs to no avail.


NZ Freeview|HD uses an unusual audio format known as LATM-HE-AAC.  Win7 Windows Media Center natively supports this format.  However if you are using a 3rd party PVR application, it must be capable of detecting this audio format and splitting it out to a audio decoder that can decode this format.  GBPVR and MediaPortal support this format along with requiring an audio decoder that supports this format, eg Monogram AAC decoder http://blog.monogram.sk/janos/2009/03/08/monogram-aac-decoder-0960/

When using windows media center the picture and audio work for the HD channels 1, 2 and 3. But for the rest of the channels the picture is black or green and pixelated - but audio comes through fine. I don't know how to check what video codec windows media center is using.


This is a known issue on ATI video cards with the current Win7 Catalyst drivers.  I belive Nvidia video cards work ok.

jjero

45 posts

Geek


  #225340 15-Jun-2009 19:12
Send private message

Thank you so much for your reply. I do have an ATI card (HD 4850) and am using catalyst 9.5. That's a shame with wintv v7, I hope they add that support I think its a really nice and fast program. I am happy how far freeview has come along in terms of software support since last year when I gave up (got everything working on mediaportal back then but it was just too buggy!).



jjero

45 posts

Geek


  #225387 15-Jun-2009 21:30
Send private message

OK, I've just installed GBPVR and am using monogram AAC decoder. Picture is working on every channel, but there is no sound for every channel EXCEPT "TV3 (AC3)".

davidcole
5517 posts

Uber Geek

Trusted

  #225388 15-Jun-2009 21:42
Send private message

Doesn't sound like your monogram codec is not taking effect.

Have you registered it? regsvr32 mmaacd.ax

And then in the gbpvr config app have you set monogram as the aac and he-aac playback codecs






Previously known as psycik

OpenHAB: Gigabyte AMD A8 BrixOpenHAB with Aeotech ZWave Controller, Raspberry PI, Wemos D1 Mini, Zwave, Xiaomi Humidity and Temperature sensors
Media:Chromecast v2, ATV4 4k, ATV4, HDHomeRun Dual
Windows 10
Host Plex Server 3x3TB, 4x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 2xUbuntu 20.04 LTS, Backblaze Backups, 


jjero

45 posts

Geek


  #225391 15-Jun-2009 21:50
Send private message

For some reason I have had monogram already installed as it appeared on the drop down list in both wintv 7 and gbpvr before I tried to set this whole thing up (and yes I selected it in the config app as both aac and he-aac). But I think it may be an old version that must have been part of some pack that I must've installed a while back before the new LATM support was added. I have not been able to install the mmaacd.ax from the site mentioned, however.



I put mmaacd.ax into C:\windows\system32 but when I try to regsvr32 it the following happens:



regsvr32 c:\windows\system32\mmaacd.ax gives me this error message: The module "c:\windows\system32\mmaacd.ax" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary dependent .dll files.



regsvr32 mmaacd.ax gives me this error message: The module "mmaacd.ax" may not [be] compatible with the version of windows that you're running. Check if the module is compatible with an x86 (32-bit) or x64 (64-bit) version of regsvr32.exe. (By the way I'm running 64 bit windows 7)

EDIT: I also just tried running the commands under administrator rights but the error messages were the same.

davidcole
5517 posts

Uber Geek

Trusted

  #225478 16-Jun-2009 08:49
Send private message

ahh, yeah the 64bit windows wont help. I think there is a way of registering 32 bit stuff, or run it in compatibility mode. And you may want to take it out of system32 and stick it somewhere else and see if that helps.

I run 32bit xp




Previously known as psycik

OpenHAB: Gigabyte AMD A8 BrixOpenHAB with Aeotech ZWave Controller, Raspberry PI, Wemos D1 Mini, Zwave, Xiaomi Humidity and Temperature sensors
Media:Chromecast v2, ATV4 4k, ATV4, HDHomeRun Dual
Windows 10
Host Plex Server 3x3TB, 4x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 2xUbuntu 20.04 LTS, Backblaze Backups, 




jjero

45 posts

Geek


  #225698 16-Jun-2009 20:40
Send private message

It doesn't let me run in compatibility mode "compatibility modes cannot be set on this program because it is part of this version of windows"

and If i try stick it somewhere else it says "The module d:\mmaacdx.ax was loaded but the call to DllRegisterServer failed with error code 0x800700005. For more information about this problem, search online using the error code as a search term"

Searching the error code doesn't help.

I guess there is still some work to do for freeview compatibility across the board with PCs.

jjero

45 posts

Geek


  #225703 16-Jun-2009 21:23
Send private message

catalyst driver version 9.6 just came out but I still have the same problem with WMC after installing it. Are ATI even aware of the problem? It's not even listed on the releaselog's known issues section.

jbmoocs
91 posts

Master Geek


  #227929 24-Jun-2009 12:40
Send private message

davidcole: ahh, yeah the 64bit windows wont help. I think there is a way of registering 32 bit stuff, or run it in compatibility mode. And you may want to take it out of system32 and stick it somewhere else and see if that helps.



I run 32bit xp



Hi someone might want to know this. I purchased wintv7 HD software from the UK it cost under NZ$50 but seems to be much more user friendly than powercinema which is not so flash with vista x64. It is bundled with all the codecs h.264 & the LATM-HE-AAC codec.  Users have to buy it or you will not get the audio support required - That's not hauppage's fault those codecs cost money. It's pretty good, click it and the TV starts - no fiddly navigation panel. BTW I have the nova t500 and the sound quality from all but C3 sounds really crappy, is that due to the tv card or the broadcast?

jjero

45 posts

Geek


  #228031 24-Jun-2009 17:14
Send private message

Does anyone sell the software in New Zealand? Or is there anywhere to buy the audio decoder online?

jbmoocs
91 posts

Master Geek


  #228032 24-Jun-2009 17:27
Send private message

jjero: Does anyone sell the software in New Zealand? Or is there anywhere to buy the audio decoder online?



The only thing I am aware of is that wintv v7 HD is shipping with certain TV cards as a bundle here in NZ.
I rocked onto the hauppage site & payed by paypal to get the CD.
I am not aware whether you can get the audio decoder downloads, (that would be too easy!)


jjero

45 posts

Geek


  #228049 24-Jun-2009 18:15
Send private message

Is it this?

http://www.hauppauge.eu/boutique_us/liste_produits.cfm?type=5&code_lg=lg_us&num=0

Might consider this...13.98 euro excluding VAT...that's quite reasonable actually.

jbmoocs
91 posts

Master Geek


  #228058 24-Jun-2009 18:46
Send private message

jjero:G Is it this?



http://www.hauppauge.eu/boutique_us/liste_produits.cfm?type=5&code_lg=lg_us&num=0



Might consider this...13.98 euro excluding VAT...that's quite reasonable actually.




Yes that's it, its worthwhile I thought. But IMHO there is still a way to go with HDTV on the PC. Would prefer it to be supported with media centre vista x64 native. (my wish)

simplestuff
84 posts

Master Geek


  #228066 24-Jun-2009 19:14
Send private message

Simplest solution in my opinion is Windows 7 version 7137 or later finds the Nova T 500 and all required without any add on Just setup Media centre and everything works.  Then get Bigscreen Epg register and setup and evrything goes 14 days Epg Hd etc. 

 1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic





News and reviews »

D-Link G415 4G Smart Router Review
Posted 27-Jun-2022 17:24


New Zealand Video Game Sales Reaches $540 Million
Posted 26-Jun-2022 14:49


Github Copilot Generally Available to All Developers
Posted 26-Jun-2022 14:37


Logitech G Introduces the New Astro A10 Headset
Posted 26-Jun-2022 14:20


Fitbit introduces Sleep Profiles
Posted 26-Jun-2022 14:11


Synology Introduces FlashStation FS3410
Posted 26-Jun-2022 14:04


Intel Arc A380 Graphics First Available in China
Posted 15-Jun-2022 17:08


JBL Introduces PartyBox Encore Essential Speaker
Posted 15-Jun-2022 17:05


New TVNZ+ streaming brand launches
Posted 13-Jun-2022 08:35


Chromecast With Google TV Review
Posted 10-Jun-2022 17:10


Xbox Gaming on Your Samsung Smart TV No Console Required
Posted 10-Jun-2022 00:01


Xbox Cloud Gaming Now Available in New Zealand
Posted 10-Jun-2022 00:01


HP Envy Inspire 7900e Review
Posted 9-Jun-2022 20:31


Philips Hue Starter Kit Review
Posted 4-Jun-2022 11:10


Sony Expands Its Wireless Speaker X-series Range
Posted 4-Jun-2022 10:25









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.