Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




150 posts

Master Geek


# 42419 5-Oct-2009 09:03
Send private message

Here is my bizarre issue.
Brand new Dell R710 server with Server 2008 Standard preinstalled.  Added Terminal Services, joined to our domain.

RDP users are unable to add local printers.

Using a single user as a test, I added the user to the local security policy: "Load and unload device drivers" and run gpupdate /force - this alone should fix the problem.  It does not, I still recieve a permission error.

Just as a test, I add the specific user to the local administrators group.  Still get the permission error.

There is no domain policy being handed down - can prove with a gpresult report if you wish.

What the hell is going on?  If I log on to the server as the local administrator account with an RDP connection it works fine, but I cannot get any other user to be able to add local printers no matter how much access I grant them.

Create new topic


150 posts

Master Geek


  # 261067 5-Oct-2009 09:06
Send private message

I cannot bring up the add local printer GUI at all, if I try to add the printer using the command line internface with rundll32 I receive the error:

"You do not have permission to modify the setting for this printer. If you need to change the settings, contact your system administrator."

xpd

Chief Trash Bandit
9939 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  # 261071 5-Oct-2009 09:23
Send private message

Users accessing Win 2008 Server over RDP wanting to use their local printers require latest ServicePacks and .NetFramework 3.0+ - this allows the "easyPrint" feature to work.

We use it here and our systems run a lot happier without having 200 different printer drivers installed :)




XPD / Gavin / DemiseNZ

 

Server : i5-3470s @ 3.50GHz  16GB RAM  Win 10 Pro    Workstation : i5-3570K @ 3.40GHz  20GB RAM  RX580 4GB Win 10 Pro    Console : Xbox One

 

https://www.xpd.co.nz - Games, emulation, geekery, and my attempts at photography.     Now on BigPipe 100/100 and 2Talk

 

Emulation - The art of getting your $4000 PC to run an 80's system - and still fails.

 

Add me on Steam


 
 
 
 




150 posts

Master Geek


  # 261072 5-Oct-2009 09:25
Send private message

Same issue from XP, Vista, Win 7 or a thin client.

In fact even just logging in locally to the server as another user has the same result.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35


Amazon Studios announces New Zealand as location for its upcoming series based on The Lord of the Rings
Posted 18-Sep-2019 17:24


The Warehouse chooses Elasticsearch service
Posted 18-Sep-2019 13:55


Voyager upgrades core network to 100Gbit
Posted 18-Sep-2019 13:52


Streaming service Acorn TV launches in New Zealand with selection with British shows
Posted 18-Sep-2019 08:55


Bitcoin.com announces partnership with smartphone manufacturer HTC
Posted 16-Sep-2019 21:30


Finalists Announced for Microsoft NZ Partner Awards
Posted 16-Sep-2019 19:37


OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.