Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


networkn

23460 posts

Uber Geek

Trusted
Lifetime subscriber

#92136 27-Oct-2011 15:16
Send private message

Hi There!

I have a customer running Premier 19.5 in a peer to peer shared between 2 people.

Everything is fine, EXCEPT that running any report even small reports, takes 6 minutes IF a second person is in the file.

Does anyone know how I can get around that ?
 

Create new topic
jaymz
1096 posts

Uber Geek


  #543198 9-Nov-2011 16:02
Send private message

We had the EXACT issue with a client a few months back.

I will try find out what the fix was in the end, i know there was a lot of pissing around to find the cause.

networkn

23460 posts

Uber Geek

Trusted
Lifetime subscriber

  #543199 9-Nov-2011 16:03
Send private message

jaymz: We had the EXACT issue with a client a few months back.

I will try find out what the fix was in the end, i know there was a lot of pissing around to find the cause.


I'd be greatly appreciative of anything you can suggest!
 

 
 
 
 


cyril7
7846 posts

Uber Geek

Trusted
Subscriber

  #543207 9-Nov-2011 16:14
Send private message

Hi, not too sure if the problem is the same as yours but I have found its better to run both sessions on a single PC and have the remote user RDP or VNC into the machine. It seems MYOB does pretty basic file sharing, once the main account file gets largish it turns turtle.


Cyril

jaymz
1096 posts

Uber Geek


  #543216 9-Nov-2011 16:31
Send private message

cyril7: Hi, not too sure if the problem is the same as yours but I have found its better to run both sessions on a single PC and have the remote user RDP or VNC into the machine. It seems MYOB does pretty basic file sharing, once the main account file gets largish it turns turtle.


Cyril


Yeah that was the "fix" that was suggested by MYOB to us, we told them to p!ss off. IMO that is NOT a fix, only a work around.  

The issue occured only when we moved them from a XP workgroup to a Win2008 Win7 environment.

Here is something to try:

In MYOB:
Deselect certain preferences

Complete the following steps to ensure the following preferences are deseleted, i.e. not activated:

1.     Go to the Setup menu and choose Preferences.

2.     Ensure the following preferences are deselected:
  • "Warn for duplicate cheque numbers" (Banking tab)
  • "Warn for duplicate invoice numbers on recorded invoices" (Sales tab)
  • "Warn for duplicate Purchase Order numbers on recorded purchases" (Purchasing tab)
  • "Automatically refresh lists when information changes" (System tab)
  • "Use Easy-Fill When Selecting From a List" (Windows tab)
 
If you are using Windows 2008 or Windows 7 try disable SMB 2.0
http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

and try modify the TCP/IP tuning:

TCP Auto-Tuning

To turn off the default RWIN auto tuning behavior, (in elevated command prompt) type:
netsh int tcp set global autotuninglevel=disabled
The default auto-tuning level is "normal", and the possible settings for the above command are:
disabled: uses a fixed value for the tcp receive window. Limits it to 64KB (limited at 65535).
highlyrestricted: allows the receive window to grow beyond its default value, very conservatively
restricted: somewhat restricted growth of the tcp receive window beyond its default value
normal: default value, allows the receive window to grow to accommodate most conditions
experimental: allows the receive window to grow to accommodate extreme scenarios (not recommended, it can degrade performance in common scenarios, only intended for research purposes. It enables RWIN values of over 16 MB)
Our recommendation: highlyrestricted

I am still to find out what the fix was, but once i do i will post it here. But try the above first. 
 

Regs
4062 posts

Uber Geek

Trusted
Snowflake

  #543268 9-Nov-2011 18:37
Send private message

we've been putting up with poor MYOB multi-user peformance for years. been through several desktop OS's from '95 through win7/win2k8r2, and several domain setups from workgroups to win nt4, win 2k, win2k8 domains.

we've tried a bunch of settings changes, network changes, hosted on shares, SANs, all to no avail.

basically,standard operating procedure is that we boot out the multiple users and run in single user mode when we need to do anything like that




cyril7
7846 posts

Uber Geek

Trusted
Subscriber

  #543276 9-Nov-2011 19:03
Send private message

I have had a few clients recently who once I have shown them xero took little time to move on, and they have never looked back, MYOB is a product that needs to evaluate its market.

Cyril

jaymz
1096 posts

Uber Geek


  #545136 14-Nov-2011 13:10
Send private message

Just confirmed that the fix was a mixture of performance tweaks for Windows Server 2008.

These included:

Disabling power management for the NIC
Updating the NIC to latest drivers (broadcom in this instance)
Set auto-tuning to Highly restrictive

Have you managed to try any of the above fixes yet? Are you able to confirm the version of windows installed on each computer?

Create new topic





News »

NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.