Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

74 posts

Master Geek

#112046 24-Nov-2012 10:40
Send private message

It seems from Wednesday, I've strangely lost my ability to download apps from the Google Play using my Motorola Defy+ (MB526) through my WiFi Connection at home (Using Telecom Broadband).
I can browse the Google Play store okay on the phone. But trying to install or update apps will result in the download status bar becoming stuck perpetually on "Downloading..."
Power cycled Router (DrayTek Vigor 2700) and wireless access point (TP-LInk TL-WR1043ND), several times. Went in and checked both devices to see if there was a block on them. (Specifically Port 5222-5228), Disabled the firewall. All to no avail. I don't recall changing any of the settings on either of devices for months.
Even went to hard reset the Phone. Again to no avail.
Apps seem to download okay over the Vodafone Mobile Data connection. All over apps seem to be working fine over my WiFi, including Gmail, Google Talk, Youtube and maps.

Anyone ever experienced similar? Is there perhaps someway to easily test where along the route that port 5228 is getting blocked or messed with?

Many Thanks.

Filter this topic showing only the reply marked as answer Create new topic
2653 posts

Uber Geek

  #722202 24-Nov-2012 10:42
Send private message

Is your memory full?

Edit: Never mind just read they download fine over Vodafone.

368 posts

Ultimate Geek

  #722249 24-Nov-2012 12:24
Send private message

And if you use a web browser (firefox,Chrome etc) on a desktop PC or Windows 7/8 Notebook, log into Google Play, then selecting your device and download an application using your existing telecom NZ broadband.

What happens then????

You SHOULD see a download icon appear on your phone and the application should be installed on your phone. This is just a way of doing a remote application install on your phone. Make sure you have your Telecom Network acces available and Vodafone Data disabled for this test.

This doesn't fix anything it's just a check to see if you can download something to your phone via Telecom Broadband from Google Play.

Again this probably wont help, but another tick off the list.
Reset data and cache structures within Google Play on your Android phone.

In settings go to applications.
Select all applications and scroll down to Google Play Store.
Force stop Google Play. Clear the cache. Do NOT clear the data.
Force stop Google Service Framework. Clear Data.
Exit Google Play Store.
Reboot your phone.
Access Google Play Store again.

It'll probably go through the except policy thing again, but your account, apps and details will remain.

This just resets Google Play and clears it data/cache files.

Other than that, if you've rest/cleared your own network devices, then it's possibly a proxy/caching server somewhere.

Can a 'mate' download an app via your network on their Android phone?????

You can install Android x86 on a PC and use the same account and if that can download an app via Telecom NZ.....???

Is it all Google Play Store downloads that don't work for you via Telecom broadband or is it just one application that won't download.

It's not a wholesale Telecom NZ problem as I'm fine Jake [smiley face]. And I have over 5 different Android systems connected via Telecom NZ Broadband.


20 posts


  #722436 24-Nov-2012 21:56
Send private message

I had the same issue, and tried virtually everything that has been recommended above, eventually gave up as I could download / update on other wifi points other than mine.

What fixed it was resetting my wifi router back to it's factory state (and setting it up from scratch again). I was very surprised when my phone started updating!

74 posts

Master Geek

  #722439 24-Nov-2012 22:07
Send private message

Many Thanks for eveyone's replies.

So far managed to track it down to my router. Swapped out the Draytek for with my elderly ADSL1 Dynalink 300U and the apps started downloading. I wouldn't have the foggiest clue as to what may have changed on the Draytek in the last few days. I reinstated the Draytek, Reset it back to factory settings, re-entered the Telecom Broadband login information but it still wouldn't allow the apps to be downloaded.

To be continued, I guess.

368 posts

Ultimate Geek

  #722446 24-Nov-2012 22:18
Send private message

I have heard of DHCP doing daft things on an Android phone. You may be blaming your network devices even when the ARP caches have been cleared and all existing DHCP leases have been deleted for the short comings of your Android phone.

Some times just a 'forget' on the existing WiFi connection on the phone and just bullishly assigning a static WiFi IP address connection can correct some wrongs. But it's not always the answer.

74 posts

Master Geek

  #731062 12-Dec-2012 08:09
Send private message

Just an exceedingly late update to this (better late than never I guess on my part!!)... Looked like it was down to some weird DNS issue. I had forced the DrayTek router to use Google's DNS server and the issue went away. Would Hazard a guess that some DNS changes weren't propagating which might go some way to explained why for many people (who were experiencing the same issue that I was) it resolved itself in a few days/weeks.

Again, thanks to everyone for their assistance.

Filter this topic showing only the reply marked as answer Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Intel introduces 10th Gen Intel Core H-series for mobile devices
Posted 2-Apr-2020 21:09

COVID-19: new charitable initiative to fund remote monitoring for at-risk patients
Posted 2-Apr-2020 11:07

Huawei introduces the P40 Series of Android-based smartphones
Posted 31-Mar-2020 17:03

Samsung Galaxy Z Flip now available for pre-order in New Zealand
Posted 31-Mar-2020 16:39

New online learning platform for kids stuck at home during COVID-19 lockdown
Posted 26-Mar-2020 21:35

New 5G Nokia smartphone unveiled as portfolio expands
Posted 26-Mar-2020 17:11

D-Link ANZ launches wireless AC1200 4G LTE router
Posted 26-Mar-2020 16:32

Ring introduces two new video doorbells and new pre-roll technology
Posted 17-Mar-2020 16:59

OPPO uncovers flagship Find X2 Pro smartphone
Posted 17-Mar-2020 16:54

D-Link COVR-2202 mesh Wi-Fi system now protected by McAfee
Posted 17-Mar-2020 16:00

Spark Sport opens its platform up to all New Zealanders at no charge
Posted 17-Mar-2020 10:04

Spark launches 5G Starter Fund
Posted 8-Mar-2020 19:19

TRENDnet launches high-performance WiFi Mesh Router System
Posted 5-Mar-2020 08:48

Sony boosts full-frame lens line-up with introduction of FE 20mm F1.8 G large-aperture ultra-wide-angle prime Lens
Posted 5-Mar-2020 08:44

Vector and Spark teamed up on smart metering initiative
Posted 5-Mar-2020 08:42

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.