Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1618 posts

Uber Geek
+1 received by user: 236


Topic # 160548 11-Jan-2015 11:50
Send private message

I've been trying to root my old S3 so I can play around with a few things but so far I've been unsuccessful.

It's a 2 Degrees model, currently running Android 4.3 stock (which I believe is the latest version from 2 Degrees).  And I've got USB Debugging turned on.

I first started by trying the latest version of Kingo Root (version 1.3.0).  That seemed to be doing something but would loop around saying "Downloading requisite files", "Checking root", "Waiting for device" and doing that over and over for about 5 minutes before my phone would reboot itself (at this point Kingo Root didn't mention anything about rebooting the phone).  After restarting my phone would just sit there even though it was still connected to my PC and Kingo Root was still showing that it was connected but "Waiting for device".  I had to close Kingo Root and restart it and then it would go through the whole process again.  I did the a total of five times before giving up (sometimes a message would pop up on my phone saying that a certain program was trying to run but that Google advised against it, but I let the program run because I thought it was part of the rooting process).

After some Googling someone said that he couldn't get the latest version of Kingo Root to work but that an old version, V1.1.0, did work for him, so I downloaded that version and tried that.  This time it was very different, with my phone downloading something from my PC and then the phone rebooting and some sort of rooting program starting with lots of text scrolling up the screen.  My phone then rebooted again and started up normally.  The Kingo Root program on my PC said it had finished but Root Check said that my phone still wasn't rooted and now I had half a dozen apps on my phone with strange names in Chinese characters.  I removed those apps and my phone seems to be working ok (hope it didn't install anything nasty, running Malwarebytes now).

So what do I do now? Is Samsung Knox stopping me? Is Know even on my phone, how do I tell?!?

I'd prefer some sort of one-click and let it do it's thing rather than too much fiddling around. I have no experience with Odin and don't have the Android SDK installed.

Create new topic
708 posts

Ultimate Geek
+1 received by user: 104


  Reply # 1211942 11-Jan-2015 14:20
Send private message

Have a look here http://forum.xda-developers.com/galaxy-s3/general/howto-rooting-wiping-flashing-ultimate-t1911726

14507 posts

Uber Geek
+1 received by user: 2669

Trusted
Subscriber

  Reply # 1211957 11-Jan-2015 16:06
Send private message

Try CF Auto Root.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


 
 
 
 




1618 posts

Uber Geek
+1 received by user: 236


  Reply # 1211996 11-Jan-2015 18:16
Send private message

Thanks guys I'll give those a try and report back tomorrow.



1618 posts

Uber Geek
+1 received by user: 236


  Reply # 1212621 12-Jan-2015 15:55
Send private message

Well that could have gone easier!

I used CF Auto Root and the first time I tried it failed.  The instructions didn't say what to do when the phone rebooted, so I unplugged it from my computer.  On the second attempt I noticed that after Odin had done it's stuff and rebooted the phone, the Start and Exit buttons were still greyed out, indicating that it hadn't finished.  So I left the phone plugged in and eventually Odin finished whatever it was doing and said "Pass" and the buttons un-greyed.

But now everything seems to be working ok with root access.

Create new topic


Donate via Givealittle


Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon introduces new Kindle with adjustable front light
Posted 21-Mar-2019 20:14


A call from the companies providing internet access for the great majority of New Zealanders, to the companies with the greatest influence over social media content
Posted 19-Mar-2019 15:21


Two e-scooter companies selected for Wellington trial
Posted 15-Mar-2019 17:33


GeForce GTX 1660 available now
Posted 15-Mar-2019 08:47


Artificial Intelligence to double the rate of innovation in New Zealand by 2021
Posted 13-Mar-2019 14:47


LG demonstrates smart home concepts at LG InnoFest
Posted 13-Mar-2019 14:45


New Zealanders buying more expensive smartphones
Posted 11-Mar-2019 09:52


2degrees Offers Amazon Prime Video to Broadband Customers
Posted 8-Mar-2019 14:10


D-Link ANZ launches D-Fend AC2600 Wi-Fi Router Protected by McAfee
Posted 7-Mar-2019 11:09


Slingshot commissions celebrities to design new modems
Posted 5-Mar-2019 08:58


Symantec Annual Threat Report reveals more ambitious, destructive and stealthy attacks
Posted 28-Feb-2019 10:14


FUJIFILM launches high performing X-T30
Posted 28-Feb-2019 09:40


Netflix is killing content piracy says research
Posted 28-Feb-2019 09:33


Trend Micro finds shifting threats require kiwis to rethink security priorities
Posted 28-Feb-2019 09:27


Mainfreight uses Spark IoT Asset Tracking service
Posted 28-Feb-2019 09:25



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.