Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




80 posts

Master Geek


Topic # 161789 19-Jan-2015 21:38
Send private message

Hi Guys ,
            I have been setting up a friends S5 Mini for them and have struct a strange problem and I was wondering if anyone can shead some light on it for me please .The issue is I have set up a email app { K9 Mail } to send and receive their email from their email client { Clear ... AKA Vodafone } via pop3 and smtp the problem is K9 mail works on the 3G/4G network sending and receiving fine however when the phone is connected to a WiFi network it will not send emails ...... I have read a little on this about the ISP blocking port 25 is this correct ? is there a fix for this ? 

here are the details ...

Samsung S5 Mini on android 4.4.2 
ISP email client is Clear.net.nz .... now supplied by Vodafone 
Cell phone provider is 2degrees 

Things I have tried .... 

1/ smtp.clear.net.nz ......... Doesnt work on wifi or 3G/4G no auth required 

2/ smtp.2degreesmobile.net.nz ........ Doesnt Work on Wifi No Auth 

As a side my set up on the same app with a S4 works fine .... my cell provider is 2 degrees and my ISP is snap my email is set up via pop and SMTP and all works fine on both 3G/$G and Wifi 


Thanks guys in advance for any help 

cheers
Andrew w

Create new topic
537 posts

Ultimate Geek
+1 received by user: 37


  Reply # 1217919 19-Jan-2015 22:06
Send private message

The problem is that neither the isp or 2degrees will allow a device not connected to their network to use their smtp server without authentication (this is to try and stop spam).  As far as I know there is no clear server with authentication.

The easiest workaround is probably to set up a gmail account (or Outlook.com, etc) and get that collecting the email from the clear account, and then set up the phone to use that gmail account.  Gmail has got authentication so will work whether you are on 3G or wifi.



80 posts

Master Geek


  Reply # 1217923 19-Jan-2015 22:16
Send private message

Awesome thank you for the reply ...... The user already has a gmail account but would prefer that all outgoing mail is sent from there ISP email address { they work for themselves and all their email correspondence is via their ISP } Gmail is not a very professional look for an email address for clients . 

I have tried using authorization and non Autho and both dont seem to work .

 
 
 
 


21620 posts

Uber Geek
+1 received by user: 4432

Trusted
Subscriber

  Reply # 1217937 19-Jan-2015 22:49
One person supports this post
Send private message

If they are using it for business then I would say that a clear email address is even less professional than a gmail one. Tell them to get a domain and appropriate hosting for what they need.




Richard rich.ms

5290 posts

Uber Geek
+1 received by user: 2318

Trusted
Lifetime subscriber

  Reply # 1217941 19-Jan-2015 22:51
Send private message

An ISP email address is an even less professional look than Gmail for a business. Get a domain name and use Office 365.





Chorus has spent $1.4 billion on making their xDSL broadband network faster. If your still stuck on ADSL or VDSL, why not spend from $150 on a master filter install to make sure you are getting the most out of your connection?
I install - Naked DSL, DSL Master Splitters, VoIP, data cabling and general computer support for home and small business.
Rural Broadband RBI installer for Ultimate Broadband and Full Flavour

 

Need help in Auckland, Waikato or BoP? Click my email button, or email me direct: [my user name] at geekzonemail dot com


5290 posts

Uber Geek
+1 received by user: 2318

Trusted
Lifetime subscriber

  Reply # 1217942 19-Jan-2015 22:52
Send private message

Ha, snap @richms :)




Chorus has spent $1.4 billion on making their xDSL broadband network faster. If your still stuck on ADSL or VDSL, why not spend from $150 on a master filter install to make sure you are getting the most out of your connection?
I install - Naked DSL, DSL Master Splitters, VoIP, data cabling and general computer support for home and small business.
Rural Broadband RBI installer for Ultimate Broadband and Full Flavour

 

Need help in Auckland, Waikato or BoP? Click my email button, or email me direct: [my user name] at geekzonemail dot com




80 posts

Master Geek


  Reply # 1217947 19-Jan-2015 22:59
Send private message

thanks guys for the replies .


339 posts

Ultimate Geek
+1 received by user: 30

Lifetime subscriber

  Reply # 1217984 20-Jan-2015 08:21
Send private message

veryshort: Hi Guys ,
            I have been setting up a friends S5 Mini for them and have struct a strange problem and I was wondering if anyone can shead some light on it for me please .The issue is I have set up a email app { K9 Mail } to send and receive their email from their email client { Clear ... AKA Vodafone } via pop3 and smtp the problem is K9 mail works on the 3G/4G network sending and receiving fine however when the phone is connected to a WiFi network it will not send emails ...... I have read a little on this about the ISP blocking port 25 is this correct ? is there a fix for this ? 

here are the details ...

Samsung S5 Mini on android 4.4.2 
ISP email client is Clear.net.nz .... now supplied by Vodafone 
Cell phone provider is 2degrees 

Things I have tried .... 

1/ smtp.clear.net.nz ......... Doesnt work on wifi or 3G/4G no auth required 

2/ smtp.2degreesmobile.net.nz ........ Doesnt Work on Wifi No Auth 

As a side my set up on the same app with a S4 works fine .... my cell provider is 2 degrees and my ISP is snap my email is set up via pop and SMTP and all works fine on both 3G/$G and Wifi 


The symptoms are consistent with login security being needed when not directly connected to the Clearnet network.

Have you tried the following (on the smtp server settings, should work regardless of how you connect) in the K9 smtp server settings:

a) Enable 'login required' with the appropriate usercode and password.
b) Use port 587.

Most ISPs support this.  There may be some help on the Clearnet website but this requires a customer login to access.



80 posts

Master Geek


  Reply # 1218003 20-Jan-2015 08:40
Send private message

Thanks for your reply i have just tried the above option and it still wont connect via wifi .

Cheers



80 posts

Master Geek


  Reply # 1218006 20-Jan-2015 08:42
Send private message

I have also just tried the above fix on 3g/4g and the sending is now not working however when i disable the authorization and use port 25 it works on 3g/4g but not wifi .again thanks all for the suggestions

Banana?
4517 posts

Uber Geek
+1 received by user: 1080

Subscriber

  Reply # 1218012 20-Jan-2015 08:52
Send private message

If you must use the ISP email, setup a yahoo email address, and add the ISP address to the allowed email addresses, and use Yahoo's secure SMTP servers as the SMTP server.
You can do the same with Gmail, but last time I tried, the senders address got changed to user@gmail.com on behalf of user@isp.co.nz, which was even less ideal.

1597 posts

Uber Geek
+1 received by user: 369


  Reply # 1219161 21-Jan-2015 14:42
Send private message

setup info here
https://help.vodafone.co.nz/app/answers/detail/a_id/19567

Clear & Paradise, being old systems they probly dont care about, may not allow roaming access to smtp.
Im pretty sure paradise email  doesnt allow it.
Looks clear smtp is stuck with port 25. Some ISPs simply block that port by default .

Time to move on to a email system not stuck in last century .
(I know that comment doesnt help you)



80 posts

Master Geek


  Reply # 1219169 21-Jan-2015 14:47
Send private message

Thanks for the reply yes i thinks its time they moved isp's

257 posts

Ultimate Geek
+1 received by user: 27


  Reply # 1219200 21-Jan-2015 15:11
Send private message

Hi Have you tried using the SMTP server smtp2.vodafone.net.nz and ticking require signin. It also important that the username is the full email address  rather then just the name.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.