Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

Topic # 230258 15-Feb-2018 14:41
Send private message

The background to this is my hardware is a samsung J1 running Android 5.1.1.  This was originally sourced from 2D but now I am with Orcon (Spark?).  For some time now I have had WIFI switched off as I do not use all of my monthly data allowance most of the time and I have so much rollover data some expires from time to time.  Moving to Orcon though, the rollover data was lost and I turned on WIFI to minimise data use over the first few months.


The problem I have is that if I power up at home, the handset connects via WIFI and GMAIL and LOGMATE (commercial driver logbook app) work OK.  Leave home though and the WIFI symbol is replaced by the 4g symbol so mobile data appears to be working.  Fire up GMAIL again though and sync fails.  Head back home and GMAIL syncs OK.  Chrome always works (or appears to).  For the LOGMATE app I can force it to stop then run it again and it comes up as 'online'.


My exposure to android and data networks is basic but as I understand it swapping from WIFI to mobile data involves an IP address change but I would have thought that apps should be able to deal with this.  Google search gave no specific results but this problem is difficult for a non-tech such as myself to use the right search words.  I am aware that the J1 is an entry-level device and would contemplate upgrading if there is credible evidence that this would alleviate or fix the ssue.


Any pointers appreciated.





--

OldGeek.

Create new topic
26470 posts

Uber Geek
+1 received by user: 6025

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1958641 15-Feb-2018 15:25
Send private message

Does any data at all work via 4G? If not have you updated your APN list when you changed providers?

 

 

 

 




306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

  Reply # 1958737 15-Feb-2018 19:01
Send private message

Yes I have mobile data working.  All apps work on WIFI and mobile data, but a change (from WIFI to mobile data and vice versa) causes the GMAP to fail to sync and LOGMATE to report 'no data connection available - offline'.


387 posts

Ultimate Geek
+1 received by user: 183


  Reply # 1958761 15-Feb-2018 19:38
Send private message


306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

  Reply # 1958785 15-Feb-2018 20:36
Send private message

Thanks for that.  I turned on Developer Mode and enabled this option.  I will report back.


387 posts

Ultimate Geek
+1 received by user: 183


  Reply # 1959731 17-Feb-2018 21:20
Send private message

Any luck OldGeek?


387 posts

Ultimate Geek
+1 received by user: 183


  Reply # 1959732 17-Feb-2018 21:20
Send private message

Any luck OldGeek?




306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

  Reply # 1959743 17-Feb-2018 22:39
Send private message

Will know tomorrow when I am away from home.


183 posts

Master Geek
+1 received by user: 9

Trusted

  Reply # 1959753 17-Feb-2018 23:16
Send private message

When you leave home i take it like most you  don't turn off the wifi on the phone, and once out of range from you modem at home you see the 4G appear on the phone

 

 

 

- when the device is in this not working 100% for data state have you tried restarting the phone............does that change anything

 

- have you  tried turning off wifi on the phone while @ home, , then turn the phone off for 10 seconds turning it back on to see if things work as should




306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

  Reply # 1961077 20-Feb-2018 15:46
Send private message

NZFINEST:

 

When you leave home i take it like most you  don't turn off the wifi on the phone, and once out of range from you modem at home you see the 4G appear on the phone

 

 

 

- when the device is in this not working 100% for data state have you tried restarting the phone............does that change anything

 

- have you  tried turning off wifi on the phone while @ home, , then turn the phone off for 10 seconds turning it back on to see if things work as should

 

 

 

 

Yep - tried a lot of combinations of power cycling, wifi of-on etc.  None have made any difference.




306 posts

Ultimate Geek
+1 received by user: 25

Subscriber

  Reply # 1961079 20-Feb-2018 15:49
Send private message

tehgerbil:

 

Perhaps try enabling "Aggresive wifi to cellular handover"?

 

https://android.stackexchange.com/questions/90250/what-does-the-aggressive-wi-fi-to-cellular-handover-option-in-developer-settin/91462 

 

 

I ran with this for a few days - the problem persists.  So I have now turned Developer Options off.

 

So there is no solution in sight.


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.