Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


1258 posts

Uber Geek
+1 received by user: 20


Topic # 230620 5-Mar-2018 19:26
Send private message

I have had installed a JVC KW-V930BW head unit which works fine except that Android Auto is not using the attached microphone plugged into the unit, instead it is using the phone's speaker. I have conformed this by placing a pillow over the phone laughing, at this stage it will no longer respond to my "hey google" command.

 

I suppose that the options are to try another mic but that would mean taking it back to the installer of the head unit who is quite a distance from me. He said he definitely remembered connecting the mic but who knows.

 

It is entirely possible I have not set something correctly on the phone or the head unit but nothing is jumping out at me.

 

Anyone know if there is some special thing I need to do to activate the mic?


Create new topic
2777 posts

Uber Geek
+1 received by user: 291


  Reply # 1968422 5-Mar-2018 19:51
Send private message

Check the google settings, there may be a flag for use alternate method for bluetooth audio if not working as expected on my Moto. 

 

In general the first command I give is handset only, and that initialises the BT input on the factory radio for the external mic. But most the time the onboard (handset) is used for anything other than phone calls. Just how it seems to be




1258 posts

Uber Geek
+1 received by user: 20


  Reply # 1968436 5-Mar-2018 20:02
Send private message

The bluetooth connect setting on the phone for the headset show Phone Calls, Media Audio, HD Audio, Input Device and Contact Sharing as all being on.


368 posts

Ultimate Geek
+1 received by user: 36


  Reply # 1968866 6-Mar-2018 12:58
Send private message

What make and model is the Phone.




1258 posts

Uber Geek
+1 received by user: 20


  Reply # 1968928 6-Mar-2018 14:14
Send private message

Google Pixel XL

583 posts

Ultimate Geek
+1 received by user: 47


  Reply # 1970206 6-Mar-2018 21:48
Send private message

Try going into Settings > Google > Search > Voice and check if the option is enabled to record audio through the Bluetooth headset. I know it helps with regular headsets, so hopefully it helps with the car audio too.

2777 posts

Uber Geek
+1 received by user: 291


  Reply # 1970208 6-Mar-2018 21:51
Send private message

^^ thats what I was getting at. I couldn't remember where it was hidden away.

 

 

 

(Moto also has a 'try this for alternate if not working as expected' on the inbuilt voice)




1258 posts

Uber Geek
+1 received by user: 20


  Reply # 1970289 7-Mar-2018 07:10
Send private message

Thanks for the suggestion. Gave it a try but no change unfortunately.

368 posts

Ultimate Geek
+1 received by user: 36


  Reply # 1970566 7-Mar-2018 13:06
Send private message

I found this link it may help.

 

https://forums.androidcentral.com/google-pixel-pixel-xl/762210-ok-google-listen-command-through-my-bluetooth-headset.html

 

It says:

 

When in Google Now, I go to Settings -> Voice 
-> At the bottom, turn on "Bluetooth Headset"
-> Under OK Google Detection -- Make sure it is always on
-> Under Hands Free -- Turn on Bluetooth Devices




1258 posts

Uber Geek
+1 received by user: 20


  Reply # 1970618 7-Mar-2018 13:25
Send private message

Thanks, I checked all those settings, they were already on :-(


Banana?
4429 posts

Uber Geek
+1 received by user: 1054

Subscriber

  Reply # 1970661 7-Mar-2018 13:34
Send private message

Do you know if it uses the Microphone when you make a call?

 

I have a BT adaptor for my car's OEM stereo, and it uses the external Mic in calls, but if I try and use Siri, it seems to use the phone's microphone (but the Siri results come out the Stereo speakers etc.).

 

I just took this as a bug, and live with it, but mine is not an official Apple product (like yours is an official Android Auto product).




1258 posts

Uber Geek
+1 received by user: 20


  Reply # 1970668 7-Mar-2018 13:45
Send private message

I will try making a call with the phone mic muffled. Its a bit tricky because the phone mic seems so sensitive but I finally wrapped the phone in a pillow and put it outside the car and at that stage OK Google detection stopped working. Will try the same with a phone call.


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.