Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




3827 posts

Uber Geek
+1 received by user: 1056


# 250870 29-May-2019 09:51
Send private message quote this post

My Samsung watch is not notifying/vibrating for any incoming texts, emails, calls etc from my phone whenever my phone's 'do not disturb' mode is turned on. Given DND mode is automatically enabled whenever I'm at work, not getting watch notifications kind of defeats the purpose of the watch!

 

As soon as I turn off DND I get all notifications (yellow dot, vibrate, screen turns on).

 

I have fiddled with all the notification settings in the Galaxy Wearable app, and have checked to see if there's anything I can do on the phone's DND settings, but no luck.

 

Does anyone have any idea what may be going on here, and what I can do to fix it?

 

I get that I may solve the problem with resetting the eatch (as I think it was working fine a couple of days ago), but doing that I won't know what caused it so may end up in the same position! I've also spent ages trying to find guidance online, but everything I find relates to the watch's DND mode, not the phone's.

 

Watch is a Samsung Galaxy; phone is a OnePlus 6.

 

Thanks for any help.

 

 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
12967 posts

Uber Geek
+1 received by user: 4342

Trusted
Lifetime subscriber

  # 2247575 29-May-2019 10:03
4 people support this post
Send private message quote this post

So. You are complaining that Do Not Disturb is...not disturbing you?






12967 posts

Uber Geek
+1 received by user: 4342

Trusted
Lifetime subscriber

  # 2247576 29-May-2019 10:04
Send private message quote this post

Leave the phone on with DND turned off and set it to silent. You won't hear the phone go off and the stuff will still go to the watch.






 
 
 
 




3827 posts

Uber Geek
+1 received by user: 1056


  # 2247623 29-May-2019 10:49
Send private message quote this post

DND, as it was working previously, related to the phone's actions (ie, fully silenced the phone); it did nothing to limit the response of the watch itself (which continued to get all notifications even when the phone's DND was on).

 

Yep, I know there are workarounds I can use, but they're unnecessarily manual - this one would require me to remember to switch my phone to silent when I get to work (and turn it on again when leaving) - something I often failed to do in the past (and I work in a VERY quiet office!).

 

The automation app I use (MacroDroid) does a perfect job of using geofencing to automatically enable/disable DND for work, and I'd like to continue to be able to rely on that.

 

 


3894 posts

Uber Geek
+1 received by user: 904

Lifetime subscriber

  # 2247685 29-May-2019 12:32
Send private message quote this post

There is a setting in the (Galaxy) Wear app on my phone, under notifications -> mute connected phone.
Would that work instead of using DND?




Areas of Geek interest: Home Theatre, HTPC, Android Tablets & Phones, iProducts.

430 posts

Ultimate Geek
+1 received by user: 101


  # 2247694 29-May-2019 13:07
Send private message quote this post

Has there been a recent software update for your phone?

The Oreo update totally changed the DND behaviour on my phone. I use DND for when I'm sleeping. Was working fine until I got Oreo. Now when DND turns off (at 6am), I get a barrage of notification sounds for every email or message I received overnight, so if I received 10 emails, then my email notification sound will play 10 times consecutively. Samsung say it is working as intended.

I now have to use Automate app to silence my phone for a few minutes at the DND switch off time.



3827 posts

Uber Geek
+1 received by user: 1056


  # 2247730 29-May-2019 14:19
Send private message quote this post

kiwiharry: Has there been a recent software update for your phone?

The Oreo update totally changed the DND behaviour on my phone. I use DND for when I'm sleeping. Was working fine until I got Oreo. Now when DND turns off (at 6am), I get a barrage of notification sounds for every email or message I received overnight, so if I received 10 emails, then my email notification sound will play 10 times consecutively. Samsung say it is working as intended.

I now have to use Automate app to silence my phone for a few minutes at the DND switch off time.

 

No, sadly! I've had Android Pie for quite a while now, and recall also having some issues at the time of the upgrade with DND and its interaction with MacroDroid.

 

But no recent OS upgrades, and everything was working as it normally does (watch notifications working when phone DND on) on my old Samsung S2 watch as of last Friday.




3827 posts

Uber Geek
+1 received by user: 1056


  # 2247733 29-May-2019 14:30
Send private message quote this post

Dingbatt: There is a setting in the (Galaxy) Wear app on my phone, under notifications -> mute connected phone.
Would that work instead of using DND?

 

Yep, that does indeed achieve the same result - the problem is that I'm not aware of any way of automating it; leaving it on permanently would mean having to turn on audio ringtones/notifications on the watch when I leave work, or turning it on/off each time I get to/leave work would require going into the notifications settings to toggle that setting.

 

@Dingbatt, and anyone else who has a Galaxy or even an earlier model Samsung watch - if you put your phone in DND mode, do you still receive all notifications on your watch (including vibrate)?

 

How would you expect the interaction between phone DND and a watch's notification - expect it to also mute all watch notifications, or allow them through and have the watch manage them?

 

Since my first post I tried completely re-setting the phone and set it up from scratch (ie, no restoring of earlier settings)... still have exactly the same problem!

 

Sadly I'm not able to use MacroDroid to reduce the volume of the phone to zero upon entering a geofenced area, which could have been an alternative to turning on DND - I believe this is because OnePlus has a hardware mute button, and it's only that which can fully mute notifications/ringtones. Is there any other way I could achieve the same aim?

 

Thanks for any further suggestions.


 
 
 
 


3894 posts

Uber Geek
+1 received by user: 904

Lifetime subscriber

  # 2247749 29-May-2019 15:02
Send private message quote this post

DND on phone gives no vibration or sound on my Gear S3.

I only use DND at night with some favorite exclusions so I prefer it doesn't make my watch buzz either.




Areas of Geek interest: Home Theatre, HTPC, Android Tablets & Phones, iProducts.



3827 posts

Uber Geek
+1 received by user: 1056


  # 2247764 29-May-2019 15:12
Send private message quote this post

Dingbatt: DND on phone gives no vibration or sound on my Gear S3.

I only use DND at night with some favorite exclusions so I prefer it doesn't make my watch buzz either.

 

Thanks so much for checking this.

 

Looks like I'm chasing the impossible, then; perhaps this was a 'feature' that was added to more recent versions of Tizen (I believe some of the more recent updates have been for the S3 onwards, so my S2 would have been running an older version).

 

I too run DND on my phone over night, but always put my S2 into airplane and DND modes as well - not only to ensure the watch didn't buzz, but also to maximise the (cr@p) battery life! Still do the same with the new Galaxy, as I can't see the point of having it connected to the phone overnight, given it's not being used.

 

I'll have to look to other ways to manage silencing my phone at work, or just put up with it being at the quietest setting.


430 posts

Ultimate Geek
+1 received by user: 101


  # 2247875 29-May-2019 17:41
Send private message quote this post

Have a look at the Automate app as I think it can base rules on location. As I mentioned before I use Automate to turn off the volume on my phone.

74 posts

Master Geek
+1 received by user: 5


  # 2247939 29-May-2019 19:24
One person supports this post
Send private message quote this post

jonathan18:

 

My Samsung watch is not notifying/vibrating for any incoming texts, emails, calls etc from my phone whenever my phone's 'do not disturb' mode is turned on. Given DND mode is automatically enabled whenever I'm at work, not getting watch notifications kind of defeats the purpose of the watch!

 

As soon as I turn off DND I get all notifications (yellow dot, vibrate, screen turns on).

 

I have fiddled with all the notification settings in the Galaxy Wearable app, and have checked to see if there's anything I can do on the phone's DND settings, but no luck.

 

Does anyone have any idea what may be going on here, and what I can do to fix it?

 

I get that I may solve the problem with resetting the eatch (as I think it was working fine a couple of days ago), but doing that I won't know what caused it so may end up in the same position! I've also spent ages trying to find guidance online, but everything I find relates to the watch's DND mode, not the phone's.

 

Watch is a Samsung Galaxy; phone is a OnePlus 6.

 

Thanks for any help.

 

 

 

 

Think in new update seen in wearable app, sync phone settings and in there sync do not disturb which is possibly solution for you and seen how used to be there before and people on reddit had same problem so hopefully this is fix for you.

 

https://www.reddit.com/r/GalaxyWatch/comments/bqhsat/notifications_not_forwarded_to_galaxy_watch_when/




3827 posts

Uber Geek
+1 received by user: 1056


  # 2247940 29-May-2019 19:25
Send private message quote this post

kiwiharry: Have a look at the Automate app as I think it can base rules on location. As I mentioned before I use Automate to turn off the volume on my phone.

 

Cheers - I may take a look at that; I did download it when I also tried MacroDroid (which I also use based on geolocation), but it may deal with this situation better than MacroDroid. However, as mentioned in an earlier post, I believe the problem originates with OnePlus using a physical switch for muting, meaning there's no electronic way to set the ringtone/notification volume to 'zero'.

 

I have fiddled with my MacroDroid macros for arriving/leaving work and have a solution that appears to be working - rather than it turning on DND I now have it setting the notification tone and ringtone to 'none', and restoring them when leaving that geofenced area. It's meant I've needed to have a single (default) notification tone for all apps (I had different ones for texts, emails and other), and I can't stop the phone vibrating in silent, but better than nothing.

 

Thanks for the ideas and advice.




3827 posts

Uber Geek
+1 received by user: 1056


  # 2247941 29-May-2019 19:32
Send private message quote this post

johny007g:

 

Think in new update seen in wearable app, sync phone settings and in there sync do not disturb which is possibly solution for you and seen how used to be there before and people on reddit had same problem so hopefully this is fix for you.

 

https://www.reddit.com/r/GalaxyWatch/comments/bqhsat/notifications_not_forwarded_to_galaxy_watch_when/

 

 

Thanks so much for posting that link - your Google-foo is clearly so much better than mine! Good to know I'm not the only one who has the same problem; here's hoping it's fixed at some point, but knowing Samsung that may never happen.


12967 posts

Uber Geek
+1 received by user: 4342

Trusted
Lifetime subscriber

  # 2248065 29-May-2019 22:54
Send private message quote this post

As far as I can tell, the watch is merely a channel for repeating notifications from the phone. If you DND the phone, then it won't give you any notifications - regardless of the method (screen, watch etc).

 

I actually turn my phone off at night if I am wearing the watch, because there is some sort of notification I can't stop that buzzes the watch and it wakes me up.

 

I do think that if you just put the phone in silent mode at work and leave the notifications on, it will send them to your watch.








3827 posts

Uber Geek
+1 received by user: 1056


  # 2248310 30-May-2019 10:37
Send private message quote this post

I checked out the Reddit thread that @johny007g linked to above again this morning, and found a new post suggesting downgrading the Galaxy Watch Plugin app fixed the problem - I'm assuming it was introduced in the May 10 update (https://www.reddit.com/r/GalaxyWatch/comments/bqhsat/notifications_not_forwarded_to_galaxy_watch_when/ep9vsel/).

 

So I decided to give it a go; it wouldn't let me downgrade the app without uninstalling the original. Once the earlier version was installed it forced a reset of the watch, damn it!

 

But I can confirm it restores the original functionality - with the phone set to DND I once again get notifications on my watch.

 

And just after doing this I got a notification saying the new firmware with One UI is ready to download; unsure if this will fix or re-break the issue, but I did see a report that this update does cause battery issues. I may hold off with this until I'm sure it's an improvement.

 

 


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.