Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




301 posts

Ultimate Geek
+1 received by user: 36


Topic # 64919 25-Jul-2010 21:36
Send private message

I know this bug has affected a few people, so basically there was an issue with the Broadcom driver that's been recently fixed:
http://android.git.kernel.org/?p=platform/system/wlan/broadcom.git;a=commit;h=5a838529e6197475cbe8f5a4557fbd31f90586a6

It was affecting some N1 owners, myself included, and a few friends. Basically if you've had trouble with your Wireless and your MAC doesn't start with 00: then this is for you.

Grab any of the latest CM6 nightlies from 07222010-135717 and the fix is included:
http://mirror.kanged.net/cm/nightly/passion/

This also resolves the issue where if your screen is off, you get *zero* traffic to your N1

Just thought I'd post the heads up here, in case it's of use to any other fellow N1 owners :)

Cheers


Chill. 

Create new topic
324 posts

Ultimate Geek
+1 received by user: 2


  Reply # 356338 26-Jul-2010 08:54
Send private message

Good news for the unlocked and rooted .... any news on when Google will roll out this fix for stock users? Mind you, I am a 00: MAC ...



301 posts

Ultimate Geek
+1 received by user: 36


  Reply # 356340 26-Jul-2010 08:57
Send private message

No, none yet, though it's apparently got quite a lot of publicity from the BoyGeniusReport, which apparently prompted the resolution. It's been going on now for ages, specifically the Android bug report that I subscribed to and was helping in was placed around Jan / Feb.

I'm wondering if they'll roll out an additional minor patch, as they've done with the likes of FRF91, making it a few hundred KB to go from FRF85B to FRF91 for example ...

 
 
 
 


5270 posts

Uber Geek
+1 received by user: 1143

Trusted
Subscriber

  Reply # 356356 26-Jul-2010 09:38
Send private message

[Dupe]




____________________________________________________
I'm on a high fibre diet. 

 

High fibre diet


5270 posts

Uber Geek
+1 received by user: 1143

Trusted
Subscriber

  Reply # 356357 26-Jul-2010 09:38
Send private message

ChillingSilence: No, none yet, though it's apparently got quite a lot of publicity from the BoyGeniusReport, which apparently prompted the resolution. It's been going on now for ages, specifically the Android bug report that I subscribed to and was helping in was placed around Jan / Feb.

I'm wondering if they'll roll out an additional minor patch, as they've done with the likes of FRF91, making it a few hundred KB to go from FRF85B to FRF91 for example ...


I may have seen this bug myself....not sure. It isn't consistent.

The wifi at home (TP-Link WiFi AP) is 100% on and rock solid all the time. So were the two DLinks before it. The Linksys/Cisco toilet-seat I tried briefly was crap with everything and I gave it away just to be rid of it. 

But the NetComm at work (and the Cisco before it) were flakey as hell. We also tried a DSE Wifi AP and that was flakey, too.

So it didn't seem to matter what wifi ap was used at work, or what channel it was on, or which Android phone I used (Magic, Liquid or N1)....the wifi is flakey.

But at home, the wifi is 100% on all / any phone all the time.

Something else going on here....so it obscures the bug you've described.




____________________________________________________
I'm on a high fibre diet. 

 

High fibre diet




301 posts

Ultimate Geek
+1 received by user: 36


  Reply # 356360 26-Jul-2010 09:41
Send private message

Define "flaky"?

Basically when your screens off, if you've been on WiFi, then you won't be getting email alerts, C2DM or anything else like that, as it doesn't utilize 3G (Coz it thinks you're still on WiFi). Streaming music like Pandora should stop the moment you turn your screen off, if you're affected by this bug (Depending on how much it's cached), and same for if you're pinging your phone.

If you're not affected by this bug, then turn your screen off, and you should be able to keep pinging your phone :)

5270 posts

Uber Geek
+1 received by user: 1143

Trusted
Subscriber

  Reply # 356396 26-Jul-2010 11:06
Send private message

ChillingSilence: Define "flaky"?

Basically when your screens off, if you've been on WiFi, then you won't be getting email alerts, C2DM or anything else like that, as it doesn't utilize 3G (Coz it thinks you're still on WiFi). Streaming music like Pandora should stop the moment you turn your screen off, if you're affected by this bug (Depending on how much it's cached), and same for if you're pinging your phone.

If you're not affected by this bug, then turn your screen off, and you should be able to keep pinging your phone :)


I set my wifi to to "never" turn off when the screen is off. This is just a notification thing? I can happily have my M001 tablet on the Net thru the Nexus One while the Nexus One is 'asleep' on the desk......though I've noticed I do occasionally have to rouse it (turn on screen and refesh a page in the browser) after a half-hour or so.   

I've also noticed that after turning the hotspot off, I often have to shutdown / reboot the phone to get 3G going again.

I'll re-read your original description and have a play at lunch time. Ta.  




____________________________________________________
I'm on a high fibre diet. 

 

High fibre diet




301 posts

Ultimate Geek
+1 received by user: 36


  Reply # 356400 26-Jul-2010 11:09
Send private message

No, it's all data. Sounds like something different from the issue described. Check your WiFi mac on the N1. If it starts with 00: then you're not affected.

You sholdn't have to do that with turning Hotspot off, I certainly never have and I've used that feature almost daily. However, that's a discussion for another thread ;)

5270 posts

Uber Geek
+1 received by user: 1143

Trusted
Subscriber

  Reply # 356413 26-Jul-2010 11:28
Send private message

ChillingSilence: No, it's all data. Sounds like something different from the issue described. Check your WiFi mac on the N1. If it starts with 00: then you're not affected.

You sholdn't have to do that with turning Hotspot off, I certainly never have and I've used that feature almost daily. However, that's a discussion for another thread ;)


My WiFi MAC starts with 00:23.....so looks like I'm OK. Ta.  




____________________________________________________
I'm on a high fibre diet. 

 

High fibre diet


324 posts

Ultimate Geek
+1 received by user: 2


  Reply # 356439 26-Jul-2010 12:22
Send private message

Linuxluver:
ChillingSilence: No, it's all data. Sounds like something different from the issue described. Check your WiFi mac on the N1. If it starts with 00: then you're not affected.

You sholdn't have to do that with turning Hotspot off, I certainly never have and I've used that feature almost daily. However, that's a discussion for another thread ;)


My WiFi MAC starts with 00:23.....so looks like I'm OK. Ta.  


Same as mine and I am affected.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.