Hi All,

Firstly, I'm new to Geekzone as a user, have been a reader of the forums for a little while now,

So Hi!

Both my wife and I recently upgraded our phones from the standard Nokia 2730 Clasics on Telstraclears 3G (aka vodafone) to hers being a LG-P500h Optimus One and mine being a Samsung Galaxy S GT-I9000.

Both phones were purchased from Noel Leemings. Hers was a XT network phone and mine a Vodafone network phone

Initially, I called Telstraclear and they sent to us both the configuartion text messages to enable the web browsing & mms settings. For a little while there everything worked nicely.

So after a little while, I installed some apps on the LG phone and set it up for working within my Wireless network at home.

But now, the LG-P500h won't send or recieve MMS messages. A first I thought this might be to do with the apps installed, so uninstalled those, and still no joy. The galaxy S will send and recieve.

I've even performed a factory reset on it via the menu (setting > Privacy > factory reset) and still no joy.

I've entered the APN settings for telstraclear as per the message at the top of this forum and still no joy. Even tried different names for the MMS settings. I've tried MMS and TCL MMS. Neither seem to work. The check box for Data enabled is checked on.

As I post this the phone isn't in front of me, but I know from memory the phone is on Android 2.2.1 and firmware is at V10B 13 Dec 2010.

The phone will still send normal text messages, make and recieve calls, and browse the web via the browser (so that setting is working) but won't send or recieve MMS.

Any help\ideas\assistance will be greatly appreciated.