Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




105 posts

Master Geek

Trusted

Topic # 98208 26-Feb-2012 20:45
Send private message

Looks like I need some help from the experts

I have a Telecom HTC Sensation, and was dabbling with installing an ICS ROM, but ended up with a phone that continually reboots.

I have root access, and have installed several ROMs over the past few months with no problems (until now).

My plan was to install Android Revolution HD™ 6.3.0 -  ICS-3.30.401.101, from here:

http://forum.xda-developers.com/showthread.php?t=1098849

 

That page told me it was necessary to install new firmware, and pointed me here:

http://forum.xda-developers.com/showthread.php?t=1412618

I downloaded the version entitled “Firmware from 3.30.401.1 & 3.30.401.101 RUU” , put the PG58IMG.zip file in the root of the SD card, rebooted to recovery and it loaded – it did report my CID did not match, but seems to complete the load.

Ever since then, no matter what I do, the phone will boot to the HTC white splash screen, briefly show the android splash very briefly, then immediately reboot.  I can get it back to recover each time, and have tried restoring from several different ROM backups, but every time it shows the HTC splash, briefly the Android splash and reboots.

I followed some instructions to try editing the android-info.txt file within the PG58IMG fileto include my CID, and re-flashed it again file, but this produced no change.  By the way my MID is PG5811000 and my CID is TELNZ001.

When I stop in in recovery mode, the screen says:

-Revolutionary-

PYRAMID PVT SHIP S-PFF RL

HBOOT-1 27.1100

RADIO-10.14.9035.02_2

OpenADSP-v02.6.0.2226.00.0131

eMMC-boot

Jan 13 2012,17:33:34

 

Any suggestions on how to get things back and running would be most appreciated.

Create new topic
1 post

Wannabe Geek


  Reply # 587165 27-Feb-2012 06:06
Send private message

Hello - I had the same problem a few weeks ago.  So long as the firmware update file remains on your sd card, the phone will keep trying to install it automatically at each reboot, even though it has already updated.  The only way I could get it to stop was to take the sd card out, put it in another device (a Nook tablet, as it happens), then deleted the firmware file from the SD card using the Nook.  I was then able to install the new rom. 



105 posts

Master Geek

Trusted

  Reply # 587195 27-Feb-2012 08:50
Send private message

Many thanks pflewis123. but that is definately not my problem.  Each time I loaded a PG58IMG.zip image I removed it from the SD card before proceeding. 

What I think I need is a copy of the stock firmware in a PG58IMG.zip  file to replace what went on - although I realise that file can contain many or few items of the firmware set.

 
 
 
 


138 posts

Master Geek


  Reply # 587686 28-Feb-2012 08:51
Send private message

When I rooted my Sensation I also done super Sid. The guide on xda (http://forum.xda-developers.com/showpost.php?p=16125079&postcount=1) is easy to follow and it only needs to be done once. I have not had any problems installing any of the new firmwares for ICS but as with all things YMMV. There is also a thread for firmware upgrade no super acid needed but I have not looked at it. Good luck. I use Virtuous with Sense removed.



105 posts

Master Geek

Trusted

  Reply # 587811 28-Feb-2012 13:07
Send private message

Many thanks k1w33d - that reference looks good, very similar to the process I followed to gain Root a few months back... I will try their recovery flashing steps this evening and see if I get a phone back!

I will report the results here for anyone interested.



138 posts

Master Geek


  Reply # 587832 28-Feb-2012 14:04
Send private message

Hi radionut,

You should be able to flash any Gingerbread firmware over top of your installed firmware. You should probably use superwipe  http://tinyurl.com/3qt4nx2 (Direct download link) to wipe your phone before flashing the firmware. Your best bet is to use the recommended firmware from a rom you have used on your phone before. Hopefully that will get your phone back into a working condition.

To check if you have Super CID from your phone without using a pc, read this thread http://forum.xda-developers.com/showpost.php?p=21173912&postcount=1
I just tried it on my phone to make sure it works.
Once I ran the verifier it confirmed that I had Super CID by showing my CID as 11111111

If your CID is not 11111111 then look in the http://forum.xda-developers.com/showpost.php?p=16125079&postcount=1 post, Step 4 explains the process to get super cid which will allow you to install the latest ICS firmware.

Once you get Super CID up and running you will be set to download the latest ICS firmwares and then taste Ice Cream Sandwich on your Sensation.

Some of the steps in XDA posts look daunting but if you carefully read the first post then scan through the replies for any issues or "ProTips" then follow the steps exactly and in order then you should be all right.

One last thing. The 4Ext Touch recovery is amazing and if you are not using it I highly recommend that you get it on your phone. http://forum.xda-developers.com/showpost.php?p=20015407&postcount=1

Good luck
 



105 posts

Master Geek

Trusted

  Reply # 589569 2-Mar-2012 20:47
Send private message

Well, two more days but no further forward.  Many thanks k1w33d for the help, but I was not able to get new information.

To explain, I need to put forward my understanding that there are two different forms of software load for the phone. The most common is called loading a ROM, which is in fact a version of Android.  I have done this many times, and in fact can still do this now, I can start in recovery mode, and load a zip file from SD card.  I have tried several ROMs, and restored several of my backups, but it makes no difference to my problem.

What I did immediately prior to the problem starting was load a new firmware, which I assume is a lower level set of software.  To load this I had to put a specific file entitled PG58IMG.zip in the root of the SD card, and when I booted to recovery it loaded the file automatically.

It appears to me I loaded a driver to something that is not correct for my hardware, and now whenever I try to boot the phone into Android, it crashes immediately and reboots again.

My assumption then was all I had to do was reload another PG58IMG.zip file which would overwrite the incorrect drivers and all would be well. I have however since found that there are many PG58IMG.zip files around, and they contain different collections of files.  It seems this is a method of loading a range of different aspects of the firmware, npt the same every time.

The file I loaded that caused the problem (reference to where I got it in my first post above) contained 8 img files:

Adsp.img
Pg2fs_spcustom.img
Radio.img
Rpm.img
Sbl1.img
Sbl2.img
Sbl3.img
Tz.img
 

All PG58IMG.zip files I have found only contain one or two files, so do not provide a replacement of many of the above functions.

So, I am sure I need a new PG58IMG.zip file, with an “old” version of one or more of the above img files, I just have no way of knowing which one I need, or where to get the file.

For those who know about these things there must be a clue in the message on my screen when stoping in recovery mode:

-Revolutionary-
PYRAMID PVT SHIP S-PFF RL
HBOOT-1 27.1100
RADIO-10.14.9035.02_2
OpenADSP-v02.6.0.2226.00.0131
eMMC-boot
Jan 13 2012,17:33:34



One of these is probably the offending one.

The info you kindly compolied k1w33d was mostly what I followed several  months ago when I first set up root access, and started loading ROMs, however there was one new learning, I had not changed the CID to the “superuser” 111111.  I have done that now, and tried re-loading the PG58IMG.zip file, in case it needed that CID to load properly, but that did not solve anything.

So – this is an extremely long post, but I am about to drop the phone in a compactor, or pay someone to fix it (if I knew where that could happen)… so any further expert suggestions would be appreciated.



105 posts

Master Geek

Trusted

  Reply # 589742 3-Mar-2012 10:33
Send private message

Wooooh Hooo!!

I have a phone again…

I decided a last ditch google session on this stormy morning would be done and some more file loading before either dropping the carcass into a skip, or heading for the shop for a “warranty” repair (likely to involve some fast talking and some $$).

The google search found this in an xda-developers thread posted by stardust240781:

I don't understand why so many people have problems installing this.

- put mike1986's PG58IMG.zip, Superwipe Script and ROM zip on SD root
- check md5 hash
- check md5 hash again
- boot into recovery
- flash Superwipe script
- flash ARHD 6.1.0
- reboot into bootloader
- flash PG58IMG.zip (this will reboot automatically once during the process)
- reboot
- have fun with ARHD 6.1.0


.. so the order of installing things matters! (not clearly stated any other source I found)…

The instruction above is a little simplistic, you must not put the PG58IMG.zip file on your SD card until you get that step (otherwise it will automatically load on the first and all subsequent boots), so you have to do the superwipe, load the ROM, power down and put PG58IMG.zip onto your SD, boot again to recovery, let it load (it then does the reboot and start again in the middle of loading) then power down and remove the PG58IMG.zip from your SD, then boot, and – it is in business!

Before I saw this I was putting the PG58IMG.zip onto the SD card and loading that first – and it did not do the reboot to load the last three images.. I now suspect therefore it was leaving the phone with some vital part of the firmware either not there, or incompatible with the rest.

Oh well, having superwiped and reset to factory defaults many times over the last week, I now have a little work to do to re-configure my phone, but it is in a much happier place now.

Thanks again to the two who did offer help – it was appreciated.  My google search found many many threads of people who seem to have the same rebooting problem, with few getting clear answers, so this thread may be helpful to some other googlers later!

138 posts

Master Geek


  Reply # 589766 3-Mar-2012 11:21
Send private message

Glad you got it sorted. I know how frustrating it can be trying to find solutions sometimes. You seem to only find the same 1 or 2 solutions that don't work for you. Welcome back to the Sensation ;)

2 posts

Wannabe Geek


  Reply # 600650 27-Mar-2012 12:10
Send private message

@Radionut. I am having the exact same problem but do not understand how to check the md5 hash or any of that stuff. Could you please walk me through the steps you went through to get your phone to work?



105 posts

Master Geek

Trusted

  Reply # 600919 27-Mar-2012 19:11
Send private message

@ strakemora, If you have installed the latest version of 4EXT recovery (available here: http://forum.xda-developers.com/showthread.php?t=1377759 ) start it , select “recovery”. There is an option to “check a file’s md5sum”.  You should be able to check your downloaded files from there before you start.  If you have this installed, even if your phone is now in the reboot – reboot cycle, you should be able to stop it (with the volume down button)  start recovery and get to this menu.

In fact I did not check my files, as I have reasonable confidence with the downloads – although it is a very large file, so anything could happen I guess.

My successful process to get the phone back was:

 

Download firmware package: “Firmware from 3.24.401.1 & 3.25.401.101 RUU” From here: http://forum.xda-developers.com/showthread.php?t=1412618

Download the new ROM entitled “Android Revolution HD 6.5.3”  and “Superwipe” from here http://forum.xda-developers.com/showthread.php?t=1098849

 

- put the two ROM  files: (superwipe and android revolution) on SD root – DO  NOT  put the firmware file (PG58IMG.zip) on the SD card at this stage.
- boot into recovery  (restart with the volume down key pressed, select recovery from menu)
- flash Superwipe script  (load zip from SD, select superwipe)
- flash  Android Revolution  (load zip from SD, select Android Revolution)

- Remove SD, use external card reader to copy PG58IMG.zip to card

- reboot into bootloader  (phone will find the PG58IMG.zip file check it and ask if you want to load it)
- load PG58IMG.zip (part way through the phone will reboot again, and load the remaining portion of the PG58IMG.zip file)
- reboot  (this takes a long time, don’t panic!)
- once it starts, you should be up and running

 

I have since then updated the ROM again (a newer version of the Android Revolution rom), with no problems, although this did not require a firmware update, so was pretty simple (superwipe, then ROM).

 

2 posts

Wannabe Geek


  Reply # 601093 28-Mar-2012 09:14
Send private message

I do not have ext4 recovery but i do have clockwordmod recovery. I am not sure how to install ext4 recovery  with the restricted use i have of my phone.

14 posts

Geek


  Reply # 606408 7-Apr-2012 14:58
Send private message

thanks to @radionut for the earlier post on order of install when flashing new ROM.

Had exactly the same problem with continual reboots, even after deleting PG58IMG.zip from root of SD card.

Now running Android Revolution HD 6.5.5, most noticable is the increased speed and extended battery life.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.