Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




190 posts

Master Geek
+1 received by user: 1


Topic # 24296 20-Jul-2008 17:26
Send private message

Hi everyone:

Just wondering anyone having issues with the Xnet usagemeter on FF?  I can't seem to get mine going, and it's really the only way I get my traffic accounting since I'm using a Mac.

Anyone seeing issues with the usagemeter at all?  what about you wolks who uses the Desktop Usame Monitor?  Is it working OK for you?

I'd be interested to hear your comments?

Cheers!

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3
15 posts

Geek


  Reply # 150237 22-Jul-2008 12:55
Send private message

Yeah I've been having problems with the Firefox plug in too. Just shows up with the Red Exclamation mark. Went back to the xnet website and reinstalled it but no luck.

The desktop usage monitor works fine though...

162 posts

Master Geek
+1 received by user: 4


  Reply # 150382 22-Jul-2008 16:37
Send private message

Mine's working fine, on FF 3.0 both on Windows and Ubuntu.

 
 
 
 


1391 posts

Uber Geek
+1 received by user: 193


  Reply # 150451 22-Jul-2008 19:30
Send private message

Yes, mine's broken on FF 3.01, has been for a few days now and up until now I hadn't had any problems with it. I've tried re-installing it and that didn't work. I'm still poking at it to see if I can figure out what's wrong with it.

15 posts

Geek


  Reply # 150569 23-Jul-2008 10:14
Send private message

alikaz: Yeah I've been having problems with the Firefox plug in too. Just shows up with the Red Exclamation mark. Went back to the xnet website and reinstalled it but no luck.

The desktop usage monitor works fine though...


I just noticed that its not working on either my PC or my Laptop. Both FF3 & XP...

If I try and change the username/password it bring up the config box again for me to correct it, so I assume the log in process is working ok...

Desktop usage is working fine and dandy

1391 posts

Uber Geek
+1 received by user: 193


  Reply # 150699 23-Jul-2008 17:03
Send private message

I did the same thing with the config. with the same result as you. Plus the desktop works fine with the username and password (except the total dollar amount shows pounds and no figure...does yours show a dollar amount??)

Other things I tried included
a) deleting FF's cache
b) checking to see if someone with the same security update as my version of FF had a working meter (they did)
c) uninstalling, reinstalling and restarting FF
d) turning off my firewall
e) restaring the computer
f) running ccleaner to delete any temp data in the net folder
g) runnin ccleaner to fix any reg problems

I didn't delete my cookies because with the five or so different logins I need for different parts of xnet (billing, voip, webmail, etc) I'm afraid I'd forget one of them.

Any of you try deleting the cookies? The data for the meter is stored somewhere because when I reinstalled it the name and pass was already there! I tried to find where the data was stored by examining the files in one of Mozilla's main storrage folders but didn't have any luck. My current theory is the stored data is corrupted somehow.

80 posts

Master Geek


  Reply # 150761 23-Jul-2008 20:54
Send private message

The data is stored in Firefox's settings backend.  If you go to about:config you'll find the settings stored under extensions.xnetusage :).

However, I'm not personally having any issues with it...


1391 posts

Uber Geek
+1 received by user: 193


  Reply # 150763 23-Jul-2008 21:00
Send private message

Thanks I'll have a look there.
Update: looks all normal there.
Tried installing it on the hubby's laptop and his doesn't work either.
Soooooo, going to check out the router settings since that at least eliminates my own laptop as the culpret and implicates some sort of more global problem.
He's on our wireless LAN but otherwise our AV's are different, I'm running a personal firewall and he isn't.
It's weird.
There's nothing in my router firewall that could be blocking it that I can see. All my port settings are to ALLOW stuff, not to block it.

15 posts

Geek


  Reply # 150783 23-Jul-2008 22:08
Send private message

what router have you got out of interest?

I'v got the WAG54GP2v2...


I've tried clearing all my data (cookies etc) but had no luck. Just tried resetting those strings in the config also but nothing.

I think there could be a glitch in the matrix

1391 posts

Uber Geek
+1 received by user: 193


  Reply # 150785 23-Jul-2008 22:22
Send private message

netgear dg834gt.
I tried deleteing cookies as well. No help.
I disabled all my router firewall rules and that didn't help either.

I think I've done all I can. How annoying!
Can't be something wrong with both laptops, they aren't even the same brand.
Got to be something to do with the account itself.

1391 posts

Uber Geek
+1 received by user: 193


  Reply # 150798 23-Jul-2008 22:51
Send private message

That's weird, my edit disappeared. So here's a bump.
I checked the error console in firefox (tools, error console) and got this:

Error: not well-formed
Source File: https://accounts.xport.co.nz/xml3.cgi?username=myusername@adsl.xnet.co.nz;token=ascitexthere
Line: 5, Column: 2
Source Code:
<>0.00</>

And underneath the first 0 a green arrow pointing upwards, presumably picking out the error?

Part in bold changed for privacy.

So, something wrong there. Delete error console entries, try to refresh xnet usage meter in FF, get same error in console.


15 posts

Geek


  Reply # 151088 24-Jul-2008 20:29
Send private message

I've got exactly the same message (Error: not well-formed). If I click the link, it opens a new window which in the title 'Source of: https://accounts.xport.co.nz........'

and then it has listed in the window the below information, which has all the correct and current data usage for my account. So presumably it can access the data, it just can't display it for some reason...

<?xml version="1.0" ?>
<trafficUsageResponse>
<ppm>true</ppm>
<bpc>69.95</bpc>
<>0.00</>
<international>14649.83</international>
<local>15423.29</local>
<national>622.79</national>
<total>15272.62</total>
<cap>20480</cap>
<overage>Throttled</overage>
<limited></limited>
<version>1.3</version>
<link>http://www.xnet.co.nz/downloads/xnetusagesetup.exe</link>
<message></message>
<ttl>900</ttl>
<cpm>0.001</cpm>
<version>1.7</version>
<link>http://www.xnet.co.nz/downloads/xnetusagesetup-1.7.exe</link>
<errstr></errstr>
</trafficUsageResponse>

2332 posts

Uber Geek
+1 received by user: 367

Trusted

  Reply # 151091 24-Jul-2008 20:44
Send private message

<>0.00</> is not valid XML which is most likely the problem

it should be
<whatever>0.00<whatever/>

You cannot have an emtpy value in <>




15 posts

Geek


  Reply # 151095 24-Jul-2008 20:50
Send private message

so would that mean it is an Xnet issue - as the problem is in the xml file?

wonder why its only affecting a few people...

2332 posts

Uber Geek
+1 received by user: 367

Trusted

  Reply # 151099 24-Jul-2008 21:10
Send private message

maybe different versions of browser have different ways of validating XML files
or maybe something on your account which makes this field invalidly blank. Only xnet can answer the 2nd one.

Anyway.. hope you get it sorted one way or another

1391 posts

Uber Geek
+1 received by user: 193


  Reply # 151111 24-Jul-2008 21:49
Send private message

I thought my next move would be calling customer support.
Or wait until the month ticks over and hope whatever issue it is with the account resolves itself.
Whichever comes first.
The former depends on my energy levels between work.
And how much it continues to irk me. I hate it when something isn't working right on my laptop.

Edit: Ok I'm irked. I'm going to call customer support and see if the tech guys can do something about the missing info in the xml tags. It isn't the browser, I tried two (FF and explorer) and neither works. If the tags are invalid, they need fixing. Hopefully the tech guys will help me out.

 1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Phone prices rising as users move upmarket
Posted 24-Nov-2017 17:16


Talking net neutrality on RNZ Nine-to-Noon
Posted 24-Nov-2017 12:11


Air New Zealand experiments with blockchain technology
Posted 23-Nov-2017 15:39


Symantec selects Amazon Web Services to deliver cloud security
Posted 23-Nov-2017 10:40


New Zealand Ministry of Education chooses Unisys for cloud-based education resourcing management system
Posted 22-Nov-2017 22:00


Business analytics software powers profits for NZ wine producers
Posted 22-Nov-2017 21:52


Pyrios strikes up alliance with Microsoft integrator UC Logiq
Posted 22-Nov-2017 21:51


The New Zealand IT services ecosystem - it's all digital down here
Posted 22-Nov-2017 21:49


Volvo to supply tens of thousands of autonomous drive compatible cars to Uber
Posted 22-Nov-2017 21:46


From small to medium and beyond: Navigating the ERP battlefield
Posted 21-Nov-2017 21:12


Business owners: ERP software selection starts (and finishes) with you
Posted 21-Nov-2017 21:11


Why I'm not an early adopter
Posted 21-Nov-2017 10:39


Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06


Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30


Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.