Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




344 posts

Ultimate Geek


# 156054 17-Nov-2014 21:42
Send private message

I'm trying to get a new Spark-supplied HG659b gateway to register with a 2talk account. It's not working, hence this post.

Before I spend any time diagnosing why it isn't registering, can anyone confirm if the Spark HG659b has VOIP functionality blocked or disabled by Spark somehow? From what I've read the equivalent Vodafone product has VOIP blocked or locked down.

The user guide has a VOIP section, and I can access and configure the appropriate settings in the web interface, which raises my hopes that Spark hasn't crippled this functionality.

Has anyone used one of these gateways with a third party VOIP provider, or know if it should work? If the answer is yes I'll start troubleshooting, if no I'll just give up...


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9


344 posts

Ultimate Geek


  # 1177869 18-Nov-2014 11:57
Send private message

I've spoken with Spark Business, who confirmed that they do not actively block the VOIP functionality on this gateway. Assuming that this is the truth, I now need to troubleshoot why the device is not registering with 2talk.

Here are the settings screens I have access to, and the information entered:



Does anyone have any idea where I've gone wrong? I get a "beep, beep, beep" tone when picking up the handset, and the device status shows as "offline" in the gateway. I've read through the 2talk generic provisioning information and can't see anything obviously wrong...

18 posts

Geek


  # 1183051 25-Nov-2014 23:12
Send private message

ashtonaut: I've spoken with Spark Business, who confirmed that they do not actively block the VOIP functionality on this gateway. Assuming that this is the truth, I now need to troubleshoot why the device is not registering with 2talk.

Here are the settings screens I have access to, and the information entered:



Does anyone have any idea where I've gone wrong? I get a "beep, beep, beep" tone when picking up the handset, and the device status shows as "offline" in the gateway. I've read through the 2talk generic provisioning information and can't see anything obviously wrong...


You have the 2talk SIP address in there but there is no fields to enter your username(phone number) or password. Without a way to authenticate who you are then you will never get registration. You may need a separate ATA device.

 
 
 
 


221 posts

Master Geek


  # 1183057 26-Nov-2014 00:02
Send private message

Is there a VOIP Numbers section below VOIP providers on the same page as above?



344 posts

Ultimate Geek


  # 1183075 26-Nov-2014 05:53
Send private message

Yes, there is another page where I enter my phone number and password. I originally had a screenshot of this page but inadvertently forgot to hide the phone number, so I had to edit the post and remove the image.

378 posts

Ultimate Geek


  # 1183108 26-Nov-2014 08:15
One person supports this post
Send private message

ashtonaut: Yes, there is another page where I enter my phone number and password. I originally had a screenshot of this page but inadvertently forgot to hide the phone number, so I had to edit the post and remove the image.


I have this working. Unfortunately, I'm now at work and not at home. Will check in when I get home and if this is still a problem I'll let you know what I did.





344 posts

Ultimate Geek


  # 1183114 26-Nov-2014 08:37
Send private message

If you wouldn't mind posting the settings that you used to get your Spark HG659b up and running with 2talk I would be very grateful!! I have run out of ideas...

378 posts

Ultimate Geek


  # 1183605 26-Nov-2014 20:15
Send private message

Sorry. Sorry. Got distracted when I got home.

VoIP Providers page looks good. Scroll down on that page and you will see the VoIP Numbers. Add one.

Set the provider to the one above (2talk as you have set)
SIP Number to be your 2talk number (028blah)
Username to be your 2talk number (same 028blah)
Password to be your 2talk password
Tick Enable.

On the left-hand side, of the same page there's a menu. Click on Telephone (under VoIP).

Expand Telephone 1 and tick select all and/or 028blah.

I then have a normal phone plugged into the middle one of the three, grey RJ11 sockets.

Will try and get some pictures up.

:-)

[Can't spill]



 
 
 
 


378 posts

Ultimate Geek


  # 1183606 26-Nov-2014 20:22
Send private message

VoIP Numbers:



Telephone 1:



Hope that helps.




344 posts

Ultimate Geek


  # 1183650 26-Nov-2014 21:00
Send private message

Thanks a lot. I can't see anything that I've done that's different to you.

A couple of questions:

1) What specific hardware do you have? HG659b, or just HG659?

2) What firmware version are you on?

378 posts

Ultimate Geek


  # 1183659 26-Nov-2014 21:15
Send private message

ashtonaut: Thanks a lot. I can't see anything that I've done that's different to you.

A couple of questions:

1) What specific hardware do you have? HG659b, or just HG659?

2) What firmware version are you on?


HG659 VER. B
and
V100R001C227B011

Didn't realise it wasn't a B, but I think that just means black.

Here's anpother page of settings - the Advanced page as found via the menu on the left of the Telephoney tab.
Click to see full size



344 posts

Ultimate Geek


  # 1183662 26-Nov-2014 21:19
Send private message

OK, here's what I did:

1) Set up a new VOIP Provider called 2talk with the generic SIP settings from my OP.

2) Created a new VOIP number with my specific number and password as you've done.

3) Assigned Telephone 1 to the VOIP Number created in step 2.

When I check "Line Status", it shows as "offline".

Interestingly enough, the VOIP light on the gateway starts flashing after step 3. From the user guide, this means that the device is communicating with the SIP provider, but 2talk has no record of the device registering, and if I plug a phone in I get a beep beep beep tone, not a dial tone.

I don't know the telnet password so I can't poke around in the back end. If I enable debug logging in the settings page, there are zero messages in the log about VOIP, which strikes me as strange.

I'm about ready to give up...



344 posts

Ultimate Geek


  # 1183665 26-Nov-2014 21:25
Send private message

Hmmm I suspect our different hardware might be part of the issue, though I would be surprised if Spark deliberately disabled functionality in the "b" version.

You can see pictures of both versions of the hardware on the Spark website - the 659 and 659b definitely look different, though the web interface looks very similar so I suspect they are very close (or identical internally) hardware and software wise.

Details of my device from the device management page are as follows:

Product type: HG659b

Hardware Version: VER.B

Software Version: V100R001C227B018



344 posts

Ultimate Geek


  # 1183682 26-Nov-2014 21:36
Send private message

Sorry for spamming this thread, but the system logs actually do show something mildly interesting:

Registering with VoIP number 03XXXXXXX to Register server sip.2talk.co.nz failed: Reason: no answer from remote station received.


378 posts

Ultimate Geek


  # 1183683 26-Nov-2014 21:37
Send private message

ashtonaut: Hmmm I suspect our different hardware might be part of the issue, though I would be surprised if Spark deliberately disabled functionality in the "b" version.

You can see pictures of both versions of the hardware on the Spark website - the 659 and 659b definitely look different, though the web interface looks very similar so I suspect they are very close (or identical internally) hardware and software wise.

Details of my device from the device management page are as follows:

Product type: HG659b

Hardware Version: VER.B

Software Version: V100R001C227B018


Sorry to hear that.

I will take my settings to work tomorrow as I believe there is a B version there. My understanding is that VoIP is not knobbled.



344 posts

Ultimate Geek


  # 1183688 26-Nov-2014 21:58
Send private message

Awesome, I really appreciate any other thoughts or tests you could help with. The fact that the log shows a failed connection attempt makes me wonder if it's something at 2talk's end that's causing the issue. I have an open ticket with them to (hopefully) investigate.

The only other things I can think to try are 1) Create a new 2talk account with a fresh 028 number and see if I can get that working, or 2) if someone can 'loan' me account details for another VOIP provider (not 2talk) then I could try them out - if they work it would rule out a device issue.

 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.