Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




172 posts

Master Geek


Topic # 22082 16-May-2008 09:39
Send private message

Hello gurus

I am using Windows xp with a dlink 502t and have had a dsl connection working for over a year now.
I recently purchased a media streaming device which needed a wireless access point so as is typical for me I rushed off without too much research and bought a wireless router, not realising that you need a modem with it and can not just use the wireless router direct from the internet(at least thats what I think you can't do, something about not being able to do PPPoa with this router?)

Anyway, I am trying to connect the working 502t wirelessly through the dlink 524 wireless router and then communicate wirelessly with my adapter in my laptop which is a Broadcom 802.11g network adapter(inbuilt)

I did have it working. I set it up enencrypted to see if I could get it to work and after a few trials and tribulations discovered something called DHCP was stopping me because both routers were DHCP servers.
I disabled the DHCP on the 524 and got a working solution. My existing internet connection wirelessly through the dlink 524.

I then tried to re set up the connection with wep encryption and it has all come unravelled.

I am reasonably sure I have set it up the same except for the encryption of course but I cannot access the internet.

Could someone see something obvious I am overlooking or perhaps give me a step by step or link to a workaround please.

It is driving me nuts, especially considering I already had it working.
I really need to secure the network so I was going to do wep encryption and mac filtering once I set it up again successfully.

Hopefully someone out there can help

Thanks a lot
Steve

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
1494 posts

Uber Geek
+1 received by user: 221

Subscriber

  Reply # 131209 16-May-2008 11:17
Send private message

I cant helpy you with your specific scenario, but have you considered taking your router back and buying the ADSL Modem/router combination.  It will make your life far more simple!!



172 posts

Master Geek


  Reply # 131216 16-May-2008 11:56
Send private message

No I cant say I have.
Considering I already had it working once, It never entered my head.

i guess I am a stubborn bastard.

Thanks

 
 
 
 


6024 posts

Uber Geek
+1 received by user: 154

Trusted

  Reply # 131232 16-May-2008 12:43
Send private message

If you have a GenII 502T then you can operate it in half bridge mode and bypass its router and use the 524s router, or you can leave the 502T as normal and bypass the router in the 524. I suggest the latter is the easist and what I prefer to do.


Therefore dont use the 524 as a router, just an AP, this means you connect nothing to the WAN port of the 524, the 524 must have its DHCP disabled, and preferably the LAN interface to access the WEB admin of the 524 changed to be in the same address space as the 502. By default the 502 will have a DHCP range of 10.1.1.2-10.1.1.254, I recommend that you shift that to 10.1.1.20-10.1.1.254 to allow for static IPs., then place the 524s LAN address at that static area, dont worry about the WAN IP of the 524 as you no long will use it. Now connect a LAN port of the 502 to a LAN (not WAN) port of the 524 and your on your way.

You will now access the 524 admin via the assigned static ip, start by turning off all the encryption and get your Wifi going then progress to lock it down.

Cyril



172 posts

Master Geek


  Reply # 131255 16-May-2008 13:48
Send private message

Hi

Thanks for the reply. Is adsl2+ the difference between a negII or a gen!?

I have an adsl2+ modulation option. Otherwise where is the version number?

Anyway, it sounds like a good option. I have disabled DHCP. I am working on the ip ranges etc. How do you change the ip range in the 502T?

The bit I seem to be struggling with at the moment is connecting again. I have taken out all the encryption etc but it wont connect so I am in the process of restarting everything.
Once I have finally got it to connect I will get back to you.

Thanks for the reply.



172 posts

Master Geek


  Reply # 131259 16-May-2008 13:57
Send private message

cyril7: If you have a GenII 502T
No1Daemon:  I don't think I have a genII 502T as it has version A5 on the back. Is that right?


then you can operate it in half bridge mode and bypass its router and use the 524s router, or you can leave the 502T as normal and bypass the router in the 524. I suggest the latter is the easist and what I prefer to do.


Therefore dont use the 524 as a router, just an AP, this means you connect nothing to the WAN port of the 524, the 524 must have its DHCP disabled, and preferably the LAN interface to access the WEB admin of the 524 changed to be in the same address space as the 502. By default the 502 will have a DHCP range of 10.1.1.2-10.1.1.254, I recommend that you shift that to 10.1.1.20-10.1.1.254 to allow for static IPs., then place the 524s LAN address at that static area, dont worry about the WAN IP of the 524 as you no long will use it. Now connect a LAN port of the 502 to a LAN (not WAN) port of the 524 and your on your way.

You will now access the 524 admin via the assigned static ip, start by turning off all the encryption and get your Wifi going then progress to lock it down.

Cyril



6024 posts

Uber Geek
+1 received by user: 154

Trusted

  Reply # 131260 16-May-2008 13:57
Send private message

In the 502 in the DHCP setting, page41 of manual (which should be enabled) adjust the start range to 10.1.1.20, this gives 10.1.1.2-10.1.1.19 as a statci area you can define printers or other fixed network assets.

In the 524, page 17 of manual set the IP address to 10.1.1.2, subnet 255.255.255.0, page 18 describes how to disable DHCP.

Once all is done, and all setting saved and rebooted, you should be able to access the 524 on 10.1.1.2.

Cyril

85 posts

Master Geek


  Reply # 131262 16-May-2008 14:05
Send private message

Sounds like you have the wireless AP acting as a bridge which is simple and all you need.

Looks like the 524 has both a WAN port and a 4x LAN ports on it. You should have the 524 connect to your adsl router via one of the LAN ports and have DHCP disabled on the 524.

Turn off WEP and verify it still works. If it does then you have a problem with the WEP setup.

WEP can be a pain to get working with the long keys, one typo and things dont work. Try WPA, all you need for that is a pass phrase, much easier to remember and WPA is more secure.

Half bridging makes things more complicated, not sure why cyril7 suggested that.



172 posts

Master Geek


  Reply # 131266 16-May-2008 14:51
Send private message

If I wait for ages, and I mean ages. Like leave the room and have a coffee or something. It will say it is connected.
WEP is off.
I am having trouble when I connect directly to the 524 via ethernet cable the local area network will not aquire a network address so I cannot go into the web configuration of the 524 to check the wep settings there.

Would you be able to give me the setup in plain english from scratch a bit at a time and we can see where it is falling over?

6024 posts

Uber Geek
+1 received by user: 154

Trusted

  Reply # 131267 16-May-2008 14:53
Send private message

If you have a GenII 502T then you can operate it in half bridge mode and bypass its router and use the 524s router, or you can leave the 502T as normal and bypass the router in the 524. I suggest the latter is the easist and what I prefer to do.



I never suggest half bridge as the prefered method as you can see from my original reply. That post and those since have all described using the 524 as a bridge rather than half bridging the 502.

Cyril

6024 posts

Uber Geek
+1 received by user: 154

Trusted

  Reply # 131268 16-May-2008 14:55
Send private message

So just to check can you connect your PC via cable to the 524, will it obtain an IP and can you connect to the internet, just checking each stage at a time, then we will sort the WiFi.

And assuming it does work,get a command prompt up and type in ipconfig /all and post what it says.

Cyril



172 posts

Master Geek


  Reply # 131274 16-May-2008 15:24
Send private message

When I connect from pc to lan port on the 524 now it says acquiring network address for ages and then comes up saying limited or no connectivity on the lan.

I have reset the 524 at the back again to undo any changes but still no good.

The lan is set to obtain an ip adress automatically, is that the right setting?

I am just trying to access the web configuration page of the 524 which should be 192.168.0.1

Obviously it cant connect to the internet because I have unplugged the ethernet cable from the 502 in order to plug it into the 524 to access the web url

6024 posts

Uber Geek
+1 received by user: 154

Trusted

  Reply # 131277 16-May-2008 15:44
Send private message

I suspect your PC has a 10.1.1.X address so will not work in 192.168.0.X, I assume you turned DHCP off in teh 524 but did not change the LAN address, so to get around that pickle you must set a static address for your PC, say 192.168.0.1 subnet 255.255.255.0 and then you should be able to talk to the 524, set its lan address to 10.1.1.2, then reboot it, now if you set your PC back to DHCP and have the 502 and 524 connected (via a LAN port of the 524) you should be able to see both and the internet, your PC should pickup an address from the 502.

Cyril



172 posts

Master Geek


  Reply # 131281 16-May-2008 15:53
Send private message

But if I set my lan ip address to the static one you suggest 192.168.0.1 then it will be the same as the ip address for the 524. Which is now reset so the DHCP is on again.

Anyway, just in case, I tried what you suggested. I unplugged the ethernet cable from the 502 and plugged it directly into the 524 then Set the lan ip to 192.168.0.1 and subnet to 255.0.0.0 and then restarted the lan connection and it connected straight away but when I tried to enter 192.168.0.1 into the url address it wouldnt find anything.

In the DHCP settings in the 502t at some stage there has been a dynamic ip set up as 10.1.1.3

Ipconfig/all reports this:Windows IP Configuration

        Host Name . . . . . . . . . . . . : Steve
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : Yes
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
        Physical Address. . . . . . . . . : 00-0E-9B-B0-32-C5
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        Autoconfiguration IP Address. . . : 169.254.112.220
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : SiS 900-Based PCI Fast Ethernet Adap
ter
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 10.1.1.20
        Subnet Mask . . . . . . . . . . . : 255.0.0.0
        Default Gateway . . . . . . . . . : 10.1.1.1
        DHCP Server . . . . . . . . . . . : 10.1.1.1
        DNS Servers . . . . . . . . . . . : 10.1.1.1

I removed my mac address but all the rest should tell you something I hope.


1742 posts

Uber Geek
+1 received by user: 240

Subscriber

  Reply # 131296 16-May-2008 17:56
Send private message

Normal to have 24 bit subnet mask (255.255.255.0) with class c address, i.e, 192.168.0.1 with a subnet of 255.0.0.0 can cause issues given that some web sites have addresses starting with 192, instead of accessing the Internet you would get routed to the local interface.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




172 posts

Master Geek


  Reply # 131310 16-May-2008 18:55
Send private message

I tried setting the lan ip to 192.168.0.1 and subnet to 255.255.255.0 and it says its connected but will not let me browse to 192.168.0.1 for the web configuration of the router.
Should I have a default gateway as well?

Anything else I can try?
I tried 10.1.1.20 with subnet 255.255.255.0. Also no go.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Symantec protects data everywhere with Information Centric Security
Posted 21-Sep-2017 15:33


FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53


Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51


Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39


If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54


Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07


OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56


Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48


Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37


Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45


Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40


Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27


NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16


Windows 10 Fall Creators Update coming Oct. 17
Posted 4-Sep-2017 14:10


Garmin introduce Garmin vivoactive 3
Posted 1-Sep-2017 18:38



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.