Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




3 posts

Wannabe Geek


Topic # 223810 18-Oct-2017 12:12
Send private message

Hi all,

 

I'm with 2Degrees for my VDSL (formerly SNAP as far as I can tell but they'd changed before I signed up).  I want to move my FritzBox out of the job it's doing as a firewall and router and relegate it to be nothing but a wifi gateway and handle phones.

 

I have my old Spark VDSL modem - an HG630b - which I can get to connect via VDSL to 2Degrees just fine.  It works nicely in either bridged mode or handling the PPPoE and routing itself - I get internets.

 

I want to run in bridged mode and use my shiny Mikrotik router - a CCR1009-7G-1C-1S+ - to handle the PPPoE and routing.

 

 

 

I have switched the HG630b into bridged mode, bound to eth4 (keeping eth1 for management etc).

 

I have created a VLAN on eth1 on the Mikrotik with VLAN-ID 10, then created a pppoe client connection and bound it to the newly created VLAN.

 

If I run a PPPoE scan on the VLAN, I can see "SNAP-69" and a MAC address, suggesting that it's working correctly, but I can't get the PPPoE client state to do anything other just sit at "Connecting...".

 

 

 

When I unplug the phone line from the HG630b it switches status to: "disconnected".

 

My setup:

 

Regular boring ethernet cable from ether1 on the Mikrotik to LAN4 on the HG630b

 


/interface ethernet
set [ find default-name=ether1 ] advertise=10M-full,100M-full,1000M-full arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1580 loop-protect=\
default loop-protect-disable-time=5m loop-protect-send-interval=5s mac-address=64:D1:54:E6:EB:F1 master-port=none mtu=1500 name=ether1 orig-mac-address=64:D1:54:E6:EB:F1 rx-flow-control=off speed=100Mbps \
tx-flow-control=off
/interface vlan
add arp=enabled arp-timeout=auto disabled=no interface=ether1 loop-protect=default loop-protect-disable-time=5m loop-protect-send-interval=5s mtu=1500 name=vlan10 use-service
/interface pppoe-client
add ac-name=SNAP-69 add-default-route=yes allow=pap,chap,mschap1,mschap2 default-route-distance=0 dial-on-demand=no disabled=no interface=vlan10 keepalive-timeout=60 max-mru=
2Degrees-PPPoE password=password profile=default service-name="" use-peer-dns=yes user=username@snap.net.nz


I can't figure out what I'm missing, it seems like this should just work.  Does anyone know where I'm going wrong?

 

Many thanks and kind regards,

 

char


Create new topic
1925 posts

Uber Geek
+1 received by user: 296

Lifetime subscriber

  Reply # 1885701 18-Oct-2017 13:35
One person supports this post
Send private message

My guess is that traffic from HG630 is untagged.





Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




3 posts

Wannabe Geek


  Reply # 1885740 18-Oct-2017 14:52
Send private message

I'd configured the VDSL interface on the HG to tag VLAN10 via the "Basic -> Link Interface -> VDSL" screen.  Although I'd have assumed that the entire thing wouldn't work if that were the issue surely? ie the HG works pretty well on it's own in router mode instead of bridged.  It's when I bridge and try to use the Mikrotik that everything stops working.


 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


3 posts

Wannabe Geek


  Reply # 1885750 18-Oct-2017 15:00
Send private message

SUCCESS!

 

On a whim, I tried turning off the VLAN tagging on the HG.  Suddenly everything started working, thank you so much for pointing me that way!


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Exhibition to showcase digital artwork from across the globe
Posted 23-May-2018 16:44


Auckland tops list of most vulnerable cities in a zombie apocalypse
Posted 23-May-2018 12:52


ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.