Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


Topic # 229021 3-Feb-2018 22:33
Send private message

Hi there,

 

Vodafone have 'upgraded' my internet to FibreX 200/20 and with it replaced the various pieces of equipment I had with a technicolor cable modem and seperate router. I have a Mikrotik router configured and managing all my home devices well and do not want to transfer them all to the new router (which does not seem to like the number I devices I tried to connect).

 

I have been trying to set up the Mikrotik to directly connect to the technicolor cable modem (following this guide - https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084, but also setting up dhcp client for IPv6) but cannot get a working connection.

 

I have:

 

1) connected the Mikrotik directly to the technicolor cable modem

 

2) run through the guide above to enable vlan tagging / dhcp / changed firewall rules etc (and enabled ipv6 too)

 

3) confirmed I am receiving an IPv4 and IPv6 address in the dhcp-client section of the mikrotik

 

4) restarted everything just in case

 

5) failed to get a connection to the internet

 

6) tried factory resetting the mikrotik incase any old rules were breaking something

 

7) still failed to get a connection to the internet

 

This has all got a bit beyond me - I have enough knowledge to follow various guides, but not enough to troubleshoot / diagnose what is actually happening here (i.e. enough knowledge to break something... but not fix it). From the guides I have read, once I have confirmed I am getting dhcp to provide IP address from the technicolor / vodafone, and provided I have the firewall configured correctly, I should be getting internet, but I am not.

 

Any help would be appreciated.


Create new topic
Meow
7373 posts

Uber Geek
+1 received by user: 3540

Moderator
Trusted
Lifetime subscriber



8 posts

Wannabe Geek


  Reply # 1951306 4-Feb-2018 10:15
Send private message

michaelmurfy:

 

Did you read through the IPoE instructions here? https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084 

 

 

Thanks michaelmurfy

 

I did - and followed through exactly first time - second / third time (after reset mikrotik), the first highlighted rule (Drop all from WAN) was no longer there. I had the following (and have tried the drop invalid both with the Vlan interface as in interface and with nothing):

 

Click to see full size

 

I do note I have not changed any of the IPv6 Firewall rules, which look like this:

 

Click to see full size

 

Click to see full size

 

I did update the NAT masquarade rule (as follows):

 

Click to see full size

 

I still do not have internet (but still showing has received IP address in DHCP Client for both IPv4 and IPv6).

 

Thanks very much for the assistance - happy to provide more screenshots / try out ideas.


 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


8 posts

Wannabe Geek


  Reply # 1954578 9-Feb-2018 22:05
Send private message

Figured out what was going wrong - 2 of the default rules once resetted the Mikrotik were different from what needed to be. What I did to fix was:

 

1) Create a new firewall rule with: Chain=input, In.Interface=VLAN (my default firewall rules did not have this rule and I was editing another rule I should not have); and

 

2) change my Masquerade rule, which was pre configured with an out.interface.list - once removed the out.interface.list, internet came back up.

 

Hope helps someone else - the original Mikrotik guide here (https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084) worked a treat, my default config was just starting from a different point.

 

Glad I have my lovely stable and secure router back!


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41


Exhibition to showcase digital artwork from across the globe
Posted 23-May-2018 16:44


Auckland tops list of most vulnerable cities in a zombie apocalypse
Posted 23-May-2018 12:52


ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.