Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

4 posts

Wannabe Geek

Topic # 26875 6-Oct-2008 14:16
Send private message


I found this article relating to using a Dlink DSL502T in half bridge mode:

I've had many late nights trying to get my VPN tunnel working between AKL and Welli where I have the following setup


1x Dlink DSL502T
1x LinksysWRV200 behind the DSL502T
Static IP assigned from Telstra


1x Dlink DSL502T
1x LinksysWRV200 behind the DSL502T
Static IP assigned from Xtra

I can get the tunnels to see each other, but I get the old expecting IP address , but got message:
014 [Wed 12:40:42] "TunnelA" #5: transition from state STATE_MAIN_I2 to state STATE_MAIN_I3
015 [Wed 12:40:42] "TunnelA" #5: STATE_MAIN_I3: sent MI3, expecting MR3
016 [Wed 12:40:42] "TunnelA" #5: Main mode peer ID is ID_IPV4_ADDR: ''
017 [Wed 12:40:42] "TunnelA" #5: we require peer to have ID '', but peer declares ''
018 [Wed 12:40:42] "TunnelA" #5: sending encrypted notification INVALID_ID_INFORMATION to

So to get the WRV200 to have the public IP address, I was going to use half bridge mode on the DSL502T, but for some reason it doesn't seem to pass it through to the WRV200.
The firmware I have on the DSL502T is V3.02B01T01.NZ.20071119.
I can see the status on the DSL502T says connected, and the Public IP is there, but even when I try bypassing the WRV200 with a Laptop and try to connect out, I cannot browse the internet.
I've rung D-Link and Linksys, but Linksys want me to at least be able to get the D-Link going, and D-link seem to think I come from the moon when I ask them questions

Can anyone help before I throw everything in the bin!



Create new topic
8020 posts

Uber Geek
+1 received by user: 386


  Reply # 169313 6-Oct-2008 15:26
Send private message

Yes when the ppoa half bridge setup is working properly the 502T should assign the public ip given to it by your ISP to be the wan ip of the WRV200 (via DHCP).

Does the Dlink have the latest firmware?

Is the Linksys set to get it's wan ip via dhcp?

What ISP/provider are you using at either end?  I ask because some ISP's (xnet, telstra etc) have their default gateway on a different subnet to the public ip address they assign and this confuses some halfbridge implementations.

Worst case scenario, bin the dlinks and get 2x Dynalink RTA1320's (they are sub $20 as new on trademe) I have several working perfectly in half bridge for me.  Note:  The half bridge option in the dynalinks is called ip extension and is in a weird part of the ui/menu heh.

4 posts

Wannabe Geek

  Reply # 169322 6-Oct-2008 15:45
Send private message


The Telecom gateway is definitley on a different address range than the IP that it's asiggned. From memory it's on a 125 subnet, whereas the IP is 203 something.

I have a firmware to try from D-Link, it's DLinkNZ_DSL-502T_singleimage_kernel_fs_V3.02B01T01.NZ.20080827, so just got to make sure it's right for one of the D-Links, will try it on Wednesday night and see how it goes. I have tried DHCP, but nothing seemed to happen.

I may not have given it enough time though, it was 3am, and I was getting a bit tired.
So I should have DHCP enabled on the D-Link?

Cheers for responding.


4 posts

Wannabe Geek

Reply # 170015 8-Oct-2008 22:43
Send private message

Well I've just messed around with again for another few hours and tried the following:

1. reset the D-Link router to factory, upgraded to the latest firmware
2. Put back in all username and password, plus the static IP assigned from Xtra
3. Tested connecting to the internet in PPOA/PPOE mode, with the D-Link plugged into my laptop, the D-link had DHCP enabled, this worked fine.
4. Put D-Link into half bridge mode, left the DHCP enabled. Saved and rebooted. It still handed out the internal LAN interface DHCP range, and I couldn't connect to the internet at all.
5. Set bridge filters to any any from any mac address with any protocol, no success.
6. Tried configuring a static IP on the laptop of the public IP, disabled DHCP on the D-Link, saved and rebooted D-Link, no success.
7. Disabled firewall, have tried it with nat disabled and enabled as well.

So now I'm going to try the Dyanlink path, I have one at home, will have to check the model, but I think it does have Half Bridge, or Bridge mode.
If this fails, will get go for Cisco kit, as I'm runnning out of patience!


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47

Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25

New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48

Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48

Oppo R11s: high-end Android, budget price
Posted 27-Feb-2018 16:27

Samsung New Zealand introducing the Galaxy S9 and S9+
Posted 26-Feb-2018 07:00

Fujifilm X beats its best with new top of the range, high-performance camera
Posted 24-Feb-2018 14:05

One million kiwis affected by cybercrime
Posted 24-Feb-2018 13:58

New Zealanders want to engage with government online and via mobile apps
Posted 24-Feb-2018 13:56

Samsung launches Samsung Max
Posted 24-Feb-2018 13:52

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43

Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27

2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21

Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.