Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




39 posts

Geek


Topic # 57090 2-Feb-2010 19:26
Send private message

Hi,


My situation is this: I have a Netgear DG834 modem/router providing my broadband connection. I have a laptop (running Vista Home Premium) connecting to the DG834 via wireless, and this works fine. I also have a desktop PC (running Ubuntu) connected to the laptop via gigabit Ethernet. I would like to share the internet connection so the Ubuntu PC can access it via the laptop.


However, so far no joy. When I attempt to enable sharing on the Wifi connection I get the not-so-helpful "An error occurred while enabling internet connection sharing" message. I Googled the error and found a couple of possible causes, the first of which being non-running services, which I then enabled. No joy. I then thought it was a problem with the router grabbing 192.168.0.1, so I changed the IP address of the router to 192.168.0.2 but left the DHCP range as 192.168.0.1 to 192.168.0.254. Still no joy. I tried making sure that both the Wifi connection and the Ethernet connection were set as Private networks. No joy.


I'm running out of ideas now. I've had a search on the forums and they only seem to suggest the things I've already tried. Any fresh ideas?


Thanks,


Martin

Create new topic
BDFL - Memuneh
59617 posts

Uber Geek
+1 received by user: 10777

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 295572 2-Feb-2010 22:18
Send private message

When setting up an ICS the FROM adapter will be changed to use 192.168.0.1. You will have to manually add gateway, DNS, etc.

You have to "reserve" that address. Change your router (as you did) and make sure the router DHCP is configured properly.

In your case your PC is 192.168.0.1 and your router 192.168.0.2... But your DHCP range starts at 192.168.0.1 - which obviously may case some problems from the start.

First. fix the DHCP configuration. Make sure no other PC is using that address and start again.







39 posts

Geek


  Reply # 295574 2-Feb-2010 22:23
Send private message

Thanks for the response. So to clarify (I'm not a networking genius, I just know enough to be dangerous!):

I need to set my DHCP range to be ABOVE the address of the router (i.e. 192.168.0.3 onwards)? Once I've done this I guess I should reboot both machines (laptop and PC) to make sure neither of them (nor the router) can grab 192.168.0.1, yes?

Cheers,

Martin

 
 
 
 


8020 posts

Uber Geek
+1 received by user: 386

Trusted
Subscriber

  Reply # 295575 2-Feb-2010 22:23
Send private message

IIRC you can change the ip address etc ICS uses by editing the registry so it doesn't use .1

BDFL - Memuneh
59617 posts

Uber Geek
+1 received by user: 10777

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 295578 2-Feb-2010 22:28
Send private message

"No network engineer" = "Don't change registry".

Yes, make sure DHCP starts from 3...






39 posts

Geek


  Reply # 295580 2-Feb-2010 22:55
Send private message

I think I'm almost there, thanks Mauricio.

I changed the DHCP range to start at 192.168.0.3. I then rebooted everything, just to be sure. I then fixed the IP address on the LAN adaptor to 192.168.0.1 (plus set the default gateway and DNS servers to the relevant values) and successfully enabled sharing on the Wifi adaptor!

However, the desktop PC (connected to the LAN adaptor on the laptop) still can't see the internet. Is there anything I need to change on the desktop PC?

(and yes, I definitely don't fancy hacking around in the registry!)


BDFL - Memuneh
59617 posts

Uber Geek
+1 received by user: 10777

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 295593 3-Feb-2010 00:06
Send private message

It "can't see the Internet" as in can't go to a website? IF you open a command prompt and type "ping www.geekzone.co.nz" what does it say?

If it says "can't resolve server" then your configuration doesn't include the correct DNS. Have you entered the DNS in the fields?








39 posts

Geek


  Reply # 295809 3-Feb-2010 19:10
Send private message

If I try and ping www.geekzone.co.nz... from the desktop PC I get "can't resolve server".

If I try and ping 66.249.89.99 (Google) from the desktop PC I get no response.

I have definitely specified the DNS servers in the network settings for the LAN adapter on the laptop. Do I also need to set them on the desktop PC? If so, should they be set to the same values as on the laptop, or to 192.168.0.1?

In the Network Connections control panel on the laptop I have 2 connections:
Local Area Connection - access to Local only
Wireless Network Connection - shared, access to Local & Internet

I feel I'm very close to a solution!

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43


Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27


2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25


Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.