Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




21 posts

Geek


Topic # 90156 15-Sep-2011 23:13
Send private message

Hi can anyone help me with the settings for draytek 120 and pfsense
Ive been trying really hard and i just cant get them to work together....

Ive looked at tons of posts about ppl using this setup but its doing my head in..
I can use the draytek on its own.
And i can connect to pfsense np.

I get a dynamicIP from vodafone.

For you ppl that have it working successfully, what do you change and what order do you do it in..

please help me :/









Create new topic
341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 521755 16-Sep-2011 07:37
Send private message

On the Vigor120, you just need this box ticked, and everything else on default options.



Then you just set up a normal PPPoE connection on the pfSense box.

1332 posts

Uber Geek
+1 received by user: 152
Inactive user


  Reply # 521766 16-Sep-2011 08:07
Send private message

You change all the settings you require, I turn all applications (firewall etc...) first but you must remember to turn NAT off last as that reboots the modem and will not assign you an IP when it comes back up so accessing it will be impossible.

 
 
 
 


1984 posts

Uber Geek
+1 received by user: 133

Trusted

  Reply # 522199 16-Sep-2011 23:42
Send private message

You probably want to tick the "always on" box instead of havingit login every time you try to use it.

I had problems with my new router last week too, eventually set the modem to PPPoA VCmux Bridged and put PPPoE login details into the wifi router (as opposed to half bridge, where my ancient modem seemed to cause DNS problems).




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 522292 17-Sep-2011 11:34
Send private message

@webwat: The Always On setting on a Vigor120 is disabled when in pass-through mode, since the router is completely responsible for managing the connection (as opposed to half-bridge mode where the modem is still responsible for handling the PPP dialing)



21 posts

Geek


  Reply # 522322 17-Sep-2011 13:53
Send private message

@TheEd: Thanks its working perfect now!

If I want to access the draytec again do I have to plug a pc right into it tho?

470 posts

Ultimate Geek
+1 received by user: 116

Lifetime subscriber

  Reply # 522352 17-Sep-2011 15:16
Send private message

I've got a pfsense box (2.0 RC3) hooked up to a Draytek Vigor 120 and have set it up so I can access the Draytek. My pfsense box connects through PPPoE passthrough as in the instructions above.  

There are a few guides on the pfsense forums on how to set up access to a PPPoE modem, which are all quite complicated. I couldn't get any of them to work, but used some of the instructions to put together a solution. In the end my solution was quite simple:

1) Set your Draytek with an IP on a different subnet to your pfsense box, for example with your pfsense box on 192.168.1.1 and your Draytek on 192.168.2.1.
2) Make sure the DHCP server is ENABLED on the Draytek.
3) On your pfsense box under the interfaces tab you should currently have at least two interfaces set up: WAN and LAN. LAN will likely be assigned to a physical port (e.g. vr0). WAN will be set to PPPoE (e.g. PPPOE0(vr1)). Create a new interface and assign it to the physical port which the PPPoE connects over (in my this example vr1).
4) Configure the new interface to obtain an IP address using DHCP and give it an name such as MODEMACCESS.
5) Save all your settings. The new interface should get an IP from the Draytek, and you should be able to connect to it on 192.168.2.1.

Hopefully I haven't missed anything!

470 posts

Ultimate Geek
+1 received by user: 116

Lifetime subscriber

  Reply # 522577 18-Sep-2011 10:24
Send private message

I did manage to miss a step.

Between 4) and 5) it looks like you also need to add a new rule to Firewall : NAT : Outbound. Switch to Manual Outbound NAT rule generation if it's not selected already, and create a new rule for the MODEMACCESS interface with source network 192.168.1.0/24 and destination network 192.168.2.0/24.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.