Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

12 posts


# 201803 4-Sep-2016 15:02
Send private message

I'm quite new with Android Tables but I have a technical background.  Hopefully there are experts here who are willing to help me out a bit.


About 3 months ago I bought a K960 (MTK8752) from here:


It was really great for what I was doing.  No complaints at all.  I recommended it to a friend and he bought one also.


His worked fine the first day. The battery got to about 30% so he put it on the charger overnight (charger has been verified OK). The next morning it wouldn't start.


He contacted the supplier and they sent him another one.  The first day he got it he was using it in bed and fell asleep. During the night he rolled over and cracked the screen.  But he didn't realize that until the next morning.  It would no longer work either.  I completely disassembled it and found the screen was not damaged...only the protective glass.  So I put it all back together.  I'm guessing it has the same or similar problem as his original one.


By the way, taking these things apart and putting them back together is a piece of cake compared to a laptop.

I would like to get his two tablets working again. I tried many of the tips and tricks I found on the internet.  No success with any of them.  So I took them apart and measured the battery voltage. It was quite low...about 3 volts. I un-soldered the positive battery wire and connect the battery to an external intelligent lithium charger. At the start of charging the charger indicated about the same voltage as my volt meter. Thought the charging process the charger screen displayed increasing battery voltage and varying current and the time to finish kept going up. After about 10-15 hours it said complete. I re-soldered the battery wire and still no boot.

They won't even boot to the recovery mode with volume up / power. At this stage they appeared to be totally dead but other observations tell me they are not completely dead...just in a coma. I have a little device that connects inline with a USB cable and it displays the voltage and current. When I connect the tablet through this device it shows some charging current for a little while then no current. When I push the power button for about 10 sec the current goes up to about 500ma for a couple of seconds then back to zero. So I know there is some life there.

I connected the bricked tablet to my pc and when I push the power button for about 10 sec the PC beeps and about 2 sec later it beeps again. I started device manager to observe what it said during the beeps. It temporarily shows a new com port then the com port disappears. When I push vol+ and power it shows a different com port for a couple of seconds then it disappears. In neither case does the tablet stay connected to the PC.

Considering the above, do you think these tablets can be unbricked?  Or do they need to show the recovery screen with vol+ and power buttons?




I found a pretty good website for un-bricking and studied the instructions quite thoroughly.




The reason for my questions above is the procecedure he describes seems to assume the tablet will  boot to recovery doesn't, but maybe it will work anyway?   More study made me wonder if the bootloader is locked and if this could be a problem with trying to un-brick.


I've done a lot of study and discovered a ton of terms that are new to me, but I'm confident I'll eventually understand this technology well enough to fix problems like this one.  


Any help would be greatly appreciated but I know how time consuming it is sending postings back and forth.  A direct phone conversation or meet up would be much easier.   However, such postings on this forum might be helpful to others.  So let's start that way.


Any help would be greatly appreciated.





View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2

12 posts


  # 1622953 5-Sep-2016 11:12
Send private message

I have made some progress.  I've managed to get all the software and drivers to connect to the bricked tablets.  In device manager the com port stays on the screen when running the flash tool.  I think the only help I need now is the correct ROM and scatter file for my device.


Below is what I have been able to find out about my device:


Looking at the working tablet, the system information in "About tablet" says k960 but (after taking it apart) the mother board says K107 2016-3-30.


Also in "About Computer" it says:




Model number:






CPU information


8 core 3.6G




Screen size:






Android Version:






Kernel Version:




buildserver@buildserver 3 #1


Sat May 7 12:31:42 CST 2016




Build number:






Custom build version:






Somewhere along the way I found something that led me to believe the maker was Jlinksz...forgot how I discovered that.




The advertising info where I bought the table said:


 9.6 inch tablet octa core MTK8752 3G GPS Android 5.1 4GB 64gb Dual Camera 5.0MP 1280*800 IPS Screen




I think that's about all I have been able to find out about this (these) tablets.  I have searched using the (not completely understood) information above but have been unable to find the correct ROM and scatter file.




If any of the above items describes (or gives a clue about how to find) the correct ROM and scatter file please explain it to me as I am still not familiar with all the technical terms, what they mean, and how they are related.




Any URLs or other helpful info would be gratefully appreciated.






Dan Lindsey

12 posts


  # 1625284 7-Sep-2016 21:37
Send private message seems no one wants to read through my long explanation or they are too busy to help.




However, I have made progress.  Finally got the right files to make Media SP Flash Tool ver 5.1436.0happy.  It loads properly and process the scatter file with no complaints.  From several observations it seems FT is recognizing my tablet, but everything I try results in BROM ERROR: S_BROM_CMD_STARTCMD_FAIL (2005).


Watching Device Manager while running FT I can see the com port pop up and if I quickly right click Properties it says "this device is working properly".


If I keep holding vol+pwr,  FT runs for about 5 sec then I get the above error and Device Manager releases the com port.


If I release pwr and keep holding vol+ , FT gives the above error immediately and the com port is released.


From observing a working tablet, it seems it powers up when the power button is matter how long you hold it.  


Since I get this error when I release the pwr button and the device powers up it seems FT doesn't like the device to power up at this stage (it has an internal battery)   


However, what about the case where I keep holding both buttons (per above) and FT runs for about 5 sec then I get the above error before I release the pwr button.  So it seems the problem is caused by something other than power up.


I guess I could unsolder the battery wire from the mother board and give that a try, but I think power up is not the problem since FT gives the error before power up.


Is there some other reason BROM CMD STARTCMD fails?


I have searched extensively for this error message and have many hits and recommended solutions but none of them have solved my problem.


I saw one solution directed exactly toward this problem and it said put a jumper on the mother board from KCOLA to GND.  I did that but it made no difference.  


Based on my 30 years experience in electronic design and manufacturing KCOLA is most likely one of several diagnostic test points on the mother board.  I couldn't find any real explanation about how KCOLA is used and what it does. Since it didn't help I guess I don't really need to know.  Just technically curious.


By the way, this tablet has not been rooted nor has Developer Options been turned.  It's pure factory stock.




Should it be able to be unbricked since I can see it is alive but in a deep comma?




Please help







10906 posts

Uber Geek

  # 1625300 7-Sep-2016 22:22
One person supports this post
Send private message

This guy links to a couple of different flash tools:

I have no knowledge in this area, so all I can say is, that was an interesting read and good luck.

12 posts


  # 1625329 8-Sep-2016 00:31
Send private message

As I mentioned earlier I have another identical tablet that is working.  I have been cautious about using it on SP Flash Tools until I become more competent at this. However, I yielded a bit and decided to connect it to Flash Tools and just do something RAM test.


Unfortunately (no I didn't brick it) I got exactly the same error message as I did with the bricked tablet.  So it seems this error message is  not caused by the bricked tablet.


Definitely I haven't got something right.   Sure would like some help.


Anyone up North (Kerikeri or even Whangarei) does this kind of work.  I'd pay to have it fixed...if I could watch!


Any help at all would be appreciated.

1905 posts

Uber Geek

  # 1625518 8-Sep-2016 11:23
Send private message

Youre assuming a re-flash will somehow fix a hardware fault  ?


1 had been sat on
the other simply died overnight .
Sounds like 2 hardware issues, rather than firmware issues




There are Ak companies that specialize in component level repairs on laptops/tablets etc, but that doesnt come cheap and wont be worth the
cost for generic chinese tablets
I dont think any tech will let you watch the repair, in fact most companies dont allow customers into the actual workshop (security reasons, cant keep an eye
on the cust while doing repairs) smile 







1905 posts

Uber Geek

  # 1625543 8-Sep-2016 11:47
Send private message

what you can try, is using a powerfull magnifying glass or similar, inspect the boards for cracks, obviously blown parts, components poorly soldered or crooked or missing(yes),
Inspect for splatters of solder etc. Try the batt out of the good one (worth a try) .


last ditch attempt may be a DIY reflow (plenty of youtube vids on that) : do that only when you've otherwise given up, it may make things worse


Bottom line is some of these cheapy chinese goods have zero quality control and higher than normal fail rate .
Add to that , they may have even been 'repaired' or faulty goods sold as new (it happens)

12 posts


  # 1626022 8-Sep-2016 20:12
Send private message

Thank you for your comments 1101.  There could be a hardware problem but that's not causing the error code I'm getting.  The identical tablet that is working responds to SP Flash Tools exactly the same way as the bricked ones do.  So that makes me think the error code I'm getting is caused by something else not being right with what I'm doing. 


I haven't been able to find the ROM for EXACTLY this device but I have found ROMs for devices that have the exactly same specifications.  I'm not sure how closely the ROM I'm trying to flash needs to be to the actual device.  No experience with this.


By the way, on the working tablet, I went to Developer Options and unlocked the boot loader.  Got the same error message.



10906 posts

Uber Geek

  # 1626054 8-Sep-2016 20:56
Send private message

Can you try a different flash tool?

588 posts

Ultimate Geek
Inactive user

  # 1626078 8-Sep-2016 21:27
Send private message

Also have no experience with SP Flash Tools however as you mention there's a slew of information online:




Meaning: The device attempted to power on before SP flash tool could flash files to it


* Take out and reinsert the battery
* Try using a different USB cord, port and PC
* Right-click flash_tool.exe > Select Properties > Select Compatibility > Set to Windows XP Service Pack 3 > Click Apply > Click OK > Run SP flash tool as Administrator
* Try a different USB cord
* Try a different port on the PC or another PC
* Ensure the battery is well changed and inside the switched off phone before connecting to PC for flashing



Looks like it could be a software / dependency issue as looks to be pretty fragile.


I'd try different compatibility settings as above;


- Avoid Windows 8 & 10, go either 7 or maybe XP if you can.


- 32-bit vs 64-bit may make a difference.


- Run as admin, disable any UAC etc, check file permissions.


- Ensure you have the relevant drivers install.


- Test for non-alerted dependencies such as: .NET Framework 4.5, Visual C++ Redistributable etc

12 posts


  # 1626084 8-Sep-2016 21:49
Send private message

I tried WiseLinkTool v (WLT)  After selecting download agent and scatter file everything seems to load OK.  


Then I click download and nothing happens.  Then I connect the tablet and nothing happens.  Then I push both buttons and a couple of seconds later I can see/hear the com port connecting and immediately WLT says Status: download DA now....69.16kb/69.16kb.  But the progress bar across the bottom does not show any change...just blank.  Then about 10 seconds later I get an error message and the com port is released.  The com port is released AFTER I get the error message:


SOFT_ENABLE_DRAM_FAIL  (Error Code 4032)


When I was searching for the meaning of this error code one guy said:   That error 4032 probably means the files you're using dont match your phone.


I'm beginning to think that is the problem.  As I said before I have not been able to get the ROM that I'm sure matches my tablet.


Can you tell me how critical it is to have a ROM that EXACTLY matches my tablet?


Also while researching this error code someone else struggling with this error code said he installed the MediaTek DA VCOM driver and that solved his problem.


I just downloaded and install this driver but Windows said I have to reboot before it will work.  I haven't tried it yet because I don't want to loose all the typing of this posting.  But I'll reboot and try it now.


Thanks for you help.

588 posts

Ultimate Geek
Inactive user

  # 1626105 8-Sep-2016 22:14
Send private message

First step is to continue to unit / isolation test as you're doing.


Work on getting your operational device to talk to the software consistently so you can rule out any hardware or compatibility issues with the poked one.


Next you should be able to recover the boot.img from the working one:


Then attempt to flash it to the faulty one. If you don't have luck with this step then attempt to test and/or isolate individual hardware components;


- inspect PCB and components.


- replace battery with bench top power supply.


- swap LCD etc with working one.


As @1101 suggests; if all else fails - reflow!

12 posts


  # 1626146 9-Sep-2016 01:27
Send private message

Thanks to those who are providing assistance.  Greatly appreciated.


The last pending item was to install the MediaTek DA VCOM drivers.  I did that and notice that when that driver was listed in Device Manager under Ports it was always there and always had the yellow caution mark to the left.  That was the only driver listed in Ports.


 When the tablet connected the "DA" driver continued to have the caution mark and a new driver popped up and did not have the caution mark.  That one was MediaTek USB Port Com 4.  


That was always the case no matter what other drivers I had loaded...and I've tried many per google suggestions.  


Some of the other drivers I installed were never seen in Device Manager and some were seen with caution marks and some were seen without caution marks but every time a connection was made with the tablet the MediaTek USB Port Com 4 always popped up.


I uninstalled the MediaTek USB Port Com 4 driver and when I connected the tablet that driver was automatically installed.  While that driver was active in Device Manager I quickly right clicked it and looked at in Properties / Details / Inf Name / it was oem55 .inf.  The inf file was found in Windows\inf.  I opened the Windows\inf folder and sorted by date and found probably all the drivers I had installed in the last week...maybe 20 Android MTK, Intel, Microsoft, Google, and others.  I don't really know that much about how uninstalling a driver works but the ones I uninstalled are still in Window\inf.  It seems you would have to manually delete them to completely get rid of them.  I renamed oem55.inf and tried it again and it still loaded when I connected the tablet...maybe from a cache.  I'll have to reboot and see when happens when I connect the tablet.  I'll continue after reboot.

12 posts


  # 1626148 9-Sep-2016 02:14
Send private message

Well, it still loaded the MediaTek USB Port Com 4 driver.  Don't know exactly how but I'll let that go for now.  It seems com4 is the communications path between the tablet and the pc  but I'm not sure why the other driver(s) don't show up in Device Manager when communicating with the tablet.  But I'm not an expert on how Windows works in terms of displaying drivers in Device Manager.  I suppose some drivers that are actually being used do not show in Device Manager.  


Another driver question I'm wondering about is the case when I loaded the MediaTek DA VCOM driver and it showed permanently in Device Manager but always had the yellow warning mark...even when the tablet was connected.  That just doesn't sound right to me.  Ig that's the driver that is really needed (as several people said) it seems the yellow warning mark should never be there or at least it should go away when connected.


It seems this could be a major issue.  Any expert opinions on this? 

588 posts

Ultimate Geek
Inactive user

  # 1626165 9-Sep-2016 07:03
Send private message

If you right click on the driver in device manager and goto properties it will tell you what is wrong with it. 


Then goto driver tab > uninstall; it should come up with a tick box to option to "deletes files", tick that and it should remove the corrosponding driver inf so it isn't automatically reloaded. Don't worry about what else is in the DRIVERINF folder, it only matters what it actually loads for the device. 




If it's loading a generic driver you may need to disable driver auto install:




Then scan for hardware changes in device manager and see what is loaded. If not the correct one goto properties > driver again and select update driver and manually select the driver inf you want. 





12 posts


  # 1626808 10-Sep-2016 00:06
One person supports this post
Send private message

First of all, thank you very much to those who have been assisting me.  I have made some progress.  Now SP FlashTools is loading everything properly and all the operations start and the red line at the bottom moves quickly across the screen and I it says Download DA 100%.  The tablet stays connected for about 10 seconds and then the tablet disconnects and I get an error message:


BROM Error 4032 - Please be sure your load matches your target.


I'm pretty sure that's a correct statement.  I downloaded a ROM for a device that uses the same MTK chip and has similar hardware specs as my tablet...QMobile M350 phone.


 The folder I downloaded contained a copy of SP Flash Tools, Download Assistant and Firmware.  Using everything from that package got the result above.  


Now if I could just get the ROM package for my tablet maybe the bricked tablet


I'm afraid to try and get the ROM from the working tablet because I fear I might do something wrong and brick it too.






I have found one ROM for a device whose description by the poster sounds very very close to my tablet.  Like me he bought it on Alibaba and it has all the same specifications except for memory.  His has 4gb /32b and mine has 4gb/64gb.  The outside appearance seems to be identical.  He posted all the numbers on the mother board and they are the same as mine except for the date...mine is newer.  And his has Android 5.1 while mine has 5.2.


I need to spend some time learning what to do with his package of files containing 10-12 img files and 3 db files.  I tried to extract them with 7zip and WinZip.  7zip extracted 2 of the 12 img files and WinZip could extract none.  Below is the listing of the files:


04/03/2016 12:17 PM            135,333         AFA013M0.db
04/03/2016 12:17 PM         7,677,952        JBFA013M0.img
04/06/2016 12:41 PM       21,270,952        JCFA013M0.img
04/03/2016 12:17 PM         8,388,912        JHFA013M0.img
04/03/2016 12:16 PM         2,130,484         JLFA013M0.img
04/03/2016 12:15 PM            125,320   JPFA013M0-M3.img
04/03/2016 12:17 PM         8,751,104         JRFA013M0.img
04/03/2016 12:17 PM       70,591,608         JSFA013M0.img
04/03/2016 12:15 PM              44,032         JTFA013M0.img
04/03/2016 12:15 PM            373,696         JUFA013M0.img
04/03/2016 10:55 AM            135,168         JXFA013M0.img
04/03/2016 12:17 PM   1,210,050,972         JYFA013M0.img
04/03/2016 10:55 AM          7,622,787    OFA013M0_ltg.db
04/03/2016 10:55 AM         8,212,940    OFA013M0_lwg.db


I may go quite for a while as I need get more educated about the ROM formats.


But if anyone has any suggestions to offer I would certainly like to receive them.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36

MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28

Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15

D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31

Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29

Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24

Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59

Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07

Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02

Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41

Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36

2degrees Reaches Milestone of 100,000 Broadband Customers
Posted 1-Oct-2019 09:17

Nokia 1 Plus available in New Zealand from 2nd October
Posted 30-Sep-2019 17:46

Ola integrates Apple Pay as payment method in New Zealand
Posted 25-Sep-2019 09:51

Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.