Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


21 posts

Geek


Topic # 30364 5-Feb-2009 15:30
Send private message

Hi there,
I started watching Prison Break last night on TV3 via MySkyHDi and noticed that the HD information at the beginning of the show displayed as HD5.1 Surround. My Sony AV Receiver(connected via optical for sound and HDMI for video) showed that the signal was in Dolby Digital but only displayed the 2 channel graphic and tHE sound was also only 2 channel. I checked that I was using the English ALT setting giving me Dolby Digital and not AAC. (Switching to TV2 changes the Sony AV graphic to Linear PCM ilke it should so i assume thta the SkyHDi is configured correctly)
I switched over to Freeview on my HTPC using Windows 7 and this displayed the 5.1 graphic and had full 5.1 sound.
Is that normal for the SkyHDi unit or does my setup need tweaking in some way?

Create new topic
348 posts

Ultimate Geek
+1 received by user: 25


  Reply # 194441 6-Feb-2009 10:58
Send private message

You may have to tell your AVR to use optical for the mysky audio rather than hdmi. Often AVRs have an auto setting but HDMI usually has precedence so you need to tell it to use the other audio source.



21 posts

Geek


  Reply # 194454 6-Feb-2009 12:31
Send private message

Thanks for the reply.
I've just tried unplugging the HDMI cable and still had sound from the HDi box so the AVR must be using optical. When I change channel away from TV3  the AVR changes to Linear PCM 2 channel at 48KHZ then when I change back to TV3 the AVR changes to Dolby Digital 3/2.1(which is the Sony way of showing 5.1)
Any other suggestions?

348 posts

Ultimate Geek
+1 received by user: 25


  Reply # 194513 6-Feb-2009 18:40
Send private message

Yes you will get sound if you unplug the HDMI. Was a DD5.1 program playing when you did it? If not you haven't proved anything. The way many AVRs work (I don't have a Sony so can't be specific) is if you have more than one connection plugged in for a given input it has an order of preference. Usually HDMI is first preference so if it is plugged in it will use that. Pulling it out will cause the optical connection to be used. Go through the menus and for the input specifically select the optical connection rather than something like "auto".



21 posts

Geek


  Reply # 194990 9-Feb-2009 21:34
Send private message

Watching CSI on TV3 now. Banner showed HD 5.1 surround.
SkyHDi is only outputting Dolby Digital 2 channel. Unplugged HDMI and sound continued so must be using optical. AVR is set to "OPT"(optical instead of Auto for HDMI
Freeview on HTPC is full 5.1 Dolby Digital
Is anyone else having this issue. Will call sky tomorrow as well and ask them

1108 posts

Uber Geek
+1 received by user: 109

Trusted

  Reply # 195077 10-Feb-2009 10:22
Send private message

Sorry to hijack the thread but I have a related question -- is 5.1 audio tied to HD in anyway? i.e. with MySky, if I don't get the HD ticket and only have SD, can I still get 5.1 sound if I connect the MySky box to my home theatre amp?

Cheers

Steve

26 posts

Geek


  Reply # 195164 10-Feb-2009 18:32
Send private message

5.1 audio is only available on HD Channels,

so if you don't have the "HD Ticket" then you won't get 5.1 sound

66 posts

Master Geek


  Reply # 197974 25-Feb-2009 12:13
Send private message

C0rsa: Watching CSI on TV3 now. Banner showed HD 5.1 surround.
SkyHDi is only outputting Dolby Digital 2 channel. Unplugged HDMI and sound continued so must be using optical. AVR is set to "OPT"(optical instead of Auto for HDMI
Freeview on HTPC is full 5.1 Dolby Digital
Is anyone else having this issue. Will call sky tomorrow as well and ask them


Yes I have this issue, only seems to be on TV3. How did you get on with Sky?

1374 posts

Uber Geek
+1 received by user: 215


  Reply # 198107 25-Feb-2009 23:12
Send private message

C0rsa: Hi there,
I started watching Prison Break last night on TV3 via MySkyHDi and noticed that the HD information at the beginning of the show displayed as HD5.1 Surround. My Sony AV Receiver(connected via optical for sound and HDMI for video) showed that the signal was in Dolby Digital but only displayed the 2 channel graphic and tHE sound was also only 2 channel. I checked that I was using the English ALT setting giving me Dolby Digital and not AAC. (Switching to TV2 changes the Sony AV graphic to Linear PCM ilke it should so i assume thta the SkyHDi is configured correctly)
I switched over to Freeview on my HTPC using Windows 7 and this displayed the 5.1 graphic and had full 5.1 sound.
Is that normal for the SkyHDi unit or does my setup need tweaking in some way?




English Alt is not the 5.1 surround, use the other one.
Also if you record it, when playing back english alt will not be available, as it only records 5.1 sound track.

All working good here.

1677 posts

Uber Geek
+1 received by user: 7

Trusted

  Reply # 198231 26-Feb-2009 15:51
Send private message

rugrat:
Also if you record it, when playing back english alt will not be available, as it only records 5.1 sound track.


yeah, that's a real oddity, they don't seem to record the transport stream, so you only get the current audio.  A bit dumb really.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.