My Harmony 5252 remote wouldn't connect to my Surface Pro running Windows 10 via USB. 


The harmony software couldn't connect to the remote even though the remote displays "USB Connected".


I've posted on this previously (thread locked), searched the web and emailed Harmony.  The problem is acknowledged  and usually attributed to the firewall and/or anti-virus software but I never found a solution.  So I gave up.


A new Satellite decoder forced me to revisit this issue and I have found a simple solution. I don't understand why this works but ....


If I plug the USB cord into the remote control first updates work as they should.  If I connect to the computer first updates fail.  I've tried it both way multiple times with consistent results. 


So the procedure that worked for me is: -


1) In the Harmony software make changes to settings etc


2) Plug the USB cord into the remote control  only


3) Click Update Remote


4) Click Next


5) Now connect plug the USB cord into the computer