Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




62 posts

Master Geek


Topic # 34801 29-May-2009 14:18
Send private message

Sent someone along at store open to pick up two USB datacards.

They are told 'should be working by the time you're back to the office'.

5 hours later, they're still not working- apparently not registered.

However several elements of the packaging are wonderfully clueless.

No contact number that will work on a vodafone mobile, other than the +64 3 number listed for 'Urgent roaming problems while abroad'. That took quite a bit of explaining to the phillipine? agent who answered.

Telecom, you need to learn that there are many people who can't dial 123/126, because they have no telecom phones.....

Not well thought out at all.

45 minutes of holding, and call shuffling later, told that oh... it might take 24 hours for a data card to be registered. Oh. Right.

Why? Why is the P.O.S computer in a telecom shop not all that is needed for a SIM to go active?

Stupid, stupid, stupid.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
913 posts

Ultimate Geek
+1 received by user: 45

Subscriber

  Reply # 219334 29-May-2009 15:08
Send private message

I'm still waiting for a XT pre pay sim to become active. Been about 4 or so hours now. Moved an existing telecom CDMA number. Was keen to have a play... oh well

199 posts

Master Geek
+1 received by user: 7

Subscriber

  Reply # 219336 29-May-2009 15:09
Send private message

You can dial 123/126 on non-Telecom phones... you can even dial it internationally too...

 
 
 
 




62 posts

Master Geek


  Reply # 219344 29-May-2009 15:23
Send private message

123/126 is not dialling as a external number on our VOIP system. But you're right- It does work on a Vodafone mobile, which somewhat surprises me.

Still waiting for activation, mind you.

146 posts

Master Geek
+1 received by user: 1


  Reply # 219346 29-May-2009 15:25
Send private message

I have waited 5 hours too, and mind still shows no service - the person who did the connection, was their first one, so I hope all is done correctly...

199 posts

Master Geek
+1 received by user: 7

Subscriber

  Reply # 219350 29-May-2009 15:26
Send private message

Whoever maintains your phone system needs to correct their dial plan then

Also, you can call 123 via 0800 800 123 I think

913 posts

Ultimate Geek
+1 received by user: 45

Subscriber

  Reply # 219354 29-May-2009 15:41
Send private message

camo786: I have waited 5 hours too, and mind still shows no service - the person who did the connection, was their first one, so I hope all is done correctly...



Try turning the phone off then on again so it trys to register with the network again.

BDFL - Memuneh
62064 posts

Uber Geek
+1 received by user: 12666

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 219356 29-May-2009 15:44
Send private message

zonky: Telecom, you need to learn that there are many people who can't dial 123/126, because they have no telecom phones.....


I know this comment won't fix the problem, but... I read in the forums a few posts from people complaining about a provider for not giving the service they expect, only to find out later the provider actualy does give the service, and it was something completely unrelated.

So it's just a heads up. It happens a lot. I'd like to see people coming here a little more "cool" - perhaps save the stronger words for the third reply?

But, yes, waiting for the connection to be activated is a pain...




19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


Reply # 219360 29-May-2009 15:49
Send private message

Don't leave the handsets on while SIM is getting activated on the network.

Power off the handsets and try turning them on every so often

John


19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 219367 29-May-2009 15:57
Send private message

The reason for the above is the KI string is checked at power up and also the triplets are sent and if the handset is powered up this will not happen so SIM registration failed will always show.

John

24 posts

Geek

Trusted

  Reply # 219376 29-May-2009 16:13
Send private message

Just a quick note to say we have already Private Messaged the people having problems with this on here to work on it.

147 posts

Master Geek

Trusted

  Reply # 219379 29-May-2009 16:17
Send private message

It is only Day 1, as with anything, there's usually issues for some when it's something new, especially when they will be super busy with a ton of requests.




nOOb alert



62 posts

Master Geek


  Reply # 219381 29-May-2009 16:21
Send private message

NickiB: It is only Day 1, as with anything, there's usually issues for some when it's something new, especially when they will be super busy with a ton of requests.


This may or may not be the case. I do wonder though, i'm talking about 2 items that were purchased within the first ~90mins of store open today, still not being active now?

Is this really the expected wait?

I agree with the premise that many businesses think it is acceptable to treat launch customers poorly, especially when large corporate vendors are doing the selling.

That is certainly not the way i like to do things.

Mainly, i'm a bit miffed around expectation management. Customers should never have been told it would be live within a couple of minutes.....

259 posts

Ultimate Geek

Trusted

  Reply # 219385 29-May-2009 16:27
Send private message

karenmonksnz: Just a quick note to say we have already Private Messaged the people having problems with this on here to work on it.



I can confirm this thanks

But as for launch day 29th looks like I might not see it untill the 30th dissapointing
considering I was one of the first into the invercargill shop this morning

38 posts

Geek


  Reply # 219398 29-May-2009 16:42
Send private message

heh, well i gotta say im glad i got a phone with Wifi.. Because in the mean time i can set up all the online services (like ebuddy) on wifi before my data starts working :D

3057 posts

Uber Geek
+1 received by user: 482

Trusted
Subscriber

  Reply # 219459 29-May-2009 19:19
Send private message

Well, add me to the list of people having issues. But I must also add, that I initally called *123 (or from a non-Telecom phone, 0800 800 163) and they said to talk to the dealer (they can only handle personal accounts, business accounts can only be handled by a 9-5 M-F department) and after speaking to the dealer I got a call back from the fellow who initially tried to activate my new SIM saying he's still working on it and has in fact been doing so for the past three hours! So I can understand there are issues with the number of orders going through (I overheard the number EIGHT THOUSAND at 1PM!) and can appreciate they are absolutely doing their best to sort it out.




I finally have fibre!  Had to leave the country to get it though.


 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.