Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1366 posts

Uber Geek
+1 received by user: 16


Topic # 70046 17-Oct-2010 18:31
Send private message

Hi

I currently have a domain hosted with goDaddy and i am using windows live mail to connect to my email accounts.

Now i entered all the correct information provided by goDaddy and all my accounts work fine at receiving email, the problem comes when i try to send email.

I have tried using all 4 ports they accept, 25.80,3535,465(SSL) but with the same problem, the email just sits in the outbox and errors.

I tried all these setting on all 4 of my hosting accounts.


So then i moved onto thunderbird in case windows live mail was the problem but i got exactly the same result.

Then i emailed goDaddy and after a few email finally got this response:

"The SSL or any other secure option will typically cause issues in email clients. We advise that you disable the SSL or encryption options to resolve the issue. If you are able to receive email but not send from within your email client after disabling the SSL options it is likely caused by SMTP relay blocking from your internet service provider. This problem will affect all email clients, regardless of manufacturer.

There are limited options for customers who use an ISP that block SMTP relay traffic. One alternative solution is to modify the port number you use to access the SMTP server. The default is 25, but we allow SMTP traffic over ports 80 and 3535. You can try using one of these alternative port numbers in the SMTP settings for your email client.

If changing the ports does not resolve the issue we advise that you contact your internet service provider and request their SMTP settings that you can use to send email through their network."


This isn't particually helpful which is exactly what i expected from goDaddy.

And i know using goDaddy i get what i pay for but just wondering if anyone else has had this problem or knows how i could fix this. Cheers

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
6329 posts

Uber Geek
+1 received by user: 391

Moderator
Trusted
Lifetime subscriber

  Reply # 392912 17-Oct-2010 19:22
Send private message

What account are you on, on Xtra?



1366 posts

Uber Geek
+1 received by user: 16


  Reply # 392913 17-Oct-2010 19:23
Send private message

nate: What account are you on, on Xtra?


Yes i am on telecom.

 
 
 
 


351 posts

Ultimate Geek
+1 received by user: 103

Trusted
Emergency Management

  Reply # 393020 18-Oct-2010 08:20
Send private message

Have you unblocked port25 via the online form @ www.telecom.co.nz/port25 and also made sure you have your username and password in your modem?

Or if this is a new Broadband Connection after 1st Jan 2010 then Broadband elpdesk can unblock this for you :)

24 posts

Geek


  Reply # 393110 18-Oct-2010 11:55
Send private message

So you have a hosted email account with your domain name from Go Daddy?
You are using a standard POP settings on your mail program?

Don't unblock port 25 unless you have a Static IP address and are hosting your own mail server on site.

I am surprised Go Daddy dont offer an authenticated mail option (port 465) with the mail account. Your point that you pay for what you get, is very true with Domain Hosts when it comes to email accounts. 

You can set your Domain Name Zone records to point to a more local email service provider with better support. Or set up an @xtra.co.nz mail account and add your user@domain.com to the options->accounts. This will allow authenticated outbound sending.


1163 posts

Uber Geek


  Reply # 393134 18-Oct-2010 12:45

Just send the email through telecoms yahoos smtp server. You do get what you pay for with cheap hosting especially these budget us companies, whose support is usually canned responses from a database. . Normally a good host will provide an alternative port such as port 26 or ssl

3429 posts

Uber Geek
+1 received by user: 419

Trusted

  Reply # 393148 18-Oct-2010 13:15
Send private message

robbyp: Just send the email through telecoms yahoos smtp server. You do get what you pay for with cheap hosting especially these budget us companies, whose support is usually canned responses from a database. . Normally a good host will provide an alternative port such as port 26 or ssl


Its not good practice to send it through Yahoo's SMTP server unless they host your domain. Will likely be picked out as spam.... 





2941 posts

Uber Geek
+1 received by user: 321


  Reply # 393150 18-Oct-2010 13:18
Send private message

As said above,

To stop spam etc Xtra disable sending of emails other than via their own authenticated smtp.

Once you go via their SMTP you then have to verify the sending account via webmail portal as it will pickup a different return/from address (much like spam has) and alert you that something is mailing with a different return address.

I have Orcon, Xtra, my Domain, and a few other email addresses. All of them have their required pop server and simply send via xtra SMTP with source/return/reply addressing of the real address details.

Just make sure you check the box next to “This server requires a secure connection (SSL). Enter port number “465” in the “Outgoing mail (SMTP)” field. As per Xtras help

3429 posts

Uber Geek
+1 received by user: 419

Trusted

  Reply # 393152 18-Oct-2010 13:31
Send private message

Oblivian: As said above,

To stop spam etc Xtra disable sending of emails other than via their own authenticated smtp.

Once you go via their SMTP you then have to verify the sending account via webmail portal as it will pickup a different return/from address (much like spam has) and alert you that something is mailing with a different return address.

I have Orcon, Xtra, my Domain, and a few other email addresses. All of them have their required pop server and simply send via xtra SMTP with source/return/reply addressing of the real address details.

Just make sure you check the box next to “This server requires a secure connection (SSL). Enter port number “465” in the “Outgoing mail (SMTP)” field. As per Xtras help


Sending via Xtra/Yahoo's SMTP server for anything other than domains that they are setup to host is not good practice. With DKIM, reverse lookups are now made for receiving mail servers. So fro example if you sent bob@orcon.net.nz through smtp.xtra.co.nz, the receiving mail server would check and find that smtp.xtra.co.nz is not authorized to relay mail for @orcon.net.nz addresses. You should be using Orcon's SMTP server as that will be authorized to send mail for @orcon.net.nz addresses.

You may have gotten away with it in the past but you will increasingly find that using a random SMTP server is going to get your mail marked as spam. 





2941 posts

Uber Geek
+1 received by user: 321


  Reply # 393157 18-Oct-2010 13:37
Send private message

Zeon:

Sending via Xtra/Yahoo's SMTP server for anything other than domains that they are setup to host is not good practice. With DKIM, reverse lookups are now made for receiving mail servers. So fro example if you sent bob@orcon.net.nz through smtp.xtra.co.nz, the receiving mail server would check and find that smtp.xtra.co.nz is not authorized to relay mail for @orcon.net.nz addresses. You should be using Orcon's SMTP server as that will be authorized to send mail for @orcon.net.nz addresses.

You may have gotten away with it in the past but you will increasingly find that using a random SMTP server is going to get your mail marked as spam. 


I too understand the implications. But I don't see how we can. When you cant contact SMTP non xtra servers from an xtra connection. Not since 2008. (I've not tested recently but its always been the case since they tried to stop email relay spam with xtra no trafic limit accounts)

Its still clearly pointed out in their help system to get around it is to use their SMTP and verify the sending address.
http://telecom.custhelp.com/app/answers/detail/a_id/1345
http://telecom.custhelp.com/app/answers/detail/a_id/1547

Clearly this requires some actual telecom input from the likes of Doogie. Cause no matter of how much advanced knowledged users are out there regarding relay and best practice. They have the final say with the previous blocking of smtp.

3429 posts

Uber Geek
+1 received by user: 419

Trusted

  Reply # 393160 18-Oct-2010 13:42
Send private message

Oblivian:
Zeon:

Sending via Xtra/Yahoo's SMTP server for anything other than domains that they are setup to host is not good practice. With DKIM, reverse lookups are now made for receiving mail servers. So fro example if you sent bob@orcon.net.nz through smtp.xtra.co.nz, the receiving mail server would check and find that smtp.xtra.co.nz is not authorized to relay mail for @orcon.net.nz addresses. You should be using Orcon's SMTP server as that will be authorized to send mail for @orcon.net.nz addresses.

You may have gotten away with it in the past but you will increasingly find that using a random SMTP server is going to get your mail marked as spam. 


I too understand the implications. But I don't see how we can. When you cant contact SMTP non xtra servers from an xtra connection. Not since 2008. (I've not tested recently but its always been the case since they tried to stop email relay spam with xtra no trafic limit accounts)

Its still clearly pointed out in their help system to get around it is to use their SMTP and verify the sending address.
http://telecom.custhelp.com/app/answers/detail/a_id/1345
http://telecom.custhelp.com/app/answers/detail/a_id/1547

Clearly this requires some actual telecom input from the likes of Doogie. Cause no matter of how much advanced knowledged users are out there regarding relay and best practice. They have the final say with the previous blocking of smtp.


They only block port 25. As long as you are using a different port it will work fine. As previously mentioned you can use SSL which is most often over port 465.

The way that we do it for customers whom have port 25 blocked by their ISPs is to run our mail server listening on both port 25 and port 26. Most use port 26 without SSL and it works perfectly. Check with your mail provider but most should have a non port 25 option.





24 posts

Geek


  Reply # 393162 18-Oct-2010 13:53
Send private message

Zeon:
Oblivian:
Zeon:

Sending via Xtra/Yahoo's SMTP server for anything other than domains that they are setup to host is not good practice. With DKIM, reverse lookups are now made for receiving mail servers. So fro example if you sent bob@orcon.net.nz through smtp.xtra.co.nz, the receiving mail server would check and find that smtp.xtra.co.nz is not authorized to relay mail for @orcon.net.nz addresses. You should be using Orcon's SMTP server as that will be authorized to send mail for @orcon.net.nz addresses.

You may have gotten away with it in the past but you will increasingly find that using a random SMTP server is going to get your mail marked as spam. 


I too understand the implications. But I don't see how we can. When you cant contact SMTP non xtra servers from an xtra connection. Not since 2008. (I've not tested recently but its always been the case since they tried to stop email relay spam with xtra no trafic limit accounts)

Its still clearly pointed out in their help system to get around it is to use their SMTP and verify the sending address.
http://telecom.custhelp.com/app/answers/detail/a_id/1345
http://telecom.custhelp.com/app/answers/detail/a_id/1547

Clearly this requires some actual telecom input from the likes of Doogie. Cause no matter of how much advanced knowledged users are out there regarding relay and best practice. They have the final say with the previous blocking of smtp.


They only block port 25. As long as you are using a different port it will work fine. As previously mentioned you can use SSL which is most often over port 465.

The way that we do it for customers whom have port 25 blocked by their ISPs is to run our mail server listening on both port 25 and port 26. Most use port 26 without SSL and it works perfectly. Check with your mail provider but most should have a non port 25 option.


The point is to set up email correctly with a reputable mail host/ service provider who can provide authenticated + SSL connections.

Oblivion is correct - using send.xtra.co.nz with authentication and ssl enabled, adding the domain email account via webmail options ->accounts verifies the domain email address sending as associated with the @xtra.co.nz account holder and should get delivery to major ESPs. Far better than using unauthenticated mail relays which are spam magnets.

That said, Go Daddy's hosted email service doesnt offer authenticated options for account holders. Other email providers are likely to defer or block unauthenticated email relay, and you're not likely to get a timely response from this mail host.

Go Daddy's service isn't up to scratch.
Setting up Port variations for mail servers without RFC compliance is going to cause issues too

If you rely on email - set it up correctly, pay for a reputable email service, it's worth it



1366 posts

Uber Geek
+1 received by user: 16


  Reply # 393230 18-Oct-2010 16:25
Send private message

I did mention in my original post that i had tried the other ports that goDaddy uses - 80, 3535 and 465 which is SSL but all of these had the same problem as using port 25. I also pinged my ail server to check that i can connect with it.

2941 posts

Uber Geek
+1 received by user: 321


  Reply # 393236 18-Oct-2010 16:33
Send private message

jbard: I did mention in my original post that i had tried the other ports that goDaddy uses - 80, 3535 and 465 which is SSL but all of these had the same problem as using port 25. I also pinged my ail server to check that i can connect with it.


You may have opted to skip the technobabble in the middle.

To simplify, you can't send via a godaddy server. (or rather the easier option is to follow Xtras guide) You need to change your mail program settings for outgoing mail. And then allow the address to be used as per the xtra help links I provided.

Modify outgoing SMTP details to xtras servers/credentials of your main xtra account, but leave reply to, and return address/pop server settings the same.


As you mentioned http://help.godaddy.com/article/4715 does indicate you can send via non standard ports. Ill check those servers respond as they should via an Xtra connection later on unless someone beats me to it (telnet and wait for flashing cursor) or if it is sniffing traffic and realising you are trying to relay


6329 posts

Uber Geek
+1 received by user: 391

Moderator
Trusted
Lifetime subscriber

  Reply # 393239 18-Oct-2010 16:38
Send private message

I can replicate the issue on my home ADSL when trying to connect to our SMTP server.  I've recently swapped from the discontinued BigTime plan to Pro. If I connect through work (which is an Adventure plan) I can connect fine.

Possibly call the helpdesk and ask why outbound port 25 is blocked, and see if they can unblock it?

24 posts

Geek


  Reply # 393245 18-Oct-2010 16:58
Send private message

Suggest checking your settings with who ever Administers your email server first.

They probably restrict unauthenticated SMTP to avoid an unsecured mail relay. 

Ensure the work mail server (e.g. MS Exchange) is configured to accept authenticated SMTP from POP mail programs (like Outlook) and use port 465 with SMTP Authentication enabled rather than attempting to open port 25 on your residential connection.

If your work email doesn't have authentication for smtp this option, then do as Oblivion has suggested and use an @xtra.co.nz email account for sending from work email from Home.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.