Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




7 posts

Wannabe Geek


Topic # 79113 12-Mar-2011 19:35
Send private message

I'm having a problem with my HTC Desire (A8183); I can't seem to send or receive MMS messages. When I try to I get 'Message not downloaded - Generic network failure'. What is strange is that I can connect to the internet just fine (and yes, I've made sure I've disabled WiFi when I test this Wink ). The APN settings I have used are the ones found here:

http://www.nzandroid.com/content/android-tips/131-android-apn-settings-telecom-xt-vodafone-nz-2degrees.html?amp;=

Does anyone have any ideas about what could be wrong? Cheers for any help, I've been trying to figure this out all day :S 

Create new topic
317 posts

Ultimate Geek
+1 received by user: 45

Trusted
Spark NZ

  Reply # 447969 13-Mar-2011 12:30
Send private message

Those are the correct settings.  What version of Android is your Desire running?  Have you tried your SIM in an XT handset to check if MMS works?
 



7 posts

Wannabe Geek


  Reply # 447980 13-Mar-2011 13:16
Send private message

I'm running 2.2. I just put my SIM into my old Nokia 3120c and I was able to send and receive MMS messages... I've rechecked my settings and they definitely are right. The phone cam with some Telstra Next G software on it (for the Australian network), could that be a possible source of this problem? If rooting and putting a mod on my phone could fix this problem I'd be keen to try that (someone on another forum has an identical phone to mine and has no problems with MMS).

 
 
 
 


1 post

Wannabe Geek


  Reply # 449604 18-Mar-2011 14:24
Send private message

I suggest rooting your phone. I have the same model - that came with Telstra configuration - and once rooted everything worked fine.



7 posts

Wannabe Geek


  Reply # 451343 24-Mar-2011 10:01
Send private message

I've rooted my phone and put Oxygen 2.0 RC7 on it, but I'm still having the same problem. I've put in the APN details exactly, but could there be another basic setting I haven't enabled/disabled? Once again, the internet on mobile data is working fine, it's just not the MMS. When I get an MMS it just comes up with: Who sent it, size of the file, when the message expires and a 'download' button. When I tap the download button it greys out and changes to 'downloading'. Then it just changes back to 'download', with no sign of a picture. I've looked in the gallery and nothing is there either. Am I just missing something incredibly basic here? This is driving me nuts :S

4123 posts

Uber Geek
+1 received by user: 842
Inactive user


  Reply # 451369 24-Mar-2011 10:56
Send private message

Can you post your settings in the thread. Also try putting leading zero's into the MMS Proxy

ie 210.55.11.73 to 210.055.011.073



7 posts

Wannabe Geek


  Reply # 451402 24-Mar-2011 11:53
Send private message

I tried putting the lead zeros in, but it didn't work. APN Settings:

Name: TelecomData
APN: internet.telecom.co.nz
MMSC: http://pdaportal.telecom.co.nz
MCC: 530
MNC: 05
APN type: default

Name: TelecomContent
APN: wap.telecom.co.nz
Proxy: 210.055.011.073
Port: 8080
MMSC: http://myhomepage
MCC: 530
MNC: 05
APN Type: default

Name: TelecomMMS
APN: wap.telecom.co.nz
MMSC: http://lsmmsc.xtra.co.nz
MMS Prox: 210.055.011.073
MMS Port: 8080
MCC: 530
MNC: 05
APN Type: mms

There is an option to have TelecomData OR TelecomContent selected in the list APNs, but not one for TelecomMMS, I don't know if this is relevant or not.

4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 451545 24-Mar-2011 18:09
Send private message

Mms shouldn't be selectable. That's normal. Install APN Manager by 81 square. Scroll the APN list and see if there's any others lit up aside from the ones showing in your apn list in settings.
There should be quite a few there due to the built in APN list.



7 posts

Wannabe Geek


  Reply # 451582 24-Mar-2011 20:22
Send private message

The only ones that are lit up are the 3 that I posted above, there are 4 more Telecom ones that I tried entering the details of into my APN list, but they wouldn't save. Should I have more than just those 3 lit up?

4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 451584 24-Mar-2011 20:35
Send private message

That list is all APN's stored in your phone. Delete all telecom and XT related ones entirely, and then re add them again under the normal APN settings.
Can you send MMS?
fyi use http://mmsgallery.telecom.co.nz for receiving MMS in the mean time.



7 posts

Wannabe Geek


  Reply # 451585 24-Mar-2011 20:50
Send private message

OK I deleted all the Telecom/XT APNs that I could see then added back the 3 that I originally posted. I'm now able to send MMS! But I still can't receive them... Any more idea ;D?

4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 451629 24-Mar-2011 23:16
Send private message

I just noticed, why are you using Oxygen 2.0 RC7? This is old.
http://forum.xda-developers.com/showthread.php?t=971904

Update it first, try again.



7 posts

Wannabe Geek


  Reply # 452052 26-Mar-2011 13:46
Send private message

I just updated to Oxygen 2.0.1 and I can now receive MMS AND send them! I didn't even need to add any APNs to my list, I just used the default 'XT Mobile' and 'XT Mobile MMS' ones that were already in my list. Thanks for all the help, I was going insane trying to fix this!

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

How Oppo shakes New Zealand’s phone market
Posted 22-Aug-2017 18:32


Recognition for top small business advisors
Posted 22-Aug-2017 17:23


OPPO R11 dual 20MP camera phone debuts in New Zealand
Posted 22-Aug-2017 15:45


Intel introduces new 8th Generation processors
Posted 21-Aug-2017 19:02


Trend Micro launches Home Network Security
Posted 21-Aug-2017 18:38


Avondale College students at top of Microsoft Office Specialist World Championship
Posted 21-Aug-2017 14:11


Garmin introduces inReach SE+ and inReach Explorer+
Posted 21-Aug-2017 14:05


Public Wi-Fi plus cloud file sharing
Posted 18-Aug-2017 11:20


D-Link NZ launches professional Wireless AC Wave 2 Access Point for businesses
Posted 17-Aug-2017 19:25


Garmin introduces the Rino 700 five-watt two-way handheld radio
Posted 17-Aug-2017 19:04


Garmin announces the Foretrex 601 and Foretrex 701 Ballistic Edition for outdoor and tactical use
Posted 17-Aug-2017 19:02


Brightstar announces new distribution partnership with Samsung Knox platform in Australia
Posted 17-Aug-2017 17:07


Free gig-enabled WiFi network extends across Dunedin
Posted 17-Aug-2017 17:04


Samsung expands with connect Gear S3 Frontier
Posted 17-Aug-2017 15:55


Fact-checking Southern Cross Next cable is fastest to USA
Posted 17-Aug-2017 13:57



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.