Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


chriserasmo

7 posts

Wannabe Geek


#28946 16-Dec-2008 21:59
Send private message

Hi guys,

I have problem with my inbound calls when I dialed my 2talk number which is 028XXXXXX using my cellphone. I heared a 2 rings on my cellphone and it goes to busy tone. The incoming calls did not get through to my asterisknow server.
My outgoing works fine now. only my inbound .. Its more than a week now since I get my 2talk until now i never used it. please help..

I am using Asterisknow. All of the configuration below is based on GUI.
What Did i missed on my configuration below.


Edit Service Provider
=======================
    Comment:  2talk
    Protocol: SIP
    Register: Yes
    Host: 2talk.co.nz
    Username: 028XXXXXX
    Password: XXXXXXXXX

    Codec Preferences
    ------------------
    Allowed: u-law & G.726
    Disallowed: GSM & a-law
    Disallow All: No (i leave it untick)

    Advanced Settings
    ------------------
    trunkname: trunk_2
    insecure: very
    port: 5060
    CallerID:
    fomdomain:
    fromuser:649974XXXX
    contact: friend
    can reinvite: No (I leave it untick)


Calling Rules
=============================
    Rule Name: 2talk
    Place this call through: Custom-2talk
    Dialing Rules: if the number begins with [02889] and
    followed by [4] digit [*] or more

    Strip [ ] digit from the front and prepend [ ] before dialing


Incoming Calls Rules
===============================
    Route [ incoming call that match ] pattern [ _028XXXXXX ]
    from provider [ Custom - 2talk ]
    to extension [ 6000-chris ]

    Route [ All Unmatched incoming calls ]
    from provider [ Custom-2talk ]
    to extension [6000-chris]

Regards,
Chris

[Moderator (ND): Removed phone numbers to prevent spamming]

Create new topic
meesham
973 posts

Ultimate Geek


  #184718 17-Dec-2008 09:53
Send private message

Have you double checked your firewall/port forwarding settings? UDP Port 5060 for SIP and possibly UDP ports 10000 - 11000 for RDP.

 
 
 

Free kids accounts - trade shares and funds (NZ, US) with Sharesies (affiliate link).
tknz
177 posts

Master Geek


  #187093 2-Jan-2009 22:48
Send private message



Remove the first inbound route rule - ignore the firewall ports the other user specified below - your using an outbound sip register which works through NAT - but verify that you don't have "Trunking" turned on in your 2talk options - login via SSH to the server -

type

sudo asterisk -r

this should get you to the cli -

try and make the call and anything asterisk recieves will come up on the GUI -

if it doesn't show up type - at the cli
 sip show registry

make sure it is registered -

Then verify inbound trunk

sip show peers


tknz
177 posts

Master Geek


  #187107 3-Jan-2009 01:15
Send private message

I think I have figured it out - I was having the same issue this evening - I now have it working please see below -
There are two problems.

1. Trunk mode is Insecure "no" this needs to be insecure "very" this will solve the first problem which is below the X is just disguising my number -

[Jan  3 01:07:30] WARNING[4483]:
chan_sip.c:8507 check_auth: username mismatch, have , digest has <04XXXXXXX>
[Jan  3 01:07:30] NOTICE[4483]: chan_sip.c:13971 handle_request_invite: Failed to authenticate user "Tui Kapo" ;tag=as3e2325ff
david*CLI>

2. Problem -

[Jan  3 01:05:43] NOTICE[11770]: pbx.c:1892 pbx_extension_helper: No such label 'directory/5001' in extension 's' in context 'DID_trunk_1'

So it is trying extension S - which is a catch all phrase - so to resolve this you put the following in extensions.conf
 exten=s,1,Goto(default,6000,1)

6000 was my test extension number -

I believe that in AsteriskNOW that would be to go to Inbound Calling Rules - under pattern matching stick 's' without the quotes - and then the extension you want to go to.

Hopefully these resolve y our issues -

BTW - Asterisk 1.4 with Asterisk GUI 2.0 is great - if your Linux knowledge is ok then you should consider the upgrade project. It is incredibly stable on Debian, with Asterisk 1.4 Stable and Asterisk Gui 2.0

Best of Luck

Tui

Create new topic





News and reviews »

Synology Introduces BeeStation
Posted 23-Feb-2024 14:14


New One UI 6.1 Update Brings Galaxy AI to More Galaxy Devices
Posted 23-Feb-2024 10:50


Amazon Echo Hub Available in New Zealand
Posted 23-Feb-2024 10:40


InternetNZ Releases Internet Insights 2023
Posted 20-Feb-2024 10:31


Seagate Adds 24TB IronWolf Pro Hard Drives for Multi-user Commercial and Enterprise RAID Storage Solutions
Posted 19-Feb-2024 16:54


Seagate Skyhawk AI 24TB Elevates Edge Security Capacity and Performance
Posted 9-Feb-2024 17:18


GoPro Releases Quik Desktop App for macOS and Introduces Premium+ Subscription Tier
Posted 9-Feb-2024 17:14


Ring Introduces New Ring Battery Video Doorbell Pro
Posted 9-Feb-2024 16:51


Galaxy AI Transforms the new Galaxy S24 Series
Posted 18-Jan-2024 07:00


D-Link launches AI-Powered Aquila Pro M30 Wi-Fi 6 Mesh Systems
Posted 17-Jan-2024 20:02


Newest LG 4K Lifestyle Projector Doubles as Art Objet
Posted 9-Jan-2024 15:50


More LG Smart TV Owners Set To Enjoy the Latest webOS Upgrade
Posted 9-Jan-2024 15:45


Panasonic Announces the Z95A and Z93A With Fire TV Built In
Posted 9-Jan-2024 15:30


Amazon Echo Pop Review
Posted 8-Jan-2024 14:22


Samsung Tab S9 FE Review
Posted 17-Dec-2023 08:26









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.