Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




94 posts

Master Geek


Topic # 68379 20-Sep-2010 18:54
Send private message

Since i am getting nothing out of the Vodafone Huawei hg556a, i have bout the Linksys SPA-2102 for making voip calls and go naked.

just got my device and having some trouble with the set up. any help will be appreciated.

I was following all the steps in 2talk's support website but got the below problem:


  1. Never got a Dial tones from the PSTN phone that plug into the ATA. even i have set up all the values and re-boot.

  2. it seems my computer is confuse with the hg556a and the ATA... since Linksys SPA-2102 also work as a router and my computer automatically pick that up and i can no longer login to the hg556a and access internet either. but i can however go to the ATA's web interface, 192.168.0.1    After i set up all the parameters, i have then disconnect the network cable and restart my router (hg556a), the plug the cable back to the ATA. the internet is back to working but phone still no tones...

  3. there is one step in 2talk i couldnt find the option in the ATA configuration which is :

             Change the following SDP Payload Types:

  • RTP-Start-Loopback-Codec: G711a





SDP Payload Types


NSE Dynamic Payload:

AVT Dynamic Payload:



INFOREQ Dynamic Payload:

G726r16 Dynamic Payload:



G726r24 Dynamic Payload:

G726r32 Dynamic Payload:



G726r40 Dynamic Payload:

G729b Dynamic Payload:



NSE Codec Name:

AVT Codec Name:



G711u Codec Name:

G711a Codec Name:



G726r16 Codec Name:

G726r24 Codec Name:



G726r32 Codec Name:

G726r40 Codec Name:



G729a Codec Name:

G729b Codec Name:



G723 Codec Name:












View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
21621 posts

Uber Geek
+1 received by user: 4432

Trusted
Subscriber

  Reply # 382416 20-Sep-2010 19:13
Send private message

You cant have the ata and your router on the same IP address, change one of them.




Richard rich.ms

104 posts

Master Geek


  Reply # 382420 20-Sep-2010 19:21
Send private message

Hi there,

Have you installed the latest firmware for the SPA2102?  Not that it's likely that's the problem, but it'd be a good idea all the same.

No dialtone is usually because the number hasn't registered successfully (eg wrong password).  The status page should tell you that.

Are you just trying to configure Extn 1 (1st phone port)?

I'm assuming you've bought an unconfigured SPA2102, not an Xnet one?

What lights are lit on the SPA2102 when it's all plugged in?

 

 
 
 
 




94 posts

Master Geek


  Reply # 382424 20-Sep-2010 19:28
Send private message


Hi there,

Thanks for the help. i will look into updating the firmware.

Yes, this is a unconfigured from Ascent.

the lights lit on SPA2102 are just the power and the phone 1.

still need to figure out how to have it co-exist with my hg556a router.. can i customized a ip address to the ATA? if so how? sorry but i am a newbie and not an IT expert either.

Thanks



94 posts

Master Geek


  Reply # 382426 20-Sep-2010 19:32
Send private message

with regards to the dialtone, i can see the there is nothing in the line1 status page... i have entered all value as per 2talk.. not sure why. but again, in order to go into the ATA interface again, i need to figure out a way and make it work with the router at the same time..

cheers

104 posts

Master Geek


  Reply # 382429 20-Sep-2010 19:38
Send private message

Ok, you need to change the SPAs mode from NAT mode to bridge mode.  I'm sorry I don't have one in front of me so I don't know exactly where that setting is, but you'll find it somewhere in the Network setup (NOT voice).

That way it'll get it's IP address from the Huawei.  Just make sure the cable from the Huawei is connected to the WAN port of the SPA (not the LAN/PC port).  

Once connected like that, you can find out the address by using your phone:

1. take your phone off the hook and dial ****
2. After the prompt, dial 110#
3. The lady will read out the SPA's IP address 

Then you can use that IP address to access the SPA, and it'll co-exist peacefully with your Huwei router 



94 posts

Master Geek


  Reply # 382434 20-Sep-2010 19:53
Send private message

Nice!!! thanks so much,,,it hooked up now and i can hear the dialtone as well.

got the below info from the status page, dose this mean i am now correctly set up with 2talk?

Line 1 Status
Hook State: On Registration State: Registered
Last Registration At: 9/20/2010 19:49:28 Next Registration In: 357 s
Message Waiting: No Call Back Active: No
Last Called Number: Last Caller Number:
Mapped SIP Port:
Call 1 State: Idle Call 2 State: Idle
Call 1 Tone: None Call 2 Tone: None
Call 1 Encoder: Call 2 Encoder:
Call 1 Decoder: Call 2 Decoder:
Call 1 FAX: Call 2 FAX:



94 posts

Master Geek


  Reply # 382438 20-Sep-2010 19:58
Send private message

Hi there,

it seems to be working fine, just made a call to my PSTN line and sounds good! can also see the record in 2talk!!

Thanks a lot for your help!! really appreciated!



104 posts

Master Geek


  Reply # 382439 20-Sep-2010 19:59
Send private message

Great!  Glad to hear it

Cheers 

15 posts

Geek


  Reply # 387080 2-Oct-2010 11:43
Send private message



Sorry about extending the post that little bit further though i have a similar issue to the person above.



I brought a spa2102 device recently(which going by the reciept is WxC modded),created a free 2talk account just to test what the clarity of the calls will be like but for the life of me i cannot get a call out.

There is a dail tone though after it rings there is a constant loud buzzing noise. (Funny enough on my 2talk account it states my number is OFFLINE?)



What i have done:

Updated to the latest firmware (5.2.10)

Copied all the setup values from 2talk's site (jeez that took awhile)



Current:

I had a guy from work who has a correctly configured spa 3102 device in which i told him to bring it in to see if the values matched. Now on the voice side im assuming it's correct what i cant understand is the WAN/LAN tab. He had WAN setup for a private address for his router setup and for LAN he had bridged the connection with a different Static IP.

Now i copied to a extent those details went home plugged it in got a dail tone though after it got dailed there was a constant loud buzzing noise.

Another point is that i cannot web onto the device with the selected static ip after i have connected it to my router (both using C Class addressed) i set in the wan configurations. The only way i can access the web page is to either plug it directly into the laptop change my ip to match the subnet  (i have assumed to use the LAN port for web manangement i dont think the internet port allows this?)



Or i reset the device.



I have the WAN port which is currently connected to my dynalink router/modem



Help





94 posts

Master Geek


  Reply # 387083 2-Oct-2010 11:59
Send private message

copy answer from Phil above would help this problem i guess:

Ok, you need to change the SPAs mode from NAT mode to bridge mode. I'm sorry I don't have one in front of me so I don't know exactly where that setting is, but you'll find it somewhere in the Network setup (NOT voice).

That way it'll get it's IP address from the Huawei. Just make sure the cable from the Huawei is connected to the WAN port of the SPA (not the LAN/PC port).

Once connected like that, you can find out the address by using your phone:

1. take your phone off the hook and dial ****
2. After the prompt, dial 110#
3. The lady will read out the SPA's IP address

Then you can use that IP address to access the SPA, and it'll co-exist peacefully with your Huwei router


15 posts

Geek


  Reply # 387158 2-Oct-2010 16:57
Send private message

Thanks though whenever i go through 110 or 210 # it tells me i have an IP of 0.0.0.0. So maybe the router is having issues supplying an IP to the unit.

Will have another look at it when i get back



94 posts

Master Geek


  Reply # 387195 2-Oct-2010 20:31
Send private message

i got the same problem before i can set the computer and the ATA with different ip address. which is using the bridge mode...

104 posts

Master Geek


  Reply # 387301 3-Oct-2010 09:01
Send private message

Hi mate, I hate to tell you, but if you've bought a worldxchange ATA it won't work with 2talk anyway - it'll only work with wxc. There may be a way to reset it but I don't know about that. Try searching the forums here to see if you can find out.

Let us know how you get on

Phil

27285 posts

Uber Geek
+1 received by user: 6717

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 387315 3-Oct-2010 09:39
Send private message

philelvey: Hi mate, I hate to tell you, but if you've bought a worldxchange ATA it won't work with 2talk anyway - it'll only work with wxc. There may be a way to reset it but I don't know about that. Try searching the forums here to see if you can find out.



Let us know how you get on



Phil


I'm not sure where you heard that but it's incorrect.

A WxC provisioned ATA will work fine with any VoIP provider after a factory reset. You can also disable the provisioning out of the box before you connect it to the internet if you don't want it to download the WxC config.

This differs to overseas providers who often lock down their ATA's to a service which can't be removed, even with a factory reset.

21621 posts

Uber Geek
+1 received by user: 4432

Trusted
Subscriber

  Reply # 387395 3-Oct-2010 15:15
Send private message

Yeah, the WXC ones are not locked, just preconfigured.

Often ones off ebay have been locked and then unlocked by the sellers just cloning the eeprom from a non locked one onto them, so when you buy 2 of them, you cant use them both as they have the same mac address.




Richard rich.ms

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.