I had a D-Link G630 Cardbus adapter that has worked fine for over a year using XP SP2, but when I installed SP3 I had all sorts of problems.  Solutions were available in the form of updated drivers, but although they fixed one problem I was left with another.  Specifically, the device detected networks, but when I clicked on the appropriate spot for further information I was then told that there were no networks available.  I tried all sorts of drivers, check the device in another SP2 computer and it worked, but in another SP3 one it didn't.  Eventually I got a new device, a DWL-650, and exactly the same thing has happened.  The device detects networks but when I try to get details it says there are no networks.  I've tried new and old drivers, sitting right next to a router, standing on my head, but nothing works.

So I did a repair reinstall of XP and reinstalled SP2.  Still the same problem.  It appears that installing SP3 has permanently changed something that has stopped the system from recognising and listing the networks that the adapter detects.

Can anyone help?  I am soooooooooo frustrated!!!