Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


13 posts

Geek


Topic # 67632 5-Sep-2010 01:57
Send private message

I downloaded and installed Ubuntu 10.04 after carefully following the upgrade path from 9.04 via 9.10. All upgrades appeared to have been installed correctly but attempting to connect to the internet using Firefox always fails. I can ping Google, Ubuntu and Yahoo but cannot connect. The "cures' on the Ubuntu forum do not work. Any ideas ?

Create new topic
264 posts

Ultimate Geek
+1 received by user: 95


  Reply # 376985 5-Sep-2010 20:47
Send private message

What happens if you run the following command from the output?

wget http://www.geekzone.co.nz

If that works it would mean is specific of Firefox, so you could try another browser (Chrome,Opera).




13 posts

Geek


  Reply # 377033 5-Sep-2010 23:46
Send private message

I tried your suggestion with no positive results. I am now getting to the stage where I will totally erase Linux and put up with the frustrations of Windows. This really annoys me as I heard Linux was so much better than Windows. 

32 posts

Geek
+1 received by user: 3


  Reply # 377046 6-Sep-2010 06:49
Send private message

Try and disable ipv6 dns in Firefox:

Type about:config in address bar

In the filter bar type ipv6

toggle by double clicking on ¨network.dns.disableIPv6;true¨

true disables ipv6 dns lookups

264 posts

Ultimate Geek
+1 received by user: 95


  Reply # 377058 6-Sep-2010 09:08
Send private message

onXgosub500: I tried your suggestion with no positive results. I am now getting to the stage where I will totally erase Linux and put up with the frustrations of Windows. This really annoys me as I heard Linux was so much better than Windows. 


Can you paste the output here? Otherwise it's very difficult to diagnose the issue.



13 posts

Geek


  Reply # 377082 6-Sep-2010 10:40
Send private message

Because I am using dual-boot I can't actually copy and paste between Ubuntu & XP but when trying to connect I eventually get a message that "Google (or whatever) server took too long".
When I check Network Connections the system appears to have correctly identified my DSL modem address on eth0 but also when I try "sudo ifdown eth0 && sudo ifup eth0" I am told "ignoring non-existent interface eth0". 

1598 posts

Uber Geek
Inactive user


  Reply # 377089 6-Sep-2010 11:38
Send private message

Try putting in "sudo ifdown eth1 && sudo ifup eth1" (without the quotes).
This worked for me yesterday, its a little bit odd that its not eth0, instead it is eth1, even though I don't have two adapters.

186 posts

Master Geek


  Reply # 377120 6-Sep-2010 13:22
Send private message

Hello!

If you can actually ping Google et al then you are very close to a working system. You have a proper network connection and all is connected correctly.

Let's see which interfaces you have.Type 'ifconfig' in the shell and note down the interface names in the left most column. These should be names such as 'eth0', 'eth1', etc., even though they could be named something else for you as well. Let us know what you have there.

Then see if you can connect to one of Google's web servers.

In the shell, type this: telnet google.com 80

You should see something like this as response:



Trying 74.125.53.106...
Connected to google.com.
Escape character is '^]'.


At the end there, type "GET /" (without quotes) and hit enter twice.

What do you see?
 



13 posts

Geek


  Reply # 377250 6-Sep-2010 19:54
Send private message

Using ifconfig  showed eth0 with the same IP address etc. as in XP.

I could not telnet using google.com but when I tried telnet 74.125.53.106 80 I got the following:

" allan@allan-desktop:~$ telnet 74.125.53.106 80
Trying 74.125.53.106...
Connected to 74.125.53.106.
Escape character is '^]'.
GET /
HTTP/1.0 302 Found
Location: http://www.google.co.nz/
Cache-Control: private
Content-Type: text/html; charset=UTF-8
Set-Cookie: PREF=ID=77d3208bdff67a9c:TM=1283751351:LM=1283751351:S=VbJUkbnKEWJitE9_; expires=Wed, 05-Sep-2012 05:35:51 GMT; path=/; domain=.google.com
Set-Cookie: NID=38=VC_Mmj5pS90do2hK10lKA9AR19jwj1XpRLzHK3j-vjqRzYKnn8c5iY7xLK1seqLTdRIrVH6htPiuqVcoHDLdyKF_SB830RDUpGMD32xsuum73roY1nBtDcqN0RICgij3; expires=Tue, 08-Mar-2011 05:35:51 GMT; path=/; domain=.google.com; HttpOnly
Date: Mon, 06 Sep 2010 05:35:51 GMT
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block

<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>302 Moved</TITLE></HEAD><BODY>
<H1>302 Moved</H1>
The document has moved
<A HREF="http://www.google.co.nz/">here</A>.
</BODY></HTML>
Connection closed by foreign host.
allan@allan-desktop:~$ "

I then tried Firefox again.
Taking eth0 down and up from the network icon suddenly brought up my Google homepage and I was able to search, but as soon as I tried to select a link I got a server timeout message again and could no longer access the internet.

27 posts

Geek


  Reply # 378148 9-Sep-2010 10:25
Send private message

I had an issue similar to this a while back. I had to set the DNS IP addresses for my ISP manually before it would work. Find out what your ISP's DNS and gateway addresses are, then manually put them into your connection properties.

46 posts

Geek
+1 received by user: 1


  Reply # 378524 10-Sep-2010 11:34

If you can ping successfully but not surf, definitely a dns issue. On Ubuntu what is in /etc/resolv.conf and is your modem/router picking up the dns address automatically or not.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.