Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




16 posts

Geek


# 78017 25-Feb-2011 19:19
Send private message

G'Day,
I have recently been given a new printer - Canon MP272.  Just tried to get it going under linux and have had no joyFrown

The auto installer under Linux Mint Debian Edition can not find a the correct drivers,

I have searched the web and found a couple of links to the Canon site hosted in Europe.  

       http://software.canon-europe.com/software/0037268.asp


I was thrilled to find a .deb install but when I tried to action I got a nasty error:

       dpkg: error processing cnijfilter-mp270series_3.20-1_i386.deb (--install): 
       package architecture (i386) does not match system (amd64)
       Errors were encountered while processing: cnijfilter-mp270series_3.20-1_i386.deb

So it seems that the driver is only applicable for i386 systems - old skool!

Has anyone else encountered and perhaps even resolved this issue?  Any help you can offer would be greatly appreciated!



 

Create new topic
635 posts

Ultimate Geek


  # 443677 26-Feb-2011 16:17
Send private message

I guess you've found these thread already...

http://ubuntuforums.org/showthread.php?t=1520307
http://www.linuxquestions.org/questions/linux-hardware-18/installing-canon-pixma-520-printer-scanner-on-64-bit-ubuntu-7-10-a-679862/

There are some suggestions that some other drivers e.g. mp220 might work in print only mode (no scanner). Depending on your environment, if all else fails, you might even want to consider setting up another machine as a print server.



16 posts

Geek


  # 443737 26-Feb-2011 21:53
Send private message

HI Alexx,

Thanks for your reply - you have solved my problem!

I had found the Ubuntuforums link but not the Linuxquestions.

I read down Linuxquestions and there was a suggestion from tpehant I had not considered previously when trying to install the 32 bit driver:

    Canon drivers are:
    http://software.canon-europe.com/fil...an_drivers.tar
    Just proceed with dpkg --force-architecture -i files.deb 
    You must also install prior to installing canon drivers:
    sudo apt-get install libgimp2.0

So, I tried the force option after making sure that libgimp was installed already (it was).  The installer complained but went ahead anyway.

    sudo dpkg --force-architecture -i cnijfilter-common_3.20-1_i386.deb 
    dpkg: warning: overriding problem because --force enabled: package architecture (i386) does not match system (amd64)
    Selecting previously deselected package cnijfilter-common.
    Unpacking cnijfilter-common (from cnijfilter-common_3.20-1_i386.deb) ...Setting up cnijfilter-common (3.20-1) ...

    sudo dpkg --force-architecture -i cnijfilter-mp270series_3.20-1_i386.deb 
    dpkg: warning: overriding problem because --force enabled: package architecture (i386) does not match system (amd64)
    Selecting previously deselected package cnijfilter-mp270series.
    Unpacking cnijfilter-mp270series (from cnijfilter-mp270series_3.20-1_i386.deb) ...Setting up cnijfilter-mp270series (3.20-1) ...

Everything looked ok and I checked package setups and all ok there as well.

So, turned on printer and tried to print - it worked!  Tried to scan and print - it worked!  Have not managed to get scan to image to work as yet but that is less important so will continue to look at this.

Thanks again Alexx - you have made my night!

Cheers,
Supersimmo


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Arlo unveils its first video doorbell
Posted 21-Oct-2019 08:27


New Zealand students shortlisted for James Dyson Award
Posted 21-Oct-2019 08:18


Norton LifeLock Launches Norton 360
Posted 21-Oct-2019 08:11


Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18


Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36


MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28


Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15


D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31


Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.