Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




144 posts

Master Geek
+1 received by user: 8


# 138751 15-Jan-2014 15:44
Send private message

I've got a Mikrotik Routerboard hooked up to a (Snap) VDSL connection via a Vigor VDSL router in bridge mode. Overnight my observed speed dropped substantially, and after hunting around for a while I've noticed that the Mikrotik is reporting fairly heavy transmit bandwidth usage (3-5Mbps). The link speed from the Vigor is sill about 26 down/7 up, which I think is quite reasonable and is consistent with what I normally get.

I've gradually unplugged everything on the network side of the Mikrotik without seeing the Tx usage drop. This suggests to me that the Mikrotik is doing something stupid with the connection. Or perhaps someone's compromised the router?

Any thoughts?

Create new topic
1057 posts

Uber Geek
+1 received by user: 214


  # 967627 15-Jan-2014 15:54
Send private message

Have you turned off the bandwidth test server authentication? Try torching the interface facing the Vigor and see what the traffic is (prot/port)




Most problems are the result of previous solutions...

All comment's I make are my own personal opinion and do not in any way, shape or form reflect the views of current or former employers unless specifically stated 



144 posts

Master Geek
+1 received by user: 8


  # 967645 15-Jan-2014 16:17
Send private message

]

This is torch on the interface. Not sure how to get info on the source/dest port?

As far as I can tell the bandwidth test is not configured at all (there's 0.0.0.0 in the "Test to" field.

 
 
 
 


27888 posts

Uber Geek
+1 received by user: 7375

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 967650 15-Jan-2014 16:20
Send private message

What are your firewall rules for the WAN? Is your DNS exposed?

You really need to torch the interface and see what the traffic is and where it's going.



1057 posts

Uber Geek
+1 received by user: 214


  # 967658 15-Jan-2014 16:27
Send private message

lyndondrake: ]


This is torch on the interface. Not sure how to get info on the source/dest port?

As far as I can tell the bandwidth test is not configured at all (there's 0.0.0.0 in the "Test to" field.


You need to tick Port and Protocol




Most problems are the result of previous solutions...

All comment's I make are my own personal opinion and do not in any way, shape or form reflect the views of current or former employers unless specifically stated 



144 posts

Master Geek
+1 received by user: 8


  # 967659 15-Jan-2014 16:29
Send private message

BTW figured out how to use torch - but now whatever was going on seems to have stopped.

Here's my firewall rules - might well need to put some more in there :-)




144 posts

Master Geek
+1 received by user: 8


  # 967747 15-Jan-2014 19:44
Send private message

Having eventually figured out how to use torch I realised I was being used for DNS amplification (is that the right term? spurious DNS requests). I had to add a default drop rule to the pppoe interface as of course the ether1 interface doesn't get a chance to intercept the packets.

27888 posts

Uber Geek
+1 received by user: 7375

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 967793 15-Jan-2014 21:25
Send private message

Hardly surprising it was DNS, it's a massive problem now.

If you have a router that has DNS exposed it's not a matter of when you'll get attacked, it's simply a matter of how much bandwidth the attack will use and how long it'll take to be detected.

Why do you have the forward rules?




 
 
 
 




144 posts

Master Geek
+1 received by user: 8


  # 968179 16-Jan-2014 14:13
Send private message

I've removed the forward rules. At one point I reset the Mikrotik and the rules it put in were different from those I'd had previously.

Thanks for the help — things seem to have calmed down now.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18


E-scooter share scheme launches in Wellington
Posted 17-Jun-2019 12:34


Anyone can broadcast with Kordia Pop Up TV
Posted 13-Jun-2019 10:51


Volvo and Uber present production vehicle ready for self-driving
Posted 13-Jun-2019 10:47


100,000 customers connected to fibre broadband network through Enable
Posted 13-Jun-2019 10:35


5G uptake even faster than expected
Posted 12-Jun-2019 10:01


Xbox showcases 60 anticipated games
Posted 10-Jun-2019 20:24


Trend Micro Turns Public Hotspots into Secure Networks with WiFi Protection for Mobile Devices
Posted 5-Jun-2019 13:24


Bold UK spinoff for beauty software company Flossie
Posted 2-Jun-2019 14:10


Amazon Introduces Echo Show 5
Posted 1-Jun-2019 15:32



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.