Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




93 posts

Master Geek
+1 received by user: 3


Topic # 150591 27-Jul-2014 22:11
Send private message

Hi,

I'm trying to use PPPoE to connect to the internet for my SNAP VDSL connection. I'm using a Draytek DV130 modem. I've deployed this combo many times before, and its always worked successfully, first time around. But this time, the solution eludes me.

I've tried pfSense release 2.1.2, 2.1.3, 2.1.4 No matter what I do, PPPoE won't connect. I've ensured the "Configure null service name" tickbox is checked as this is not required. This combination has worked for every other time that I've deployed this particular setup, but no luck this time.

The pfsense log is relatively unhelpful:

 

Jul 27 17:32:17 	ppp: [wan_link0] Link: reconnection attempt 4 in 1 seconds
Jul 27 17:32:18 ppp: [wan_link0] Link: reconnection attempt 4
Jul 27 17:32:18 ppp: [wan_link0] PPPoE: Connecting to ''
Jul 27 17:32:27 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
Jul 27 17:32:27 ppp: [wan_link0] Link: DOWN event
Jul 27 17:32:27 ppp: [wan_link0] LCP: Down event

 


I've tried hooking up the modem to my desktop computer (win 7) and establishing a PPPoE link that way -- this works -- so the issue is likely to be in the pfsense, but I am stumped as to why this setup works elsewhere but not here.

Anyone here had similar issues?


Filter this topic showing only the reply marked as answer Create new topic
26 posts

Geek
+1 received by user: 2

Subscriber

  Reply # 1096884 28-Jul-2014 09:09
One person supports this post
Send private message

I encountered a similar problem recently when I set up this combo. It turned out - for me at least - that the Draytek Vigor 130 firmware that shipped with the device was faulty and doesn't properly support the PPPOE bridge mode.

I would confirm your Draytek's firmware version with the one listed on http://www.draytek.net.nz/draytek/downloads/ and update if necessary.
As I recall there were two packages, one contained standard presets for passthrough so all I had to do was upload the firmware + configuration presets and it started working straight away. I had already done the appropriate configuration in pfsense.

The passthrough installation guide can also be found at http://downloads.snappernet.co.nz/draytek/dv130/DV130_Bridged_With_VID10.zip if you didn't have it already. (I think it may also contain the fixed firmware also)

Lastly, this is the definitive thread on geekzone for the router. It contains the information I used to fix my issue, and much much more.
http://www.geekzone.co.nz/forums.asp?topicid=128773

Hope this helps.

Edits: embedded links didn't work



93 posts

Master Geek
+1 received by user: 3


  Reply # 1096936 28-Jul-2014 10:11
Send private message

Grr!! That did it! Flashed the firmware supplied by snappernet which is an OLDER version to the one I had and PPPoE works now through pfSense.

 
 
 
 


26 posts

Geek
+1 received by user: 2

Subscriber

  Reply # 1096984 28-Jul-2014 10:46
Send private message

I'm pleased that you got it sorted. It's shame you had to downgrade though.

Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44


New Zealand's IT industry in 2018 and beyond
Posted 22-Jan-2018 12:50


Introducing your new workplace headache: Gen Z
Posted 22-Jan-2018 12:45


Jucy set to introduce electric campervan fleet
Posted 22-Jan-2018 12:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.