Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


378 posts

Ultimate Geek
+1 received by user: 3


Topic # 27491 28-Oct-2008 11:41
Send private message

Hi!

I have a mixed wireless / wired LAN with this configuration.
As you can see. I can "ping" some devices from some points, but not the others.
Both computers access internet OK and the wireless connection is encrypted.

Why can't I ping any device from any computer? Shouldn't it be possible? I believe without achieving that, I will never be able to share files or to use the printer server. Am I right? Or sould I try to get the file sharing working even if the pings are not ok? I cannot ping the PC from the laptop and vice-versa and I feel this is the first step in achieving file sharing.

Not sure about the speed of the wireless connection as I am capped to 65kbps untill the end of the month... you know... but a speed test from laptop or from pc gives the same results so far, I believe it will be ok when speed restriction is lifted.  

If any more details are required, I will provide model numbers and the settings.




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
75 posts

Master Geek


  Reply # 174024 28-Oct-2008 12:02
Send private message

It looks like a problem with your routing configuration.

Are you using the WAN port on the Wireless AP or one of the LAN ports to connect to the wired router? 

I had a similar sort of problem when I first created my network and this was exactly the problem.  Connect Wireless AP LAN to wired router LAN, and disable all routing functions on the wireless AP.  Your wired device has to route, as you are connecting it to two different networks, however the wireless AP doesn't need to route, and it is much simpler if it doesn't.

26922 posts

Uber Geek
+1 received by user: 6358

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 174031 28-Oct-2008 12:25
Send private message

You don't have DHCP enabled on both devices do you? If so it should only be enabled on one device.

75 posts

Master Geek


  Reply # 174033 28-Oct-2008 12:30
Send private message

Good point - I also made that mistake :-/



378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174085 28-Oct-2008 14:57
Send private message

Wow!!

It looks like two things are wrong in my setup:

1] I am using WAN port on AP to connect to the wired router. I was thinking it makes sense that way considering the wired router is modem as well. The wired router is declared as gateway as well

2] DHCP is enabled on both, for any of them to be able to allocate an IP to any device connected to them. It sounds right, but it appears to be wrong. Can the wireless AP allocate IP addresses if DHCP server is not on? I suppose it just passes the request to the wired router?

I will change these settings and post a reply later today.


I am also planning to add a second wireless desktop later. I will have the wireless adapter in a couple of days.
If the AP does not have the DHCP turned on, is it going to identify the two wireless computers?




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


75 posts

Master Geek


  Reply # 174087 28-Oct-2008 15:04
Send private message

If you connect your Wireless AP to the wired router via the WAN port, then by default your network has two subnet segments.  This means you should have seperate subnetting schemes for each, and potentially a DHCP server on each.  If you want it to be one complete network without having to configure all the routes - you use the LAN port on the wireless AP.

A DHCP client looks for a server anywhere that is reachable in the network.  If you only have one subnet, then you are fine.  It does not have to connect directly to the machine running the DHCP server.  Remember - 802.11 (wireless LAN) is a L2 protocol, DHCP is higher (L4or 5?) - you can have established a valid connection to a wireless AP at L2, without already having an IP address.




378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174089 28-Oct-2008 15:19
Send private message

I downloaded several e-books like "Networking for dummies" hoping I will find the answer by reading them... but I got soon discouraged by the amount of reading to be done, in average 500 pages for a book like this...

Each DHCP server requires a segment on the network. That makes sense! It looks like this is the solution!

I was thinking myself: how come the addresses allocated by the two DHCP servers do not generate a conflict? So I tried to play with "IP ranges", trying to make them not to overlap. Pretty stupid, hah? Now it seems so simple. I will see what I get, later in the day.

And maybe this is the solution for the USB server printer as well... I bought this "wireless Ap / server printer" device more than two years ago and I was unable to make the server printer function to work...




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


75 posts

Master Geek


  Reply # 174092 28-Oct-2008 15:27
Send private message

What could be happening, is the IP address looks like one in the same subnet as it meets the IP/subnet criteria of the LAN, so it does not get routed, however the printer is actually sitting on a different subnet, so can't be found.




378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174101 28-Oct-2008 15:40
Send private message

I will do the following steps:

1] I will make the changes we discussed about and see if I can OK results when ping-ing from any computer.
2] add second wireless computer - that should not change anything
3] actually play with the subnet masks to get the printer available, if it does not work by default.

Thanks a lot for help!




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.




378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174218 28-Oct-2008 20:13
Send private message

I did the changes.

Desktop can ping both routers + laptop!
Laptop can ping both routers + desktop.
Internet working OK on both computers.

Bad news: the AP connects itself with 192.168.1.254, which is ok;
The printer server is 192.168.123.254; I cannot change this, there is no interface to access any settings (why didn't they put it on 192.168.1.x as well ???).
Wired router always used sub-mask 255.255.255.0
I changed it to 255.255.0.0 but still cannot ping the print server. Is this the way to go?
Should I be able to ping that address for the print server? I think I should...

How should I set the subnet mask?
Desktop was unable to ping laptop but now is ok, after I changed the laptop subnet mask to 255.255.0.0 (trial and error, and this is how I got it working).




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


6299 posts

Uber Geek
+1 received by user: 288

Trusted
Subscriber

  Reply # 174239 28-Oct-2008 21:17
Send private message

Hi, what brand model is the print server, purhaps it has telnet access to configure.

Cyril

75 posts

Master Geek


  Reply # 174294 29-Oct-2008 08:58
Send private message

All 192.168.X.X adresses are C class, and should have 255.255.255.0 as their subnet mask.  It is called the subnet mask, because it is used as a bitmask in your IP stack to determine the subnet/addressven IP address.  The computer performs an XOR operation between the bitmask and the IP address, and the remainder is your actual address. 

In the case of 255.255.255.0 it is easy, the first 3 octets are your subnet, the last is the address.  Every machine in the network needs to be part of the same subnet.  This means the mask must be the same (255.255.255.0) and the first three octects of the address must be the same (either 192.168.1.X OR 192.168.123.X).

Simple solution, is if you cannot change the IP address of the print server, then re-address everything else to 192.168.123.X with a subnet mask of 255.255.255.0.






378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174340 29-Oct-2008 12:18
Send private message

The wireless router is this one:
http://global.msi.com.tw/index.php?func=proddesc&prod_no=98&maincat_no=131&cat2_no=250&cat3_no=253

The wired modem/router could be this one:
http://www.zyxel.com/web/product_family_detail.php?PC1indexflag=20040812093058&CategoryGroupNo=5B2D5F12-92AD-48B5-9180-B51A3ACED766

I will try to re-address everything to the "192.168.123.x" range and see what happens withn the printer server and file sharing..




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


6299 posts

Uber Geek
+1 received by user: 288

Trusted
Subscriber

  Reply # 174349 29-Oct-2008 13:00
Send private message

ahhh, it was the print server that I was refering to with brand/model. Otherwise as Iain says move the mountain to mohammad.

Cyril

75 posts

Master Geek


  Reply # 174350 29-Oct-2008 13:04
Send private message

I've come across a lot of cheap print servers that don't really let you set anything.  Mine is the same, a lesson learned after picking stuff up in China.



378 posts

Ultimate Geek
+1 received by user: 3


  Reply # 174442 29-Oct-2008 19:33
Send private message

I re-addressed everything to "192.168.123.x" range. The printer server should be 192.168.123.254 as stated in the manual but I cannot ping it from any of the computers. All other pgs are OK and internet sharing works fine.

When accessing the router's settings it shows the printer server "ready" if the printer is off. As soon as I turn the printer "on", it changes from "ready" to "Device Error". But the printer is working ok if connected straight to the computer...

I found a list of compatible printers on the manufacturer's site, and my specific model is not listed. That might explain the error message, but that list is soooo short !!

http://global.msi.com.tw/html/popup/comm_printer_support/rg54gs2.htm

It shows only two models of HP Deskjet... and none is mine.

Anyway... should I be able to ping the printer server?




mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.