Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


3 posts

Wannabe Geek


Topic # 30261 3-Feb-2009 08:22
Send private message

So....any bright ideas please would be greatly appreciated.
Iv got a D-Link G604T wire/ethernet router. It works fine with the cables on mulitiple computers ...however I can only get the wireless to work off my (home) computer. Its set on WPA2 settings with password etc and mine works perfectly however my flatmates (3 of them...who all have new computers) cannot get the wireless to work on theres.
You can see the connection there on there wireless connections, and 1 of them even say it is connected however it wont actually go on the internet, the other 2 computers jsut sit there trying to connect for ages and maybe do connect for a few seconds then disconnect.
I have my internet through ORCON but they dont support D-Link routers....so I rang D-Link who told me that the others need to download a WPA2 upgrade from there computer manufactorer and that would be the only way to get them to work. I didnt think this was right because the others have all previously been able to connect to wireless internet both with and without passwords?
I rang ORCON and a few of the guys there got me to run through a few things like manually putting in an ip address etc, removing the connection and putting it back, repairing the connection etc and still nothing works.
The last thing was manually putting in the IP address and all the stuff that goes in there..gateway etc etc etc
but still nothing.
All they'v suggested now is for me either try this site for ideas or take it back to where i got it from...along with my computer and 1 of my flatemates computer and the stupid router and get the shop to do it which is a complete hassle really.

Im really quite over this and think its stupid that D-Link only spoke with me for about 2 minutes then concluded thats what needed to happen, ORCON guys have actually been great despite them not meant to be helping me actaully spending a good few hours trying to help me out.

Im going to try ring DLink one last time other than that....no idea........
Also tried to turn the WPA2 off...and just have it on WPA but then my computer stopped working as well....

Thanks,
Rowena

Create new topic
6270 posts

Uber Geek
+1 received by user: 281

Trusted
Subscriber

  Reply # 193605 3-Feb-2009 08:41
Send private message

Hi Rowena, welcome to GeekZone, let me guess the computers that dont connect are running Vista?, my guess is that is the case, Vista has issues with connecting via WPK2 although latter upgrades should fix this. To check this is the problem, turn security off and see if they connect there should be no problem with connections with security off. I see you say that nothing works if you turn security off, check you did save settings and reboot the router.

Cyril

1790 posts

Uber Geek
+1 received by user: 126


  Reply # 193614 3-Feb-2009 09:16
Send private message

Rowena,

  Check that the router's wireless access control (MAC addressing) is turned off before your friends try connecting.  Once they have connected, then you can add their Device Name and MAC Address to the list before turning the control back on for extra security.

Ricky.

1874 posts

Uber Geek
+1 received by user: 84

Trusted

  Reply # 193627 3-Feb-2009 09:46
Send private message

I agree with Cryil and rickles, first in your dlinks config page check that mac address filtering isnt turned on, by memory this is under the firewall section on dlink routers. Next i would take it off wpa2 and put on wpa1, ive had great troubles at clients sites with wpa2 and vista, that and it might be incompatible with your flatemates pc's.. After you have set the network to wpa you will need to change some settings on your pc for it to join the new network, in control panel goto the network & sharing centre and then manage wireless network connections, and from there remove your wireless network and then rejoin the network (if you dont do this vista will try and apply the wpa2 key to your now wpa network.. vista is good like that :) ). If your wireless network is called the default dlink then that might be causing issues with your flatmates pcs too, check to see that they havnt already joined a wireless network called dlink (and therefore giving the wrong wpa key). Wireless networks are actually quite simple, there are only a few things that can catch you out.



3 posts

Wannabe Geek


  Reply # 193777 3-Feb-2009 19:45
Send private message

Hey everyone thanks for your ideas........ all the flatmates computers are running on windows xp  but mine runs on vista would this be a problem then? I havent tried the suggestions as one other query...when I did try it turning off WPA2 and jsut having it WPA the internet went crazy and jsut didnt work at all not even with an ethernet cable so couldnt even get back into the d link hpage to reset it which was a headache cos had to ring orcon again and had to manually put in the ip address etc etc etc with there assistance...


sooooo what i need to do is ...
---> first in your dlinks config page check that mac address filtering isnt turned on, by memory this is under the firewall section on dlink routers. Next i would take it off wpa2 and put on wpa1, .. After you have set the network to wpa you will need to change some settings on your pc for it to join the new network, in control panel goto the network & sharing centre and then manage wireless network connections, and from there remove your wireless network and then rejoin the network (if you dont do this vista will try and apply the wpa2 key to your now wpa network.. vista is good like that :) ). If your wireless network is called the default dlink then that might be causing issues with your flatmates pcs too, check to see that they havnt already joined a wireless network called dlink (and therefore giving the wrong wpa key). Wireless networks are actually quite simple, there are only a few things that can catch you out.


and I do this all on MY computer then theres should work- is the reason when i put it onto WPA and then MY internet wouldnt work full stop  becuase i didnt do the stuff in network and sharing centre on MY computer? then to delete my wireless net and rejoin....do i do that on the dlink page or just delete it off the list under wireless connections  on windows then rescan for connections? which should put on the new "FANCY" (thats the name of my connection ...and it'll just be under WPA) but will it still ask for a password because i dont want anyone scamming our internet?


and is the 'security' mentioned the MAC setting i turn off then turn back on once they'v got there internets to work?

im sorry for sounding so stupid but i just really know much about wireless....your instructions are excellent though!



1874 posts

Uber Geek
+1 received by user: 84

Trusted

  Reply # 193789 3-Feb-2009 20:09
Send private message

hmmm i would think about reseting your router, it sounds like there is something funny in there if it wouldnt work on ethernet after changing to wpa.. I dont know why you would have ro re-enter your ip address with orcon? thats strange, leave you computers on dynamic ip address in network settings (not specify ip address). All you should need from orcon is your username and password.

Once setup on wpa you would delete the old fancy wpa2 wireless network from your wireless network list on your computer.. then rejoin the fancy network with your new wpa key..

you dont need mac address filtering on at all, if by chance it is on just turn it off, its more a nusiance then anything else, a good strong wpa key is more than enough :)



3 posts

Wannabe Geek


  Reply # 193880 4-Feb-2009 08:01
Send private message

Well....I dont know. I flicked it onto WPA because I saw some of the other connections they had prev used were just on WPA. so changed it to that then I rebooted the router etc etc etc and couldnt get the internet to go full stop. But is that becuase I didnt delete the old FANCY wpa2 which would have all the old pre-auth stuff you mentioned so in theory once i delete the switch it to WPA, delete old fancy and mak e a new one....it should go (and turn off MAC settings) .  Yes?

Oh yeah with ORCON I tried the normal obtain ip address automatically and that didnt work (which I think is because didnt update to a new fancy) so they got me to manually put in all that stuff and it was fine.

Im kind of hesitant to reset the whole router because to even get the wireless to go on my computer inititally was a huge problem....so I think I'll just try what you said then hope it goes. If not then I guess I'll have to reset it.

1874 posts

Uber Geek
+1 received by user: 84

Trusted

  Reply # 193906 4-Feb-2009 09:52
Send private message

Yes i would say that is the case. Do as i stated earlier and you should be up and running. If you dont want to reset the router thats fine. I would say mac address filtering is actually turned off by default but have a look anyway.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.