Hi all.
Firstly i dont think this is in the wrong forum, as i couldn't find a electronics one, but if i missed it please move to the correct area.

Second this is a bit of a long post, so sorry in advance.


I have a dual LED Strip setup at home which is controlled by an arduino
Previously I have been running it from a Nano, which has worked perfectly, however I wanted to add networking, so I have upgraded to a NodeMCU

One Strip is further away than the other, and I use a Cat5e cable to send both power and data to the LED strips


One of the strips refuses to work, It works fine when I run it from the Nano, but when I swap to the Node, it just doesn't get a signal
(Running the same test rotating color program)

This is where things get odd though

If i swap over the Pins on the Node, or the 3.3 to 5v converters, or any combination, its always the same LED strip that has problems.
But thats not all

I did some basic troubleshooting by connecting a small LED strip directly to the output of the converters, and it worked perfectly fine, but if I put both the cat5 cable and test strip on
It works fine on the closer LED strip, but not on the further away one
(It should at least work on the test strip, even if the proper one is having issues)

So I unplugged the LED strip from the cable, and did a continutity test, and all 3 lines (Pos, Neg and Data) are not linked in any way, tested with the test strip and no signal.
The moment I remove the cat5 from the output it starts working
Even though the other end of that cable is not connected anywhere, 

And it works perfectly fine from a Nano running the exact same code and connections

Any ideas?