Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


eeb41039

59 posts

Master Geek
Inactive user


#21081 15-Apr-2008 13:57
Send private message

Hi All,

I have an OOB 1.1.2 currently running 1.1.4 firmware using iLibertyX for Mac OS X - upgraded to 1.1.4 a few days ago.

My problem is this: when I create a text message, send it to one of my named contacts...all looks good (it's sent when I go to the SMS area of the iPhone and it has the correct name e.g John Smith) Randomly, as in it doesn't happen everytime, if John Smith replies to my original text, it'll come in as a NEW text (not a threaded reply), without his name - instead it'll just ahve the number e.g. +64 27 xxx xxx.

I have Kiwi-ised my phone and addd the pertinent Caller ID and other Vodafone specific fixes but this hasn't changed anything.

Anyone know why this is happening or if there's a fix out there? (this happened on 1.1.3 as well for me)

Create new topic
piksel
129 posts

Master Geek


  #123718 15-Apr-2008 17:01
Send private message

Is it just for this one phone number? Sometimes this can be casued by using a sim import tool. Not sure of the exact cause but have you tried editing the phone number (add a zero or something) on the iPhone, saving and then changing it back and saving??

eeb41039

59 posts

Master Geek
Inactive user


  #123724 15-Apr-2008 17:15
Send private message

Thanks Piksel, I'll try your suggestions but no it's for most numbers in my contacts list

Maybe I'll 'scrub' them all out on my mac, re-create them, then sync them again with my iPhone.
If that doesn't work, then I'll test with creating the contacts directly on my iPhone.

By the way what format do you have NZ cell phone numbers listed in your contacts list? (A mixture of 021 xxx xxx and +64 21 xxx xxx?)

 
 
 
 


piksel
129 posts

Master Geek


  #123732 15-Apr-2008 17:41
Send private message

They are all formatted as +64 xx xxx xxx on my phone. The formatting itself is completely unrelated but i wonder if it has something to do with the missing Intl Code...

The latest build of the PhoneNumber Dynamic Library that the Kiwi-ise Caller ID package uses didn't appear to need any specific settings for NZ. Whereas, in the past, I have had to apply a specific phone number template for NZ for all previous versions. I wonder if this new version does need some customisation after all?

Basically the
PhoneNumber Dynamic Library is what handles the caller id (recognition) of the incoming call or text. So the problem you're having is related to the caller id part of the Kiwi-ise CallerID package (it does more than just caller id :)).

I will have a look at the PhoneNumbersTemplate files again to check the new system they are using. I think, as I said above, that it does need customised setting still.

I imagine I didn't notice the issue because of the way my phone number entries are entered with intl code included... will let you know what I find anyway. And if you could let me know what happens if you add the intl code to those numbers and whether that fixes it.

eeb41039

59 posts

Master Geek
Inactive user


  #123734 15-Apr-2008 17:50
Send private message

Thanks again, I'll try this stuff out tonight (yeah...before Kiwi-ise came along I just manually edited and SFTP-ed all the pertinent files to my phone)

Just got my friend to reply to a text a second ago (error still happening) - her number is formatted as +64 21 xxx xxx in my contact list ARRHGGGHHH!!! Oh well, keep you updated

piksel
129 posts

Master Geek


  #123742 15-Apr-2008 18:20
Send private message

Hmm - are you able to zip up the contents of your /System/Library/Frameworks/AppSupport.framework/ directory and email to me? (Grab my email off the kiwi-ise website).

This will help me find the issue easier.

eeb41039

59 posts

Master Geek
Inactive user


  #123762 15-Apr-2008 18:53
Send private message

Cool - zipping it up now..thanks Piksel..will send it your address soon

eeb41039

59 posts

Master Geek
Inactive user


  #125434 21-Apr-2008 21:18
Send private message

Just an update for anyone interested:

error still happening haphazardly, manually re-entered all my contacts on my macbook and re-imported into the iPhone - nothing changed!
Also, sometimes I'll receive a text named correctly (i.e.john Smith) but it will be a NEW message rather than a threaded reply to my first one

Aw well..no biggie...will keep investigating.

 
 
 
 


djpaubes
394 posts

Ultimate Geek


  #125956 23-Apr-2008 19:39
Send private message

hey I have the same issue.... played around a fair bit and cant fix it. Also some times it doesnt pick up the contact if
I initiate the txt... I used ziphone and have kiwi'ized.

cheers,




Toys:  iphone 4s; PS3 good times.  13inch macbook pro.   ipad 3. ï£¿ 27inch imac.   airport express & time machine. raspberry-pi running xbmc and a gopro try hard.

T: jptocker@twitter
E: jptocker@gmail.com
www.innocle.co.nz

Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.