Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




43 posts

Geek


# 79004 11-Mar-2011 14:53
Send private message

Hi,
I have a DSL G604T WiFi router that works fine - my laptop and other laptops connect fine via WiFi.

The problem is my iPhone consistently connects and reconnects without establishing a clean connection. I see in the WiFi Netwroks screen that the 'tick' to show that WiFi is connected on my phone goes on and off and 2 second intervals.

I can connect to other WiFi networks without difficulty - and other laptops can connect to my WiFi, so I am at a loss on how to fix this.

I have googled a bit but no-one seems to have a solution.

I open this problem then to the NZ IT expert cloud-mind :)

thanks in advance
cheers

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
Minimalist
5596 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  # 447563 11-Mar-2011 15:00
Send private message

Have you done yesterday's update to iOS 4.3? There were bugs with iOS 4.2.1 which have hopefully been fixed in 4.3.



43 posts

Geek


  # 447567 11-Mar-2011 15:02
Send private message

Clicking check for update in itunes tells me I am up to date with 4.2.1 ??

 
 
 
 


Minimalist
5596 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  # 447576 11-Mar-2011 15:12
Send private message

Limerick: Clicking check for update in itunes tells me I am up to date with 4.2.1 ??


Run Apple Software Update first to make sure iTunes is up to date? (10.2) 



43 posts

Geek


  # 447578 11-Mar-2011 15:16
Send private message

Cheers Scott,

Still bizarre though....


Run Apple Software Update tell me iTunes is up to date (its on 10.2.2.1)

2186 posts

Uber Geek

Trusted
Subscriber

  # 447633 11-Mar-2011 17:18
Send private message

Do you have an iPhone 3G? If so, you won't see the update in iTunes as iOS 4.3 doesn't support the 3G.




2018 iPad Pro 12.9 Wi-Fi 64GB (Space Grey) | 2018 iPad mini Wi-Fi 64GB (Space Grey) | iPhone 11 Pro Max 64GB (Midnight Green) | 2x HomePod (Space Grey) | 3x Apple TV 4K | Apple Watch Series 4 44mm (Space Grey)

 

Sony 65" A8F OLED TV | Sony 65" X850F LED TV | Sony 55" X900F LED TV




43 posts

Geek


  # 447635 11-Mar-2011 17:22
Send private message

right - there we go - its a 3G - should've made that clear above.....
so software updates are fine.

2186 posts

Uber Geek

Trusted
Subscriber

  # 447638 11-Mar-2011 17:28
Send private message

Have you reset the network settings on the iPhone?




2018 iPad Pro 12.9 Wi-Fi 64GB (Space Grey) | 2018 iPad mini Wi-Fi 64GB (Space Grey) | iPhone 11 Pro Max 64GB (Midnight Green) | 2x HomePod (Space Grey) | 3x Apple TV 4K | Apple Watch Series 4 44mm (Space Grey)

 

Sony 65" A8F OLED TV | Sony 65" X850F LED TV | Sony 55" X900F LED TV


 
 
 
 


1044 posts

Uber Geek

Trusted

  # 447663 11-Mar-2011 19:14
Send private message

Limerick: Hi, <br />I have a DSL G604T WiFi router that works fine - my laptop and other laptops connect fine via WiFi.<br /><br />The  problem is my iPhone consistently connects and reconnects without  establishing a clean connection. I see in the WiFi Netwroks screen that  the 'tick' to show that WiFi is connected on my phone goes on and off  and 2 second intervals.<br /><br />I can connect to other WiFi networks  without difficulty - and other laptops can connect to my WiFi, so I am  at a loss on how to fix this.<br /><br />I have googled a bit but no-one seems to have a solution.<br /><br />I open this problem then to the NZ IT expert cloud-mind :)<br /><br />thanks in advance<br />cheers


Reset your router to 'g' from 'n'. Usually works.

HTH.

Cheers,
R2D2




Galaxy S has gone to its new owner. HTC Sensation has gone to its new
owner. Galaxy S3 has gone to its new owner. Now using Galaxy Note 3. Skipping Note 4 I think...



43 posts

Geek


  # 447675 11-Mar-2011 20:26
Send private message

thanks

but I'm not sure how to do that?

94 posts

Master Geek


  # 447699 11-Mar-2011 21:47
Send private message

The DSL-G604T doesn't support N, so don't go looking for it.

If it did exist it would be under the DSL-G604T menu: Advanced > Wireless Performance and under Mode.

Go to that menu anyway, and if it's not selected already, select "G Only", click Apply.

Then, go to Tools > System and select Save and Reboot.

Wait until rebooted, revisit the menu listed above and check the setting stuck. The retest from your iPhone.

If there is still a problem, reset your iPhone network settings.

From the iPhone Home Screen, click on "Settings". Go > General > scroll to the bottom >"Reset", then "Reset Network Settings". After accepting the warning > Go Settings -> Wifi, see if you can see your Wifi network, attempt to connect.

The Apple support link for Reset Network Settings is here: http://support.apple.com/kb/ts1398

See what happens.

2645 posts

Uber Geek


  # 447700 11-Mar-2011 21:51
Send private message

I had no end of trouble with my (Telecom supplied) G604T. Wired connections were mostly fine, but wireless connections were very problematic, to both my laptop and phone (a Nokia). This was even true a couple of feet away in the same room.

Replaced the router with a Belkin that I got a good deal on some months ago and all is now fine. Wireless is rock-solid to all devices, and I can easily stream video from the upstairs study to the downstairs living room.

Try a different router - that model is v. old and, in my experience, crappy.

@ArtooDetoo - from memory his model is wireless B/G only, so he can't flick it to n and back again.

1044 posts

Uber Geek

Trusted

  # 447732 12-Mar-2011 06:04
Send private message

Limerick: thanks

but I'm not sure how to do that?


You've had a couple of responses I see, so maybe your question has been answered. I wasn't aware that the router you have has no 'n' functonality, so I'm sorry I put you on the wrong track.

I know from experience that having a mx of 'g' and 'n' devices in my own net has proved unsatisfactory in the past, hence my original reply.

Good luck with finding a solution that works for you.

Cheers,
R2D2




Galaxy S has gone to its new owner. HTC Sensation has gone to its new
owner. Galaxy S3 has gone to its new owner. Now using Galaxy Note 3. Skipping Note 4 I think...

2645 posts

Uber Geek


  # 447915 12-Mar-2011 23:09
Send private message

One reliable way to mix G and N without problems is to go with a dual-mode dual-radio router. Set up two concurrent SSIDs, run the N connections at 5GHz and the G connections at 2.4GHz, and they won't interfere with each other.

I run my video streaming over N at 5GHz, and reserve 2.4GHz for laptop web surfing (using N) and occasional use with my phone (only G capable), which seems to work fine.

94 posts

Master Geek


  # 447949 13-Mar-2011 10:54
Send private message

Once you've set the DSL-G604T mode to "G Only" under Wireless Performance,  saved and rebooted. And once you've reset your iPhone network settings, if things still arn't working check:

Dlink admin menu > Advanced > Wireless Management > look at Mac address filtering. If it's on, turn it off.

Dlink admin menu > Advanced > Wireless Performance > look at Antenna transmit power. Check it is max.

Dlink admin menu > Home > Wireless > If not using WPA security, check the WPA button and under 'PSK String String' enter the secret password all devices connecting on Wifi must know.
Then, Admin > Save & Reboot. Check to be sure the setting stuck. Go key the secret password into your iPhone. Connect.

I recommend the last point above, even if you've done it before.



43 posts

Geek


  # 448156 14-Mar-2011 11:05
Send private message

hi all,
sorry - was offline over the weekend....
thanks for all the help.... really appreciate this.


however, after doing all the suggestions above (bar buying a belkin :).... its now G only, full antenna etc....

it was set to WPA, but reset it to this and put my password as the PSK String - saved and rebooted (it did not at this stage to off)....

but now the phone sees the router it fails to connect after submitting the password... :(


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32


Vodafone 5G service live in four cities
Posted 10-Dec-2019 08:30


Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01


NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00


New Zealand Rugby Selects AWS-Powered Analytics for Deeper Game Insights
Posted 5-Dec-2019 11:33


IMAGR and Farro bring checkout-less supermarket shopping to New Zealand
Posted 5-Dec-2019 09:07


Wellington Airport becomes first 5G connected airport in the country
Posted 3-Dec-2019 08:42


MetService secures Al Jazeera as a new weather client
Posted 28-Nov-2019 09:40


NZ a top 10 connected nation with stage one of ultra-fast broadband roll-out completed
Posted 24-Nov-2019 14:15


Microsoft Translator understands te reo Māori
Posted 22-Nov-2019 08:46


Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.