Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Nyuuji

5 posts

Wannabe Geek


#26191 15-Sep-2008 12:23
Send private message

Hi,

I have installed a Hauppauge Nova-T 500 in order to get terrestial freeview on the pc.
Have also installed Cyberlink PowerDVD 8 Ultra and MediaPortal and relevent Microsoft updates/patches.
Also have latest DirectX 9.0c, NET Framework 2, Visual C++ and Windows Media Player11.
This is all on WinXP SP3.

I managed to scan and find all NZ channels, but cannot view them, and it has certainly got something to do with
the H.264 Video Decoder option being greyed out in MediaPortal configuration. Screenshot here...

http://www.imagef1.net.nz/files/Mediaportal_screenshot.JPG

Have uninstalled and reinstalled PowerDVD, Mediaportal, SQL Server to no effect.

Does anyone have any suggestions I could try to resolve this?

Thanks in Advance,

Nyuuji.

P.S. Forgot to mention the GPU is a Nvidia 9600 GT.

Create new topic
nzkc
891 posts

Ultimate Geek


  #164511 15-Sep-2008 13:33
Send private message

I really don't know if this will make any difference, but have you tried switching to "expert mode".  It's on the top right of your screenshot.

Quidam
291 posts

Ultimate Geek


  #164524 15-Sep-2008 13:56
Send private message

nzkc: I really don't know if this will make any difference, but have you tried switching to "expert mode".  It's on the top right of your screenshot.


Definately worth doing, as it will bring up another important menu item (DirectShow; or something like that).

When selecting that item, the settings for the cyberlink H.264 can then be configured (eg Hardware accelleration on/off).

Having said that, the default values should not cause a blank-screen, and I think the only reason the H.264 codec is greyed out is because Cyberlink's codec is the only one installed on your system.

Can you elaborate on what you mean by "can't view them"?  ie. are you going out of TV Server and into Medfiaportal|My TV and then just get a blank screen?  Also, no audio?

The problem could be that the TV Server's Host Name has not been properly set up.

It is hard for me to be clear on this without the system in front of me, but you need to make sure you have correctly defined the Host name in both TV Server and in Mediaportal.




"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


 
 
 
 


Quidam
291 posts

Ultimate Geek


  #164525 15-Sep-2008 14:09
Send private message

OK, further to my above post:

1) Run TV server config.  Click on TV Servers and note the name of the TV server directly below it (below that should be the Nova T 500 tuners)

2) Run Mediaportal Config and go to Television|TV Client.  Ensure you have entered a hostname = to the name above.





"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


kiwijunglist
2889 posts

Uber Geek


  #164554 15-Sep-2008 16:44
Send private message

It may be best to check that mediaportal tvserver is working properly before trouble shooting problems with mediaportal.

Load Mediaportal TV Server configuration
Select TV Channels
Highlight a TV Channel
Select preview.

Ensure that works first.

Also is the H264 codec also greyed out under the [+] Movies - Player in MP Configuration?




HTPC / Home automation (home assistant) enthusiast.


shacknasty
29 posts

Geek


  #164578 15-Sep-2008 18:35
Send private message

Its usually greyed out unless you have more than one decoder of that type installed. If you install coreavc you will be able to choose between them. 

What I am saying is that the codec or the greyed out option is probably not whats stopping you from watching tv. 

Are you using TV Server? Can you use manual record and play back the recorded files at all?

Mantis
75 posts

Master Geek


  #164598 15-Sep-2008 19:23
Send private message

Hi, from the look of your screenshot the TV client has not been installed.  MediaPortal is using the built in TV support which does not support H264, so the option is greyed out.  You could try installing MediaPortal again and make sure you say you want to watch TV and then HDTV aswell.  You can then scan for channels etc using the TV Server configuration program.  There are good guides on the MediaPortal website on how to install and setup MediaPortal and TVServer.

Nyuuji

5 posts

Wannabe Geek


  #164614 15-Sep-2008 20:31
Send private message

Hi Everone and thank you very your answers.
I've just got home and will try all your suggestions and report back how I faired.

Thanks again.

 
 
 
 


Nyuuji

5 posts

Wannabe Geek


  #164640 15-Sep-2008 21:47
Send private message

Nzkc: I turned on "Expert Mode", then checked in the DirectShow menu that hardware accelleration was on, which it was.

http://www.imagef1.net.nz/files/TV_server.JPG

Quidam: Yes, after exiting TVServer and starting MediaPortal, I get a black box and no audio where there should be viewable tv.
Also had a look at TVServer name, but could not find the "Television|TV Client" option in the MediaPlayer Config.

Kiwijunglist: Tried what you said and after pushing preview, I got a error message "Preview Failed:ChannelNotMappedToAnyCard".
The codecs were not greyed out in movie player options...

http://www.imagef1.net.nz/files/movieplayer.JPG

Shacknasty: cannot record at all.

Mantis: I'll try reinstalling now and see how I go.

The guide I have been following to do allthis is the one from here..
http://cranznz.googlepages.com/newmpguide22
I'll post back soon

Nyuuji

5 posts

Wannabe Geek


  #164648 15-Sep-2008 22:02
Send private message

Have reinstalled Media Portal, but am failing at the login for SQL.

http://www.imagef1.net.nz/files/failed_login.JPG

and second attempt

http://www.imagef1.net.nz/files/login_failed.JPG

I am using password "MediaPortal" as said in the guide from above post.

Quidam
291 posts

Ultimate Geek


  #164653 15-Sep-2008 22:24
Send private message

Yeah, I got that error as well when trying to do a new re-install.

If I remember correctly, I think I used Revo uninstaller to ensure the SQL application was completely uninstalled.  At the very least, check the list of installed programs and make sure all components have been uninstalled prior to doing a new install.

Quite frankly, your best bet might be to go back to a previous "restore point" prior to your first install of TV Server/Mediaportal.

Good luck -if it is any consolation, it is worth the effort once you get it going!




"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


Nyuuji

5 posts

Wannabe Geek


#164703 16-Sep-2008 07:47
Send private message

Right, after uninstalling SQL and mediaportal and deleting all traces of them with Ccleaner, I reinstalled both again.
Then it my Nova TV card disappeared. Would not come up in device manager even after scanning for hardware.
That was late last night and gave up for the time being.

However, after booting up this morning, I got the "Found new hardware" popup from windows, which I closed and used the latest  drivers from Hauppage for my card instead.
After a couple of reboots the Tv card finally showed up in the Tv Server Config.
Scanned for channels, and was able to preview Laughing

Checked all options in Mediaportal config and was away laughing after that.

I'll sort the  EPG out later, I'm just happy to be able to watch TV One on a clear screen without looking like its a snow blizzard.

Thanks everyone for your suggestions!

Quidam
291 posts

Ultimate Geek


  #164707 16-Sep-2008 07:59
Send private message

I love it when a plan comes together.  Let us know if you have any issues setting your epg up.




"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


Dingbatt
4568 posts

Uber Geek

Lifetime subscriber

  #164718 16-Sep-2008 09:01
Send private message

I also had a problem with a disappearing tuner card.  It is only when I do a 'hot' reboot, i.e. hit restart rather than shutdown.  If I use shutdown and then power up the computer the tuner reappears.

This is not a problem with MediaPortal but with Vista and the Hauppauge drivers, as the card disappears from the Device Manager as well.




Areas of Geek interest: Home Theatre, HTPC, Android Tablets & Phones, iProducts.

Create new topic




News »

HP unveils new innovations for businesses adapting to rapidly evolving workstyles and workforces
Posted 17-Sep-2020 15:36


GoPro launches new HERO9 Black camera
Posted 17-Sep-2020 09:45


Telecommunications industry launches new 5G Facts website
Posted 17-Sep-2020 07:56


New Zealand ranks 3rd in world in GSMA index
Posted 15-Sep-2020 10:13


Trend Micro Security Suite adds web monitoring to prevent identity theft
Posted 14-Sep-2020 15:37


NVIDIA to acquire Arm for US$ 40 billion
Posted 14-Sep-2020 12:27


Epson launches its next gen A3+ colour EcoTank multi-function printer
Posted 10-Sep-2020 16:08


Sony launches three new native 4K SXRD home cinema projectors
Posted 9-Sep-2020 18:00


Catalyst Cloud brings Kubernetes-based open-source web hosting solution to market
Posted 9-Sep-2020 17:54


Verizon Connect eyes further growth in New Zealand
Posted 8-Sep-2020 09:26


PNY launches XLR8 gaming NVIDIA GeForce RTX 30 series powered by the all-new NVIDIA Ampere architecture
Posted 3-Sep-2020 16:39


NVIDIA delivers greatest-ever generational leap with GeForce RTX 30 Series GPUs
Posted 3-Sep-2020 16:17


Weta Digital advances visual effects and animation in the cloud with AWS
Posted 2-Sep-2020 17:09


Kiwrious lab-in-the-pocket kit designed for schoolchildren
Posted 28-Aug-2020 09:03


Fitbit introduces Sense, its most advanced health smartwatch
Posted 26-Aug-2020 10:14



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.