Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




6 posts

Wannabe Geek


#115824 8-Apr-2013 15:38
Send private message

For the past week I have been trying to get wamp server fully running on Windows 8 the IPv4/v6 (commonly complained about)  issue I solved no problem (thanks google) but I just can't get the mySQL service to start and so the wamp tray icon remains orange.

I have tried both wamp server 2.2 (with multiple install attempts) and the 2.3 beta.

With each install attempt with both versions all the services started initially (on first launch) no prob but then after either "restarting all services" or shutting down wamp and re-launching results in mySQL refusing to start.

Restarting my machine was also of no help.

Googling around has not provided me any insight as to the cause of the problem or a point to start looking to solve the prob.



Any assistance would be fantastic.

Filter this topic showing only the reply marked as answer Create new topic
1957 posts

Uber Geek


  #795097 8-Apr-2013 15:53
Send private message

I dont know if its the same but I had to reconfigure skype to get it to work
try by exiting skype then try starting




Is an English Man living in New Zealand. Not a writer, an Observer he says. Graham is a seasoned 'traveler" with his sometimes arrogant, but honest opinion on life. He loves the Internet!.

 

gnfb on trademe

Email Me


1767 posts

Uber Geek

Subscriber

  #795099 8-Apr-2013 15:54
Send private message

Anything in the log files for mysql?

 
 
 
 




6 posts

Wannabe Geek


  #795117 8-Apr-2013 16:32
Send private message

@ gnfb1234

I'm not running skype but I believe that that is a common issue with skype and apache both trying to use port 80.

@ itxtme

Below is the log (I only included the 1st error as it just repeats for each time I tried to start mySQL) I looked up the 87 error number and it is 'ERROR_INVALID_PARAMETER' but what parameter I have no idea.

The log:

130408 12:46:27 [Note] Plugin 'FEDERATED' is disabled.
130408 12:46:27 InnoDB: The InnoDB memory heap is disabled
130408 12:46:27 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130408 12:46:27 InnoDB: Compressed tables use zlib 1.2.3
130408 12:46:27 InnoDB: Initializing buffer pool, size = 128.0M
130408 12:46:27 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
130408 12:46:27  InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
130408 12:46:27  InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
130408 12:46:28  InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
130408 12:46:29  InnoDB: Waiting for the background threads to start
130408 12:46:30 InnoDB: 1.1.8 started; log sequence number 0
130408 12:46:30 [Note] Event Scheduler: Loaded 0 events
130408 12:46:30 [Note] wampmysqld: ready for connections.
Version: '5.5.16-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
130408 12:47:19 [Note] wampmysqld: Normal shutdown

130408 12:47:19 [Note] Event Scheduler: Purging the queue. 0 events
130408 12:47:19  InnoDB: Starting shutdown...
130408 12:47:19  InnoDB: Shutdown completed; log sequence number 1595675
130408 12:47:19 [Note] wampmysqld: Shutdown complete

130408 12:47:26 [Note] Plugin 'FEDERATED' is disabled.
130408 12:47:26 InnoDB: The InnoDB memory heap is disabled
130408 12:47:26 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130408 12:47:26 InnoDB: Compressed tables use zlib 1.2.3
130408 12:47:26 InnoDB: Initializing buffer pool, size = 128.0M
130408 12:47:26 InnoDB: Completed initialization of buffer pool
130408 12:47:26 InnoDB: highest supported file format is Barracuda.
130408 12:47:26  InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html
InnoDB: File name .\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.

3344 posts

Uber Geek

Trusted
Vocus

  #795119 8-Apr-2013 16:37
Send private message

Is this a large disk using GPT?

If so maybe check out this bug:

http://bugs.mysql.com/bug.php?id=28913

Seems that setting

innodb_flush_method=normal

in the mysql config might be helpful.



6 posts

Wannabe Geek


  #795128 8-Apr-2013 16:52
Send private message

@ubergeeknz

You are a Genius

Thanks

Seems to fix the prob (I can now access phpMyAdmin at least)

Now I just need to uninstall the 2.3beta and reinstall the stable 2.2 (not willing to develop on the beta) and make sure it works but still again.......... THANKS



6 posts

Wannabe Geek


  #795146 8-Apr-2013 17:31
Send private message

Yup ubergeeknz's fix works



Just as an aside the device I am running it on (Asus TF810C) does not have a large disk (64GB solid state) but does use UEFI instead of Bios.

According to Wikipedia (http://en.wikipedia.org/wiki/GUID_Partition_Table#Windows:_32-bit_versions) 32bit windows doesn't support booting from GPT partitions/drives though it only mentions compatability up to windows 7 (mine is 32bit win8). 

Checking with "DISKPART> LIST DISK" It would seem that my drive is GPT so 32bit support must have been added with windows 8.


Again thanks for the assist in this.



3344 posts

Uber Geek

Trusted
Vocus

  #795212 8-Apr-2013 20:20
Send private message

Guess my google-fu was strong today.  Glad it helped :)

Filter this topic showing only the reply marked as answer Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.