Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Milutiche

157 posts

Master Geek


#197867 15-Jun-2016 19:59
Send private message

Hey all, I've just take the plunge and launched my own website, it's a photoshelter website & i've also purchased a domain name from domains4less.co.nz

 

I am having some trouble getting my domain name assigned to my website, the live chat I've been using with the domains4less crew has been very friendly but I'm not sure they know exactly what they're doing, can anyone help me out? 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
networkn
23479 posts

Uber Geek

Trusted
Lifetime subscriber

  #1574691 15-Jun-2016 20:44
Send private message

Who is hosting the website? PhotoShelter? If so they should have given you an IP address and you need to edit the DNS for your website to point the www and nonwww records to the IP of the server. 

 

 

 

There may be other steps like configuring your host to accept the connection, I am not familiar with PS themselves, but shouldn't be too hard. 

 

 

 

I work in IT consulting, I am happy to have a brief look and give you more specific information. PM me if like.

 

 

 

 


timmmay
16532 posts

Uber Geek

Trusted
Subscriber

  #1574711 15-Jun-2016 21:10
Send private message

Generally you just create an A record pointing at the IP address PhotoShelter gives you. Should be really easy and take a few minutes.


 
 
 
 


gzt

gzt
11677 posts

Uber Geek

Lifetime subscriber

  #1574713 15-Jun-2016 21:17
Send private message

It can take a while for the new record to propagate through the internet.

If you did everything right and it is not working yet, wait longer. ; ).

Milutiche

157 posts

Master Geek


  #1574714 15-Jun-2016 21:18
Send private message

Thanks guys, 

 

 

 

this is my website www.actionimages.net.nz as you can probably see, the main tabs/menus 

 

http://www.actionimages.net.nz/index

 

http://www.actionimages.net.nz/archive

 

http://www.actionimages.net.nz/about

 

http://www.actionimages.net.nz/contact 

 

are all working fine, but If i select a gallery the web address goes back to the photoshelter web address http://actionimagesnld.photoshelter.com/gallery-collection/Hockey/C0000gi7vAQBmejU for example

 

Also if I try to share a link via one of the sharing tabs g+, FB or twitter, it links to the photoshelter address also

 

 

 

 

 

The website is hosted by photoshelter & the domain is hosted by domains4less.co.nz

 

 


timmmay
16532 posts

Uber Geek

Trusted
Subscriber

  #1574716 15-Jun-2016 21:23
Send private message

That's not a dns issue, it's what photo shelter is doing. Could be configuration, could be just how it is.

Milutiche

157 posts

Master Geek


  #1574717 15-Jun-2016 21:23
Send private message

basically this is the setup for the photoshelter side of things https://support.photoshelter.com/hc/en-us/articles/203375130-Overview-Setting-Up-Your-CNAME#goal1

 

I can see that the cname has proporgated via this website https://www.whatsmydns.net/#CNAME/www.actionimages.net.nz 

 

It was working 2 days ago and links were doing their thing but I was having trouble with my email @actionimages.net.nz so I got the help desk to make some changes, it was just after that that my website started going wonky

 

 


Milutiche

157 posts

Master Geek


  #1574719 15-Jun-2016 21:25
Send private message

timmmay: That's not a dns issue, it's what photo shelter is doing. Could be configuration, could be just how it is.

 

 

 

Thanks Timmy, I shared this link http://www.actionimages.net.nz/gallery/Western-Sharks-vs-Waipu-2016/G0000tUCVkn.._hs/C0000AxkNSAFaJY8 on Wednesday (edit: Actually tuesday) evening but as you can see it's not going back to the photoshelter address, I've e-mailed photoshelter but their helpdesk is in New York so I won't hear from them until the morning

 

 


 
 
 
 


gzt

gzt
11677 posts

Uber Geek

Lifetime subscriber

  #1574726 15-Jun-2016 21:53
Send private message

The http address http://actionimages.net.nz does not work as it should. Try it.

Add a record for that, wait, and try again. : ).

Milutiche

157 posts

Master Geek


  #1574727 15-Jun-2016 21:57
Send private message

gzt: The http address http://actionimages.net.nz does not work as it should. Try it.

Add a record for that, wait, and try again. : ).

 

 

 

I'm a bit new to this, do I create a new cname record for actionimages.net.nz ? 

 

 


timmmay
16532 posts

Uber Geek

Trusted
Subscriber

  #1574783 16-Jun-2016 06:56
Send private message

DNS is fine, it's pointing requests at the right server. The issue is the PhotoShelter application is generating the pages with links to the subdomain, not the actual domain. This sounds like something that you could look for in their configuration or raise with support. It may just be the way it is though, with nothing you can do about it.

 

 


gzt

gzt
11677 posts

Uber Geek

Lifetime subscriber

  #1574842 16-Jun-2016 09:06
Send private message

Milutiche:

gzt: The http address http://actionimages.net.nz does not work as it should. Try it.

Add a record for that, wait, and try again. : ).


 


I'm a bit new to this, do I create a new cname record for actionimages.net.nz ? 


 


Oops that was the wrong thing to say. The behaviour shows there is a record for it, but it is wrong in effect. Maybe this is a side effect of something that is needed or maybe there are problems in the dns configuration. Can you paste a list of all your current dns settings?

itxtme
1779 posts

Uber Geek

Subscriber

  #1574875 16-Jun-2016 09:49
Send private message

gzt: 
Oops that was the wrong thing to say. The behaviour shows there is a record for it, but it is wrong in effect. Maybe this is a side effect of something that is needed or maybe there are problems in the dns configuration. Can you paste a list of all your current dns settings?

 

Its a weird thing with that site host he is using.  They dont want you to use A records. They need the domain to be fowarded to the Cname - quite strange.  Also they have this comment on their help page

 

 

 

 

What if my registrar asks for an IP address? Can I use an “A” name/record?

 

You cannot use an A NAME, because an A NAME relies on IP addresses. Our IP addresses are subject to change at any time without notification. For this reason, we strongly recommend using a CNAME instead.

 

 

 

 

And another below maybe will answer the OP's original question as to why it changes back to photoshelter

 

 

I’ve set up my CNAME, but some of my pages still have PhotoShelter in the address bar. Why is that?

 

Any secure pages, such as pages in the cart or even the single image pages in your archive, must revert back to the PhotoShelter-provided URL so that they may be protected by our security certificate (SSL). This does not tend to affect client behavior, and your custom domain can still be used as an entryway to your site.

 

 

 

 

 

In conclusion OP: Get rid of the A record, foward the domain to the cname address, and live with the fact the subdomain of your provider shows up because thats a limitation (or flaw in my opinion) of the service they offer you!

 

 


Amosnz
503 posts

Ultimate Geek

Lifetime subscriber

  #1574889 16-Jun-2016 09:59
Send private message

I use d4l and for my wifes domain (which points to a 3rd party website) we had to setup a url redirection (in the advanced control panel) and enable cloaking so it would always show her domain name in the url (which I think is what you are trying to do).

 

 

 





Speedtest


Milutiche

157 posts

Master Geek


  #1575193 16-Jun-2016 17:52
Send private message

 

 

 

 

 

 

 

 

In conclusion OP: Get rid of the A record, foward the domain to the cname address, and live with the fact the subdomain of your provider shows up because thats a limitation (or flaw in my opinion) of the service they offer you!

 

 

 

 

 

 

Yep I think it is a bit of a flaw, I chose photoshelter after some for a couple of reasons, one being that I know a photographer doing a similar line of me that uses it and he said it works well, secondly the pricing was quite good. This is my first attempt at having my own website so I'm sure i'll learn a lot along the way. 


Milutiche

157 posts

Master Geek


  #1575194 16-Jun-2016 17:54
Send private message

Amosnz:

 

I use d4l and for my wifes domain (which points to a 3rd party website) we had to setup a url redirection (in the advanced control panel) and enable cloaking so it would always show her domain name in the url (which I think is what you are trying to do).

 

 

 

 

 

 

 

Yes that is basically what I want to do, but I also want to be able to share links that look like they are going to my own domain name and not to photoshelter, even if the links were generated to my domain name and then redirected to photoshelter once clicked I'd be a bit happier. 

 

 

 

 


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic





News »

Huawei launches IdeaHub Pro in New Zealand
Posted 27-Oct-2020 16:41


Southland-based IT specialist providing virtual services worldwide
Posted 27-Oct-2020 15:55


NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.