Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


827 posts

Ultimate Geek
+1 received by user: 70

Trusted

Topic # 198678 18-Jul-2016 19:46
Send private message

I have found a couple of apps [snapchat & runkeeper] I wanted to install come up saying '

 

'Your device isn't compatible with this version' 

 

Yet playstore doesn't say there is a minimum android version and runkeeper is installed on another handset with the same Android version. Both handsets are rooted and running Gingerbread 2.3.x [and cannot be upgraded]

 

I get same msg on a Cyanogenmod kitkat handset too. I am now wondering if my google account is corrupt since I use multiple droid versions on multiple devices ?

 

I even downloaded the apks manually using different package managers but when I install those I get the Parsee error... 'There is a problem parsing the package

 

Any ideas other than a new handset 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


Create new topic
1430 posts

Uber Geek
+1 received by user: 495

Trusted

  Reply # 1594719 18-Jul-2016 19:54

Parse error = They're targeting a higher API (Read:Android version) than Gingerbread, so the current version can't install.

 

 

 

Your best bet is to extract the APK file from the handset with an old version that works. Failing that, new phones are definitely in order.





Product Manager @ PB Tech

https://pbtech.co.nz/smartphones


Stu

Hammered
5074 posts

Uber Geek
+1 received by user: 1067

Moderator
Trusted
Lifetime subscriber

  Reply # 1594720 18-Jul-2016 19:55
Send private message

May not be related, but there is something going on with Google Play Services. Having problems with a Galaxy Note 3 that I wiped last week to lend to someone and thanks to whatever is going on with Google Play Services, it's just not playing ball. Many apps say Google Play Services needs to be updated for them to run, but get the "Your device isn't compatible with this version" error. Seems it's a recent issue (last week or so) and is happening all over the show, but certainly to many with the the Note 3 after a factory reset.





Keep calm, and carry on posting.

 

 

 

Click to see full size Click to see full size




827 posts

Ultimate Geek
+1 received by user: 70

Trusted

  Reply # 1594722 18-Jul-2016 20:01
Send private message

Thank you for your prompt replies smile

 

NikT:

 

Parse error = They're targeting a higher API (Read:Android version) than Gingerbread, so the current version can't install.

 

Your best bet is to extract the APK file from the handset with an old version that works. Failing that, new phones are definitely in order.

 

 

I tried older apks for these apps [including copying off a working Gingerbread handset] that should work on Gingerbread yet they also get the Pare error for a manual install

 

Stu:

 

 May not be related, but there is something going on with Google Play Services. Having problems with a Galaxy Note 3 that I wiped last week to lend to someone and thanks to whatever is going on with Google Play Services, it's just not playing ball. Many apps say Google Play Services needs to be updated for them to run, but get the "Your device isn't compatible with this version" error. Seems it's a recent issue (last week or so) and is happening all over the show, but certainly to many with the the Note 3 after a factory reset.

 

 

I too suspect something odd is going on for snapchat not to install on 2.3.x or cyanogenmod kitkat

 

 

 

 

 

 


665 posts

Ultimate Geek
+1 received by user: 98

Subscriber

  Reply # 1594729 18-Jul-2016 20:37
Send private message

I struck this same problem after buying a new Huawei 8" Mediapad running 4.4 just a couple of weeks ago, couldn't install my kids' games like Simpsons Tapped Out despite that game's minimum requirement being 2.3.

 

However for me downloading the APKs from APK mirror worked fine. Does seem to be a Google Play Services problem considering I was well clear of the game's own version requirements.




827 posts

Ultimate Geek
+1 received by user: 70

Trusted

  Reply # 1595112 19-Jul-2016 15:54
Send private message

Fixed - well work around

 

I download ancient versions of the apks 

 

Runkeeper from March 2013 & Snapchat from Jan 2014

 

Manually installed no issues, now it will be interesting to see if playstore updates them to the latest versions for Gingerbread.

 

I suspect playstore client or server app has an issue not allowing some store apps to workout what minimum version is needed when none is specified

 

 

 

 

 

 

 

 


Stu

Hammered
5074 posts

Uber Geek
+1 received by user: 1067

Moderator
Trusted
Lifetime subscriber

  Reply # 1595160 19-Jul-2016 17:14
Send private message

Have just received updates to a bunch of Google apps and Google Play Services. The problem on the Note 3 appears to have been resolved.





Keep calm, and carry on posting.

 

 

 

Click to see full size Click to see full size


257 posts

Ultimate Geek
+1 received by user: 39


  Reply # 1595163 19-Jul-2016 17:22
Send private message

I get the same message as well (app is not compatible with your device) when trying to install some apps as well, does my head in.

 

 

 

I have a Sony Compact Z3 running android 6.0.1.

 

 

 

Dont know what to do.


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.