Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


reapz

15 posts

Geek


#91807 20-Oct-2011 16:54
Send private message

Hi guys, I have an android phone currently running 2.3.4 stock ROM (rooted)

Firstly let me say, I have tried every setting and every combination possible to get this working and I have read all the stickies. The issue is I cannot get Data or MMS to work on Telecom XT network.

Just as a check, I put my 2degrees SIM in the phone, and the android pulled the APN settings down correctly and I could send and receive MMS with no troubles.

When I have my XT sim in the phone, it pulls two APNs (telecomData and telecomMMS) all the settings are correct.

I can send an MMS to myself, it will send ok (a little blue "H" logo shows up in the status bar and I get a message saying data connection to TNZ has been established. The messages arrives in the inbox and when I click download it will either give an error saying message could not be downloaded, or no message at all and just returns the download button.

The same issue for internet, disabling wifi and leaving the 3g data connected I open a browser and get page cannot be displayed.

The same XT sim worked in an old nokia phone for internet and MMS, another 2degrees sim works in the android for internet and MMS.

I am really going crazy here, I deleted all the APNS, and just left the mms, I changed the default APN to have the mms setting, nothing worked. i could always send it but never download it. Have rebooted many times, have factory reset about 3 times.

Would love some ideas!

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
blakamin
4431 posts

Uber Geek
Inactive user


  #535710 20-Oct-2011 17:30
Send private message

How old is the sim? I've seen it mentioned on twitter that this is sometimes an issue (i'm probably wrong tho)

reapz

15 posts

Geek


  #535717 20-Oct-2011 17:41
Send private message

its only about 6 months old

 
 
 
 


mattyjnz
133 posts

Master Geek


  #535772 20-Oct-2011 19:11
Send private message

reapz: Hi guys, I have an android phone currently running 2.3.4 stock ROM (rooted)

Firstly let me say, I have tried every setting and every combination possible to get this working and I have read all the stickies. The issue is I cannot get Data or MMS to work on Telecom XT network.

Just as a check, I put my 2degrees SIM in the phone, and the android pulled the APN settings down correctly and I could send and receive MMS with no troubles.

When I have my XT sim in the phone, it pulls two APNs (telecomData and telecomMMS) all the settings are correct.

I can send an MMS to myself, it will send ok (a little blue "H" logo shows up in the status bar and I get a message saying data connection to TNZ has been established. The messages arrives in the inbox and when I click download it will either give an error saying message could not be downloaded, or no message at all and just returns the download button.

The same issue for internet, disabling wifi and leaving the 3g data connected I open a browser and get page cannot be displayed.

The same XT sim worked in an old nokia phone for internet and MMS, another 2degrees sim works in the android for internet and MMS.

I am really going crazy here, I deleted all the APNS, and just left the mms, I changed the default APN to have the mms setting, nothing worked. i could always send it but never download it. Have rebooted many times, have factory reset about 3 times.

Would love some ideas!


Seems like you are on the right track.
 
Damager did a post about this a while back and noticed that the settings he was using were different to those telecom had set up on a phone in the store....also different to what is posted APN settings sticky.

So all I can suggest is to try this set up if you haven't already, was posted in the Telecom page so you might have missed it in your searching....I use it, works fine, never had any problems.

http://www.geekzone.co.nz/forums.asp?forumid=39&topicid=72732

Cheers






Dinosemur
3 posts

Wannabe Geek


  #535830 20-Oct-2011 21:12
Send private message

great, thanks Cool

reapz

15 posts

Geek


  #535998 21-Oct-2011 10:05
Send private message

Ok so I tried the exact same settings that Damager had. It gave the same result, could send MMS but not receive. I restarted between changes, still no internet access either. I took off PAP and set to none restarted and still no luck with MMS or internet. ulled the sim out, rebooted, turned off put sim back in, still no dice.

The only extra setting I have that no-one else seems to is the option of IP version, IPV4, IPV6 or IPV4/IPV6 I have tried all of them with no change to results but I would assume it should be IPV4

kiwitrc
4123 posts

Uber Geek
Inactive user


  #536018 21-Oct-2011 10:45
Send private message

Is the number you are using ie 021, 022, 027 one that has ever been ported from another carrier? For example if it is say 021 and was originally on Vodafone but has been ported to Telecom, the carriers have to make sure the number is routed to the new carrier.

reapz

15 posts

Geek


  #536026 21-Oct-2011 10:53
Send private message

Thats a good point, but nope, definitely never been ported. this same SIm does work in another Xt phone for sending and receiving.

 
 
 
 


kiwitrc
4123 posts

Uber Geek
Inactive user


  #536035 21-Oct-2011 11:03
Send private message

Sorry missed that bit about it already working in an old Nokia phone.

Linuxluver
5615 posts

Uber Geek

Trusted
Subscriber

  #536123 21-Oct-2011 13:30
Send private message

reapz: Hi guys, I have an android phone currently running 2.3.4 stock ROM (rooted)

Firstly let me say, I have tried every setting and every combination possible to get this working and I have read all the stickies. The issue is I cannot get Data or MMS to work on Telecom XT network.

Just as a check, I put my 2degrees SIM in the phone, and the android pulled the APN settings down correctly and I could send and receive MMS with no troubles.

When I have my XT sim in the phone, it pulls two APNs (telecomData and telecomMMS) all the settings are correct.

I can send an MMS to myself, it will send ok (a little blue "H" logo shows up in the status bar and I get a message saying data connection to TNZ has been established. The messages arrives in the inbox and when I click download it will either give an error saying message could not be downloaded, or no message at all and just returns the download button.

The same issue for internet, disabling wifi and leaving the 3g data connected I open a browser and get page cannot be displayed.

The same XT sim worked in an old nokia phone for internet and MMS, another 2degrees sim works in the android for internet and MMS.

I am really going crazy here, I deleted all the APNS, and just left the mms, I changed the default APN to have the mms setting, nothing worked. i could always send it but never download it. Have rebooted many times, have factory reset about 3 times.

Would love some ideas!


Do any of the APN lines have asterisks / stars in them? They need to be blank if there is no value to be set for them. 

I have used an HTC Sensation, Samsung Galaxy S II and LG Optimus 3D on Telecom XT for MMS and had no problems with any of them if the APNs were really correct (and not just me thinking they were correct - as happened more than once. )  




_____________________________________________________________________
If you order a Tesla, click my referral code below to order your car and get free stuff. 

 

My Tesla referral code: https://ts.la/steve52356


reapz

15 posts

Geek


  #536140 21-Oct-2011 14:27
Send private message

 


Do any of the APN lines have asterisks / stars in them? They need to be blank if there is no value to be set for them. 

I have used an HTC Sensation, Samsung Galaxy S II and LG Optimus 3D on Telecom XT for MMS and had no problems with any of them if the APNs were really correct (and not just me thinking they were correct - as happened more than once. )  


No they are all blank, here is exactly as it is on my phone now for the MMS APN (I also have an internet APN but won't list that here)

name: telecom MMS
APN: wap.telecom.co.nz  (have tried internet.telecom.co.nz)
proxy: <not set>
port: <not set>
username: <not set>
Password: <not set>
server: <not set>
MMSC: Http://lsmmsc.xtra.co.nz
MMS proxy: 210.55.11.73
MMS Port: 80 (have tried 8080)
MCC: 530
MNC: 05
Authentication type: None (have tried pap and chap)
APN Type: mms (have tried default, internet)
APN protocol: IPv4 (have tried (IPv6)

3G data is turned on, Wifi is turned off

with these settings, no internet access, MMS send but won't download.

blakamin
4431 posts

Uber Geek
Inactive user


  #536161 21-Oct-2011 15:08
Send private message

Have you tried leading zeros in the IP

210.055.011.073

? just a thought

kiwitrc
4123 posts

Uber Geek
Inactive user


  #536172 21-Oct-2011 15:35
Send private message

What are your other settings ie these ones
APN Name: TelecomData or TelecomInternet
APN: internet.telecom.co.nz
Proxy:
Port:
Username:
Password:
Server:
MMSC: http://pdaportal.telecom.co.nz
MMS proxy:
MMS port:
MCC: 530
MNC: 05
APN type: default (type this in)

reapz

15 posts

Geek


  #536183 21-Oct-2011 15:57
Send private message

Ok made some progress! I have now got mobile internet working, still no MMS download though. The only two things I changed were:
GPRS transfer mode (changed from data prefer to call prefer) not sure if that made any difference.

and under SIM management, there was no mobile number set for Telecom XT, so I entered my own number, and I believe that is what allowed the internet to start working. (Perhaps it uses the phone number as authentication or something?)

anywho.. that still works after a reset which is good.

I tried padding the ip address in the MMS APN but that hasn't helped, I have noticed that some of the settings make a difference in how it fails, ie sometimes it fails straight away, but with other settings it appears to be downloading (HSPA activity indicator goes for maybe 10 seconds) before it tells me its failed.

anymore suggestions? think we are getting close!



my Internet APN is as follows:

name: Telecom Internet
APN: internet.telecom.co.nz
MCC: 530
MNC: 05
APN Type: default,supl,dun
(everything else not set)

blakamin
4431 posts

Uber Geek
Inactive user


  #536186 21-Oct-2011 15:58
Send private message

just make APN type: default

reapz

15 posts

Geek


  #536189 21-Oct-2011 16:04
Send private message

blakamin: just make APN type: default


Ok, did that, net still works, no mms. tried changing the mms APN to default (instead of "mms", net still works  (weird??) still no mms.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic





News »

Huawei launches IdeaHub Pro in New Zealand
Posted 27-Oct-2020 16:41


Southland-based IT specialist providing virtual services worldwide
Posted 27-Oct-2020 15:55


NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.