Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




32 posts

Geek


# 173733 3-Jun-2015 20:10
Send private message

I recently had Spark fibre installed. Because the ONT had to meet certain location requirements I ended up with my wifi at the other end of the house to where I needed it. Last night, with the help of a friend, I completed an inter-floor Cat-6 cable which has allowed me to move both the Huawei HG630b and my Apple Airport Extreme Base Station to where I want them. Since when I've had an odd issue with IP allocation.

Previously: ONT -> patch lead -> HG630b -> patch lead -> Airport Extreme -> massive distance to devices (Macs)

Now: ONT -> Cat-6 inter-floor -> HG630b -> patch lead -> Airport Extreme -> nice and close to devices

The wifi is turned off on the HG630b.
The Airport Extreme is set to bridge mode (no DHCP) and creates my wifi network.
There is a second, older Airport Extreme (first of the 802.11n models) which is set to "extend wireless network"

None of these devices were reconfigured while commissioning the inter-floor cable. Not that it probably matters, but a cable tester was used on the new cable and reported all OK. I also double checked both Airport devices were NOT running DHCP server function.

So, the problem. Actually now I think about it this first occurred while we were sorting the cable out. My wife's Mac complained its assigned IP address (192.168.1.64) was duplicated on the network. I toggled the wifi off and on and a new address was assigned.

When I was testing the cable, I plugged my MacBook Pro directly into the far end of the new cable, the near end being directly in an HG630b port. I got the same error, also with the .64 address. I had proved the cable was working so I ignored it and removed the cable. Since then my wife's Mac has multiple times made the same complaint. The .64 address is assigned elsewhere, it says.

Tonight I started troubleshooting. A network sniffer tells me that the main Airport has the .64 address and nothing else looks amiss. I forced a lease renewal on the Mac and it got something like .78 allocated. All good. Except a while later – the Mac hadn't even been touched – it came up again with .64 in use! Wut!? Another lease renewal brought me back .64 again this time!

The HG630b is configured to allocate .64 through .253 for DHCP, so I set a fixed address of .63 on the Mac and it could not see the Internet but could access the HG630b admin page. Don't understand that at all.

Next thing I have done is taken .64 out of the DHCP range. I set the range start to .65 and then forced a lease renewal on the Airport and it picked up a new address fine.

So far, the Mac seems to remain happy. But what on earth is going on here? The only thought that crosses my mind, but still wouldn't make sense to me, is whether the ONT has an IP itself and could this be also .64? Surely not.

Create new topic


32 posts

Geek


  # 1316972 3-Jun-2015 20:12
Send private message

Supplementary point. In the process of moving the HG630b and Airport downstairs last night both obviously got a reboot and the problems have persisted after that.

3880 posts

Uber Geek

Trusted
Lifetime subscriber

  # 1317062 3-Jun-2015 21:58
Send private message

Sounds interesting! You've already tried the first few things that came to mind.









Information wants to be free. The Net interprets censorship as damage and routes around it.


 
 
 
 


463 posts

Ultimate Geek


  # 1317117 4-Jun-2015 07:00
Send private message

Are you getting the MAC address of the conflicting device? If so what are the first 6 chars may give a clue as to what it is.

Banana?
4856 posts

Uber Geek

Subscriber

  # 1317181 4-Jun-2015 08:53
Send private message

Can you give the Airport that currently has .64 a set IP address (.2 for example)?

2091 posts

Uber Geek


  # 1317217 4-Jun-2015 09:23
Send private message

And everything in the house is on DHCP - nothing on statics?

18143 posts

Uber Geek

Trusted

  # 1317238 4-Jun-2015 09:53
Send private message

When I went to fibre, I had one instance of the duplicated IP on my rMBP.  Just once. When I changed from the 630b to the 659b, it happened again, I think I reset the DHCP lease, been fine ever since. My setup is similar to yours. I figure that the change from one router to another, mine was a TP-Link W8960N,left an outdated DHCP lease, or the router got confuserated. been fine since. Maybe turn off the router, and turn off all devices (off, not sleep) and power the router up, then the devices so it all gets in sync? 

We have a 659B and an Airport Extreme Base Station, mostly the usual suspects in iDevices, plus a Win 7 and Win 8 laptop.



32 posts

Geek


  # 1317326 4-Jun-2015 11:59
Send private message

hashbrown: Are you getting the MAC address of the conflicting device? If so what are the first 6 chars may give a clue as to what it is.


No. The message I get does not include the MAC address. I did, however, run Fing on my iPhone to sniff out what was on the network and only a single device showed up - the Airport - with the .64 address. Not sure if that would have been able to show two with the same address though.

 
 
 
 




32 posts

Geek


  # 1317327 4-Jun-2015 12:00
Send private message

trig42: Can you give the Airport that currently has .64 a set IP address (.2 for example)?

Hadn't got to that point yet. I did try and fix the problem Mac to .63 but for some reason it wouldn't see outside the network despite happily talking to the router.



32 posts

Geek


  # 1317331 4-Jun-2015 12:03
Send private message

wasabi2k: And everything in the house is on DHCP - nothing on statics?

Not that I could find! It's quite amazing how many devices are on my network though. I checked a bunch of the obvious candidates like my AVR and Apple TV and all are DHCP.

The crazy thing is my previous network config was a 10. network (served by the Airport) so if anything was fixed, it would be outside of the current network anyway. In fact, when I first went to test my new cable I did a control test over a patch cable and took a few minutes to realise I had it fixed to a 10. address over Ethernet (I had been using wifi since the fibre install).



32 posts

Geek


  # 1317336 4-Jun-2015 12:10
Send private message

tdgeek: When I went to fibre, I had one instance of the duplicated IP on my rMBP.  Just once. When I changed from the 630b to the 659b, it happened again, I think I reset the DHCP lease, been fine ever since. My setup is similar to yours. I figure that the change from one router to another, mine was a TP-Link W8960N,left an outdated DHCP lease, or the router got confuserated. been fine since. Maybe turn off the router, and turn off all devices (off, not sleep) and power the router up, then the devices so it all gets in sync? 

We have a 659B and an Airport Extreme Base Station, mostly the usual suspects in iDevices, plus a Win 7 and Win 8 laptop.

That's really interesting. Because my MacBook Pro had exactly one instance of the same error (with .64) as well. So in that sense it is identical to your experience. Just that I have another machine with a chronic case of same.

I wonder if there is something between Macs (perhaps of a certain OS version - both are on Yosemite) and these Huawei routers? And perhaps involving the Airport as well. As best I can tell the Airport had the .64 address from the get go, so why on earth the Huawei would think to offer that to the Mac? And why was the Mac getting a new address when the leases are 1 day long and I had JUST forced it to renew?

Touch wood, the change to .65 as the bottom end of DHCP seems to have cured the problem. There have not been any further occurrences since I changed that last night and forced the Airport onto a new address.

Thanks all for your suggestions.

40 posts

Geek


  # 1324685 15-Jun-2015 04:17
Send private message

I have had this same exact issue with a Macbook Pro and the same Huawei Router. Funny thing is that the issue followed me even when I wasn't connected to the router...I travelled all around Auckland that day connecting to different networks and the issue continued. I just couldn't stop it but eventually I figured it out.

This is how I fixed it.

First I made a script that set the hostname's

Opened the terminal

# nano hostnamefix.sh

Added the following to the file (swinebook1 is what I called my macbook, you call it whatever you want)

scutil --set LocalHostName swinebook1
scutil --set HostName swinebook1
scutil --set ComputerName swinebook1

CTRL+X 
Yes to save
Then

# sudo CHMOD 777 hostnamefix.sh
# sudo ./hostnamefix.sh

Then You need to go into Sharing in Preferences and set your Computer name and then click Edit and make it the same.

Then execute hostnamefix.sh again.   Throughout this you may continue to get plauged by the popup. If this happens then you need to go into network configuration and remove all the Locations so that only "Automatic" exists. Remove ALL the interfaces and then run the hostnamefix.sh again.   If this doesn't work in normal mode - it WILL work in safe mode.

28271 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1324692 15-Jun-2015 07:21
Send private message

My pick would be some sort of L2 bridging issue that's not correctly passing through the MAC address of the end device.

I'd personally invest in cheap hardware (you're only looking at $30 - $40 depending on what option you go for) to VLAN tag the WAN traffic from the Airport so this can be used as the primary router.

My Apple can't move out of the 1990's and offer basically functionality such as VLAN tagging on their routers still amazes me. It's pretty much the default for all MEF networks globally these days.


2 posts

Wannabe Geek


  # 1326863 17-Jun-2015 22:33
Send private message

I have exactly the same setup. I just installed a second AirPort Extreme to extend wifi coverage and initially I tried the extend existing network option and had the same issue with ip addresses. I then changed that to create network, set the ssid to the same as my main network but has the two airports on different channels. Seems like the problem has disappeared, but too early to tell for sure

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Arlo unveils its first video doorbell
Posted 21-Oct-2019 08:27


New Zealand students shortlisted for James Dyson Award
Posted 21-Oct-2019 08:18


Norton LifeLock Launches Norton 360
Posted 21-Oct-2019 08:11


Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18


Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36


MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28


Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15


D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31


Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.