Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Loismustdye

825 posts

Ultimate Geek

Trusted
Subscriber

#143157 4-Apr-2014 21:05
Send private message

I currently have an iPhone 5s.
When sending an iMessage (using wifi or 3G) the phone is supposed to convert the message to a SMS.
When sending a SMS to my wife's iPhone 5 (who has iMessage turned off), she doesn't receive the message. I either have to turn off iMessage or she has to turn it on.
It's the same with my mother who is using an iPhone 4s.
We are all on telecom, anyone have the same issue or know of a fix?
Thanks

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
Affiliate link
 
 
 

Affiliate link: Free kids accounts - trade shares and funds (NZ, US) with Sharesies.
scuwp
3569 posts

Uber Geek


  #1018813 4-Apr-2014 21:32
Send private message

Are you sure you have the "send as SMS if iMessage not available' option selected?

It's under settings > messages, about the 3rd option down






Always be yourself, unless you can be Batman, then always be the Batman



RunningMan
7043 posts

Uber Geek


  #1018878 5-Apr-2014 08:04
Send private message

What do you mean the phone is supposed to convert it to SMS?

If iMessage is on, and it thinks the receiving device is iOS, it will go as iMessage - if it thinks it is not an iOS device, it will go as SMS instead.

You can turn off iMessage on your phone to force all to go as SMS, or tap and hold on an individual message to send that as SMS.

Dairyxox
1590 posts

Uber Geek


  #1018893 5-Apr-2014 09:37
Send private message

I thought the expected behavior was that it first tries to send as iMessage if available, and if that fails it drops to SMS after say 60 seconds of trying.

Do you have the setting enabled that scuwp suggested?



RunningMan
7043 posts

Uber Geek


  #1018908 5-Apr-2014 10:11
Send private message

AFAIK when sending a message to a cell number, it checks with Apple to see if that number is registered to an iOS device, and if so, trys to send as iMessage. If the recipient used to have an iOS device and no longer does, it seems to keep trying to send as iMessage for a couple of weeks before deciding that SMS should be used for that recipient.

scuwp
3569 posts

Uber Geek


  #1018910 5-Apr-2014 10:28
Send private message

RunningMan: AFAIK when sending a message to a cell number, it checks with Apple to see if that number is registered to an iOS device, and if so, trys to send as iMessage. If the recipient used to have an iOS device and no longer does, it seems to keep trying to send as iMessage for a couple of weeks before deciding that SMS should be used for that recipient.


I have never experienced this in the 4 years I have had an iPhone.

If the recipient is not available through iMessage for whatever reason (availability is checked almost instantaneously), then provided the SMS option is enabled as mentioned before then it will immediately opt to send as an SMS through your normal carrier.  Often I will see an iMessage sent to another iPhone start off as blue (indicating an iMessage) a split second later turn green (indicating an SMS).     




Always be yourself, unless you can be Batman, then always be the Batman



Loismustdye

825 posts

Ultimate Geek

Trusted
Subscriber

  #1018919 5-Apr-2014 10:50
Send private message

All settings are correct (send as SMS is turned on on all 3 phones).
My understanding is if it cannot send as an iMessage (in this case the receiving iPhone has it turned off) then it is sent as an SMS, which is what it should be doing to send to my wife's iPhone. It is nt doing this, messages are showing as delivered (in iMessage blue) on my iPhone yet my wife is not receiving them, turning iMessage off on my iPhone and resending does sends the SMS.
If I hold down the SMS on my iphone I can select "send as SMS" my the 3 options that appear (this is with iMessage on), but to me this isn't a fix for the problem.
If imessage is turned off on my iPhone, my mothers 4s (with iMessage turned on) has the same behaviour, it shows as delivered in blue on her phone but I do not receive it.
In both instances iMessage is not available on the receiving phone, and the sending message should be changed to an SMS, but it isn't.

Chrizvi
295 posts

Ultimate Geek


  #1018927 5-Apr-2014 11:15
Send private message

Check your wife contact details on your iphone. It is possible that you are sending imessage to her apple id rather her mobile no. You can check this on the message itself then press contact then info. Whatever the highlighted blue color then that is where you sent you message. I suspect this is your wife apple id which is normally her email address.

Did experinced this with wife and we both debated on why not responding. Hehe



Loismustdye

825 posts

Ultimate Geek

Trusted
Subscriber

  #1018932 5-Apr-2014 11:38
Send private message

Thanks, tried the above and her mobile number is selected as the contact for iMessage.
Think I will have to get both phones in front of me this weekend at some point and have a good ol twiddle with them and see what happens. Does seem an odd problem, wonder if it's some change to the latest ios which has caused it to occur, as prior to now it's never happened :-|

DeroyBoy
248 posts

Master Geek

Trusted

  #1018949 5-Apr-2014 12:35
Send private message

Does your wife also have an iPad or Mac with iMessage turned on?

GSManiac
415 posts

Ultimate Geek


  #1019231 5-Apr-2014 22:30
Send private message

I too had this problem. I fixed it by changing their contact number to either +6427xxxxxx or 027xxxxxxx. Do the opposite of what you have your wife's number stored as. Ie if her number is stored as 027xxx change it to +6427xxx or vice versa.

If that makes sense. Fixed it for me instantly.

Batman
Mad Scientist
27803 posts

Uber Geek

Trusted
Lifetime subscriber

  #1019256 5-Apr-2014 23:19
Send private message

the iphone does not know the receipient imessage is no longer working.

delete the contact, recreate the contact and it will discover there is no imessage and send via sms.




Involuntary autocorrect in operation on mobile device. Apologies in advance.


Batman
Mad Scientist
27803 posts

Uber Geek

Trusted
Lifetime subscriber

  #1019258 5-Apr-2014 23:20
Send private message

or the above. basically they "created a new contact" by changing the prefix




Involuntary autocorrect in operation on mobile device. Apologies in advance.


alasta
5673 posts

Uber Geek

Trusted
Subscriber

  #1019342 6-Apr-2014 08:52
Send private message

Why does your wife have iMessage disabled? I can't think why you'd want to exclusively use SMS, but if that is indeed what she wants to do then maybe she needs to de-register her phone number from her Apple ID?

Loismustdye

825 posts

Ultimate Geek

Trusted
Subscriber

  #1019348 6-Apr-2014 09:03
Send private message

alasta: Why does your wife have iMessage disabled? I can't think why you'd want to exclusively use SMS, but if that is indeed what she wants to do then maybe she needs to de-register her phone number from her Apple ID?



She's tight and would rather use her free texts :-)

Loismustdye

825 posts

Ultimate Geek

Trusted
Subscriber

  #1019350 6-Apr-2014 09:15
Send private message

Will try the other options later this afternoon when she gets back from out of town.
Thanks for the suggestions, will update if I get it sorted. :-)

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic





News and reviews »

D-Link G415 4G Smart Router Review
Posted 27-Jun-2022 17:24


New Zealand Video Game Sales Reaches $540 Million
Posted 26-Jun-2022 14:49


Github Copilot Generally Available to All Developers
Posted 26-Jun-2022 14:37


Logitech G Introduces the New Astro A10 Headset
Posted 26-Jun-2022 14:20


Fitbit introduces Sleep Profiles
Posted 26-Jun-2022 14:11


Synology Introduces FlashStation FS3410
Posted 26-Jun-2022 14:04


Intel Arc A380 Graphics First Available in China
Posted 15-Jun-2022 17:08


JBL Introduces PartyBox Encore Essential Speaker
Posted 15-Jun-2022 17:05


New TVNZ+ streaming brand launches
Posted 13-Jun-2022 08:35


Chromecast With Google TV Review
Posted 10-Jun-2022 17:10


Xbox Gaming on Your Samsung Smart TV No Console Required
Posted 10-Jun-2022 00:01


Xbox Cloud Gaming Now Available in New Zealand
Posted 10-Jun-2022 00:01


HP Envy Inspire 7900e Review
Posted 9-Jun-2022 20:31


Philips Hue Starter Kit Review
Posted 4-Jun-2022 11:10


Sony Expands Its Wireless Speaker X-series Range
Posted 4-Jun-2022 10:25









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.