Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




19 posts

Geek


Topic # 223640 10-Oct-2017 14:29
Send private message quote this post

Hi guys

 

Long time since I've been here but something has stumped me. I cant get remote access to work on plex! I am with 2degrees and have a static ip address and a made my computer an exposed host but plex just never wants to work remotely. Am i doing something wrong or is the isp blocking that port number?

 

 

 

Thanks in advance 
Will


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
6813 posts

Uber Geek
+1 received by user: 3137

Moderator
Trusted
Subscriber

  Reply # 1880359 10-Oct-2017 14:33
Send private message quote this post

Don't make your computer an exposed host ever as it is a massive security risk. You should just be able to have UPnP forward the port automatically if you're using a Fritz!Box.

 

I would say the problem here is Windows Firewall not allowing the Plex app through or your firewall is in public mode.





Michael Murphy | https://murfy.nz
Want to be with an epic ISP? Want $20 to join them too? Well, use this link to sign up to BigPipe!
The Router GuideCommunity UniFi Cloud Controller | Ubiquiti Edgerouter Tutorial




19 posts

Geek


  Reply # 1880363 10-Oct-2017 14:39
Send private message quote this post

Right so i turned that off :P UPnP will not seem to forward the port and yes i do have a FritzBox 7490 and the fritz wont let me forward the port manually (32400) stays greyed out but other ones are green. It will forward other applications just not plex. Plex is allowed through the firewall aswell. Ive tried on a VM (Linux) and same story. Just about to pull out my laptop and try on that.


 
 
 
 


6813 posts

Uber Geek
+1 received by user: 3137

Moderator
Trusted
Subscriber

  Reply # 1880371 10-Oct-2017 14:48
Send private message quote this post

Have you tried another service for example a web server on your VM?





Michael Murphy | https://murfy.nz
Want to be with an epic ISP? Want $20 to join them too? Well, use this link to sign up to BigPipe!
The Router GuideCommunity UniFi Cloud Controller | Ubiquiti Edgerouter Tutorial




19 posts

Geek


  Reply # 1880389 10-Oct-2017 14:52
Send private message quote this post

Yes web servers and FTP RDP all work execpt for Plex. That's why its annoying me.


285 posts

Ultimate Geek
+1 received by user: 8


  Reply # 1880401 10-Oct-2017 15:30
Send private message quote this post

Do you use a VPN - I happily ran Plex through 2Degrees and a fritzbox for quite a while, recently changed my router is all.

 

 

 

A VPN does complicate it a bit, hence the question - and would require a bit more explanation.

 

 

 

If you don't use a VPN on the VM/Server, here's a few parts to check:

 

 

 

1) Plex Media Server correctly configured to use a port of your choosing, lets use 3200 which is the default AND Remote Access is enabled.

 

2) Windows Firewall is configured to allow the same port.. or the application in and out - you can always momentarily disable your Windows Firewall, test, then re-enable .. if it works you know it's the firewall.

 

3) Router - I manually created a port forward for this, so it definitely is possible on the Fritzbox. It's been too long for me to remember exact steps but the Fritzbox usually makes it easy though.. make sure you're in Advanced view though.

 

 

 

If it is VPN, I'll add another comment when time allows!


xpd

8293 posts

Uber Geek
+1 received by user: 1090

Mod Emeritus
Trusted
Subscriber

  Reply # 1880402 10-Oct-2017 15:33
Send private message quote this post

Using default Plex remote settings ? If so, I noticed there seemed to be some bug a few versions back where even though I had enabled the ports etc it wouldnt connect until I manually set the port in Plex - to the same default port. Its worked fine ever since.

 

 





XPD^ / @DemiseNZ / Gavin

 

Internet : Voyager (VDSL)         Mobile : 2Degrees

 

Data Backed up by Backblaze

 

xpd.co.nz


3576 posts

Uber Geek
+1 received by user: 389

Trusted

  Reply # 1880421 10-Oct-2017 15:58
2 people support this post
Send private message quote this post

I use a manual port forward to my machine (have done since using gargoyle on a tp link wr1043nd).  

 

Just make sure for your manual port forward (if a different port) you forward to port 32400 on your plex server port.

 

 





Previously known as psycik

NextPVR/OpenHAB: 
Gigabyte AMD A8 Brix --> Samsung LA46A650D via HDMI, NextPVR,OpenHAB with Aeotech ZWave Controller
Media:Chromecast v2, ATV4, Roku3, Raspberry PI temperature Sensors and Bluetooth LE Sensors,HDHomeRun Dual
Windows 2012 
Host (Plex Server/Crashplan): 2x2TB, 2x3TB, 1x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 1xW2k8, 2xUbuntu 16.04 LTS, Crashplan, NextPVR channel for Plex,NextPVR Metadata Agent and Scanner for Plex


3074 posts

Uber Geek
+1 received by user: 844

Trusted

  Reply # 1881808 11-Oct-2017 10:38
Send private message quote this post

The other day my remote access to plex stopped working for some reason, after years working fine. After some confusion caused by installing a new version on the server, which logged out my account on the server,  then accidentally logging in with a google account (don't think they had the login with google\facebook options when I first did it) whereas my original was just a plex email\password so I ended up with the wrong "account" claiming my server, I finally got things working again by deleting the server on the google account, logging in and claiming the server with the right account, then manually port forwarding as @davidcole suggests above.


4113 posts

Uber Geek
+1 received by user: 627

Moderator
Trusted
Subscriber

  Reply # 1881817 11-Oct-2017 10:51
Send private message quote this post

Remote access only works using HTTPS now IIRC.  You need to make sure your client side is accessing HTTPS and that your server is publishing as HTTPS.  Then just port forward one port from outside to your server (32400 I believe is the default Plex port).  

 

It's all made a lot simpler if you have a Plex Pass subscription.




19 posts

Geek


  Reply # 1881822 11-Oct-2017 11:01
Send private message quote this post

Hey guys

 

 

 

So it turns out it fixed its self overnight and then boom not working again. The ports are still registering as not open. But it works on plex.tv/web and finally went green with out my interaction then failed again. I have plex pass. Do you want me to post my settings from the router and from plex? Just to make sure i have it right?


3576 posts

Uber Geek
+1 received by user: 389

Trusted

  Reply # 1881825 11-Oct-2017 11:03
Send private message quote this post

revolution488:

 

Hey guys

 

 

 

So it turns out it fixed its self overnight and then boom not working again. The ports are still registering as not open. But it works on plex.tv/web and finally went green with out my interaction then failed again. I have plex pass. Do you want me to post my settings from the router and from plex? Just to make sure i have it right?

 

 

 

 

No harm.  Just let us know which machines it's talking to when you post settings.





Previously known as psycik

NextPVR/OpenHAB: 
Gigabyte AMD A8 Brix --> Samsung LA46A650D via HDMI, NextPVR,OpenHAB with Aeotech ZWave Controller
Media:Chromecast v2, ATV4, Roku3, Raspberry PI temperature Sensors and Bluetooth LE Sensors,HDHomeRun Dual
Windows 2012 
Host (Plex Server/Crashplan): 2x2TB, 2x3TB, 1x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 1xW2k8, 2xUbuntu 16.04 LTS, Crashplan, NextPVR channel for Plex,NextPVR Metadata Agent and Scanner for Plex




19 posts

Geek


  Reply # 1881830 11-Oct-2017 11:12
Send private message quote this post

So here are my settings it might look green but there are the port is not open what so ever and the fritz isnt lighting it up green and i cant access it on plex.tv/web at all. Just my desktop over ethernet via fritzbox to ONT to my phone on mobile data.

 

 

 

 

 


412 posts

Ultimate Geek
+1 received by user: 85

Subscriber

  Reply # 1881897 11-Oct-2017 12:04
One person supports this post
Send private message quote this post

Settings should be:

 

Plex > Manually specify public port: 32400

 

Router > Port to device: 32400 to port 32400

 

Router > Port requested externally (IPv4): 32400

 

Or:

 

Plex > Manually specify public port: 50000

 

Router > Port to device: 32400 to port 32400

 

Router > Port requested externally (IPv4): 50000

 

 

 

Edit: @sidefx is correct internal port doesn't change.


3074 posts

Uber Geek
+1 received by user: 844

Trusted

  Reply # 1881902 11-Oct-2017 12:11
One person supports this post
Send private message quote this post

solutionz:

 

 

 

Plex > Manually specify public port: 50000

 

Router > Port to device: 50000 to port 50000

 

Router > Port requested externally (IPv4): 50000

 

 

 

 

Are you sure on that one? I thought I read somewhere when troubleshooting my issues that plex always used 32400 internally so only the external port would be different... maybe wrong though.  I ended up just using the default port both internally and externally and it worked so I didn't bother going further. Some may argue that choosing a non-standard external port is better but meh.




19 posts

Geek


  Reply # 1881904 11-Oct-2017 12:13
Send private message quote this post

Just tried that to no avail both ports port 50000 and port 32400 still fails to connect on mobile or another computer over the internet

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Air New Zealand experiments with blockchain technology
Posted 23-Nov-2017 15:39


Symantec selects Amazon Web Services to deliver cloud security
Posted 23-Nov-2017 10:40


New Zealand Ministry of Education chooses Unisys for cloud-based education resourcing management system
Posted 22-Nov-2017 22:00


Business analytics software powers profits for NZ wine producers
Posted 22-Nov-2017 21:52


Pyrios strikes up alliance with Microsoft integrator UC Logiq
Posted 22-Nov-2017 21:51


The New Zealand IT services ecosystem - it's all digital down here
Posted 22-Nov-2017 21:49


Volvo to supply tens of thousands of autonomous drive compatible cars to Uber
Posted 22-Nov-2017 21:46


From small to medium and beyond: Navigating the ERP battlefield
Posted 21-Nov-2017 21:12


Business owners: ERP software selection starts (and finishes) with you
Posted 21-Nov-2017 21:11


Why I'm not an early adopter
Posted 21-Nov-2017 10:39


Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06


Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30


Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26


UFB killer app: Speed
Posted 17-Nov-2017 17:01


The case for RSS — MacSparky
Posted 13-Nov-2017 14:35



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.