Hi forumites.

I have a 1 TB WD drive in a USB box that was formatted using a Linux-based satellite decoder/recorder (a PVR) and which contains some files I'd like to retrieve, so I don't want to reformat it.  I'm not certain of the exact format the PVR used, but I seem to recall selecting a journaled system, and ext3 or JFS may be possibilities.

I can't mount the drive using my G5 imac under 10.4.11.  I've tried using the "Fuze" extension, but no joy.  I don't have any other computers.

I've just got a new Linux-based PVR which I had hoped would be able to mount the USB drive if I plugged it in, but alas, it hasn't been so simple.

I can telnet to the PVR, and this is what I tried:

root@vuduo / # fdisk -l

Disk /dev/sda: 1000.2 GB, 1000202043392 bytes
255 heads, 63 sectors/track, 121600 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1      121600   976751968+  83  Linux
root@vuduo / # ls /mnt
card/     cf/       hdd@      mmc1/     net/      ram/      realroot/ sda1/     union/    usb/
root@vuduo / # mount /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: Invalid argument


The ID of 83 does suggest that it is some sort of Linux-style partition, so that is promising, I think.

It was suggested that there could be a problem using "sda1" as the name of the mount point, so I tried:


root@vuduo ~ # mkdir /mnt/WD1T
root@vuduo ~ # mount /dev/sda1 /mnt/WD1T
mount: mounting /dev/sda1 on /mnt/WD1T failed: Invalid argument


I don't know exactly what version of Linux is running on the PVR, but it does use "busybox" if that helps.

Any pointers on what to try to get this thing mounted and rescue my files?

Oh - P.S.
I can't use the first PVR to access the files. It was so bug-ridden I returned it to the supplier.