Hi NZ gamers, 

 

 

 

Yesterday i got an update from blackops3 xbox 1 and immediately after that my gameplay completely deteriorated my global KD which was 1.31 went down to 1.16 in just one day ,  tried every thing ,even port forwarding and DMZ as well but no luck  it was working perfectly for last 14 days but suddenly after update every thing ruined. is it due to update i also felt a bit of lag as well although my internet is fibre 30 MB download and 10 upload speed, with ping normally under 100. i usually use berricci , haymaker and kuda and KN44 but all of them are not helping even shot guns which are normally my last resort to pull if every thing is failing but this time even shotguns are no difference too.

 

 

 

no luck , i stopped playing it to save my declining KD and i tried playing the same game on PS3 same network same settings and its working perfect over there with KD of 1.6 overall. that makes me confidence on my gameplay and it felt the culprit is the new update 

 

 

 

does any one else experiencing the same issue. i cannot simply play